Fork me on GitHub


Téléchargements Modules Version 2.5 Textes Xpress


Xpress Populaire 
2012
  • 25
  • mai

Avertissement : ce module est encore en phase de test
Il peut encore contenir quelques bugs mineurs, merci de votre compréhension


Description

Xpress 2.42 en utf8 sans BOM, appelé aussi XpressMe.
Il s'agit du célèbre gestionnaire de blog Wordpress porté sous Xoops, Xpress – alias "WordPress pour Xoops".


Installation

Avant de lancer l'installation du module, faire un CHMOD 777 sur les répertoires :

- cache (celui à la racine du site Xoops, pas celui de de xoops_data)
- modules/xpress/wp-content/
- modules/xpress/templates/

 Date de proposition: 25/05/2012

 Proposé par: Cesag

 Téléchargé 1472 fois

 Note: 0.0 (1 votes)

 Page d'accueil: ICI

 Dossier de langue FR: Inclus

 Version: 2.42

 Taille du fichier: 2574 [Ko]

 Plateforme:  2.5.x

 Langue: Français

 Developpeur: dhsoft

 Licence: GPL

Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Newbie
Inscrit le: 04/03/2003
De: Cambrai
Contributions: 5
natsaka Posté le: 02/12/2011 18:44  Mis à jour: 02/12/2011 18:44
 Re: Xpress 1.07
Effectivement, il est très difficile de comprendre comment installer ce système de blog si la page qui s'affiche est en japonais.
N'y a t-il pas un module équivalent en langue vernaculaire ?

Nat.
Supporter Xoops
Inscrit le: 09/01/2005
De: Breizh
Contributions: 16978
Kris Posté le: 03/12/2011 17:30  Mis à jour: 03/12/2011 17:30
 Re: Xpress 1.07
Les fichiers de langue française sont disponible ici -> http://xoops.svn.sourceforge.net/view ... les/xpress/1.08/?view=tar
Newbie
Inscrit le: 04/03/2003
De: Cambrai
Contributions: 5
natsaka Posté le: 08/12/2011 09:52  Mis à jour: 08/12/2011 09:52
 Re: Xpress 1.07
Merci Kris.
Admin Frxoops
Inscrit le: 16/03/2009
De: Tende (06)
Contributions: 2399
Cesag Posté le: 08/05/2012 22:13  Mis à jour: 08/05/2012 22:13
 Re: Xpress 1.09
Xpress 1.09 FR (nommé aussi XpressMe) compatible Xoops 2.3.3
Régulier
Inscrit le: 26/02/2005
De:
Contributions: 180
nonohadi Posté le: 08/05/2012 22:25  Mis à jour: 08/05/2012 22:31
 Re: Xpress 1.09
Bonsoir cesag
je viens de voir que tu a poste une nouvelle version fr.

faut-il que je désinstallé la version 1.07 du site ou je l’écrase et fait une mise à jour??

Merci
Admin Frxoops
Inscrit le: 16/03/2009
De: Tende (06)
Contributions: 2399
Cesag Posté le: 08/05/2012 23:16  Mis à jour: 31/05/2012 21:44
 Re: Xpress 2.42
Cette version 1.09 n'est compatible qu'avec Xoops 2.3.3. Quelle version de Xoops as-tu?

Je serai portée à te dire d'écraser, mais si tu n'as encore rien fait avec Xpress 1.07 alors oui le plus simple est de désinstaller, vider le cache et mettre Xpress 1.09 à la place.

Sinon deux solutions :

- Tu testes cela en local (Exemple de mise à jour en local - Installer un module sur un serveur local wamp - Aide sur le forum - ou Xoops pré-installé en local)
ou
- Tu attends que je teste et traduise en français la dernière version Xpress 3.0 Alpha1, qui normalement devrait être compatible avec la dernière version de Xoops.

Toujours sauvegarder la base de données de ton site avant (avec le module Backup 3.2 par exemple).


EDIT le 31 Mai 2012 :

Xpress 2.42 utf8 fr

Module de blog incluant le dernier Wordpress 3.3.2

Il m'a donné du fil à retordre. J'ai dû faire pas mal de modifications en plus de la traduction, voilà pourquoi cela a été si long.

Avant de lancer l'installation du module, faire un CHMOD 777 sur les répertoires :

- cache (celui à la racine du site Xoops, pas celui de de xoops_data)
- modules/xpress/wp-content/
- modules/xpress/templates/

Fonctionne avec Xoops 2.5.4 et 2.5.5 (Il est censé fonctionner dès Xoops 2.3 mais je n'ai pas testé).
Régulier
Inscrit le: 27/03/2005
De: Pen ar bed
Contributions: 137
vinyz Posté le: 04/01/2013 11:37  Mis à jour: 04/01/2013 11:38
 Re: Xpress 2.42
Super cette version, mais pourquoi proposer imposer toujours l'utf8 sans BOM ?
Personnellement c'est inexploitable, sachez qu'il y a encore (et il y aura toujours) des sites en ISO, référence du latin. (on se fout de pouvoir afficher les caractères asiatiques sur un site français).
Donc s'il vous plaît, pensez à nous et essayez de proposer des modules dans les 2 encodages les plus courants, soit l'UTF8 et l'ISO.

Merci en tout cas
Admin Frxoops
Inscrit le: 04/03/2011
De: Lot
Contributions: 2191
montuy337513 Posté le: 04/01/2013 13:04  Mis à jour: 04/01/2013 13:04
 Re: Xpress 2.42
On impose l'UTF-8 par choix, francophone ne veux pas dire la France.
1) Pour une meilleur compatibilité entre pays (ou même à l'intérieur d'un même pays, la Belgique a deux langues nationales donc 2 latins, idem pour la Suisse avec 3 langues, le Canada avec deux langues, le Maroc avec deux langues, etc... ). Effectivement pour un français qui possède un site rien que pour les français, il n'y a pas forcement d'utilité a passer a l'UTF-8, tant que sa marche... Mais pour les autres, qui sont quand même la majorité des utilisateurs de Xoops, l'UTF-8 est la solution, pas de soucis quelque soit la provenance du visiteur.

2) A une époque pas si lointaine, les deux versions étaient proposés mais il y avait beaucoup de nouveaux utilisateurs qui ont essayé Xoops sans faire attention a l'encodage, et repartaient déçus a cause des problèmes d'encodage

3) L'ISO est révolu, arrêtez de garder des antiquités pour faire fonctionner vos sites. Depuis PHP 5.3, l'UTF-8 est sélectionné par défaut. Les navigateurs de dernières générations fonctionnent sous UTF-8 par défaut. Vous voulez que votre site s'affiche sans soucis sur les appareils nomades et avec une grande rapidité (les sites en ISO sont convertis en UTF-8 par l'OS, donc s'affiche plus lentement) passez à l'UTF-8.

4) Travaillant dans le référencement sémantique (nouvelle génération de moteur de recherche), les données en UTF-8 sont référencés sans problème, les données en ISO (codés sur un octet par caractères) ne seront pas traités car cela nécessite de posséder une version de robot pas version de ISO et provoque une incompatibilité entre les données (on ne stocke pas des données ISO dans une bibliothèque UTF-8 sans problème avec les caractères accentués)

Pour ma part si tu as des sites en ISO je te recommande vivement de changer d'encodage dans un futur proche. Certains se sont plains lorsque Google a changer de méthode de référencement et ont perdu de l'argent.
Régulier
Inscrit le: 27/03/2005
De: Pen ar bed
Contributions: 137
vinyz Posté le: 04/01/2013 14:44  Mis à jour: 04/01/2013 14:44
 Re: Xpress 2.42
Merci pour cette réponse claire et précise, cependant la conversion UTF-8 d'un site ISO en production est quasi-impossible sans devoir tout remettre en question ou réencoder les fichiers (php/js/html) à la main avec notepad++ (j'fais une tite pub au passage )

J'ai essayé pour technifree, je me suis cassé les dents sans avoir eu de réponse claire. Je conçois que mon site n'est pas une référence en matière de respect des normes, mais je fais partie des premiers site à avoir adopté Xoops (depuis 2005) époque à laquelle l'ISO était de mise.
Aujourd'hui, on me demande de passer en UTF-8 pour pouvoir bénéficier des nouveaux modules ou mises à jour des anciens que j'utilise, je n'ai rien contre, mais je n'ai jamais réussi !!

Je suis passé en 2.5.5 croyant pouvoir justement ne plus devoir me heurter à ce genre de problème, mais je vois que c'est peine perdue. L'ISO affiche l'intégralité du site correctement, à chaque test avec l'encodage UTF (avec ou sans BOM), je me retrouve avec l'ensemble des datas de la base endommagée. Je suis encore entrain de corriger les erreurs (caractères accentués) que j'ai eu lors du passage en Xoops 2.0.18-1, je n'ai pas spécialement envie de réitérer l'opération.

Je sais que tu as raison, je soutiens cette démarche pour les nouveaux sites. Mais QUID de la transition des anciens sites ISO vers l'UTF ? (un peu hors sujet, veuillez m'en excuser ou déplacer le sujet dans le fofo).

Bien amicalement
Admin Frxoops
Inscrit le: 04/03/2011
De: Lot
Contributions: 2191
montuy337513 Posté le: 04/01/2013 16:00  Mis à jour: 04/01/2013 16:00
 Re: Xpress 2.42
C'est vrai qu'une modification d'encodage sur un site est plutôt fastidieux quand on connait peu le sujet.
Je fais beaucoup de migration iso->utf-8 pour des sites en production, il faut changer l'encodage du thème, des fichiers de langues, et surtout des données de la BDD.
J'ai fait un script que tu peux récupérer ici. Il fonctionne avec MySQL en mode MyISAM ou InnoDB, il est facile d'utilisation. Si un jour tu as envie tenter l'aventure de la migration.
Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

27 Personne(s) en ligne (1 Personne(s) connectée(s) sur Téléchargements) | Utilisateur(s): 1 | Invité(s): 26 | alainpe, Plus ...