Fork me on GitHub


 Bas   Précédent   Suivant

(1) 2 3 4 ... 51 »


Re: Problème de smarty Déboguage impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Merci pour votre aide mais je n'ai pas trouvé par contre le problème à empiré.

Maintenant lorsque je clique sur mon menu déroulant il se déroule plus il est bloqué donc j'ai coupé mes extensions toutes la sécurité sur mon navigateur rien n'y a fait.

Alors j'ai installé un autre navigateur (Opéra) pour testé et c'est pareils j'en arrive à la conclusion c'est que chez o2switch ils ne sont pas aussi professionnel que ce qui est annoncé sur leur site.

Car je leur ai envoyé un message leur expliquant mon problème il m’ont répondus qu'il ne pouvait pas m'aider qu'il ne savait pas mais hier soir mon menu fonctionnait aujourd'hui je n'ai rien touché et ce soir je suis retourné sur le site pour chercher une fois de plus mais, vu que le menu ne se déroule plus je me dit que c'est forcément de chez eux que viens le problème c'est pas possible autrement.

Je ne vois pas d'autres explication.

Je suis sous Xoops depuis la version 2.0.13 et la 2.5.10, je ne vais pas me vanter d'être un pro mais je suis pas non plus un navet. Et l'ordi depuis Win 3.1

Peut être c'est les martiens, ou la C.I.A !

Posté le : 15/11 00:18
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Problème de smarty Déboguage impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Aujourd'hui c'est le troisième jours que je cherche donc autant vous dire que j'ai eu le temps d'inspecter le thème et le module et ça ne viens pas de là !

Ce qui est dans mon thème c'est ÇA : <{$xoops_module_header}>

Et ÇA ! ça m'affiche des liens qui proviennent d'un autre fichier LEQUELS ???

Si vous ne savez pas dit le que je demande sur xoops.org ou https://stackoverflow.com/

Posté le : 14/11 09:10
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Problème de smarty Déboguage impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Je n'arrive pas à trouver d'ou viennent les liens que m'affiche <{$xoops_module_header}>

J'ai activé le débogue pour smarty et comme résultat j'ai ceci :
{$xoops_module_header}     <script src="https://www.monsite...


Pas cool les trois petits points car je ne vois pas le fichier j'ai relu mes anciens Post que ma donné Alain mais ça n'as rien changé. J'ai même contacté mon hébergeur il ne peut pas m'aider.

Alors ma question est simple : Dans quels fichiers ce trouve les liens que m'affiche <{$xoops_module_header}>

<script src="https://www.monsite.com/include/xoops.js" type="text/javascript"></script> <link rel="stylesheet" href="https://www.monsite.com/language/french/style.css" type="text/css" /> <link rel="stylesheet" href="https://www.monsite.com/media/font-awesome/css/font-awesome.min.css" type="text/css" /> <link rel="stylesheet" href="https://www.monsite.com/browse.php?modules/xsitemap/assets/css/style.css" type="text/css" /> <base href='https://www.monsite.com/modules/xsitemap/' />


J'ai cherché dans les fichiers du module :

index.php
header.php
xoops_version.php
etc . pas trouvé ???

S.V.P la réponse que je puisse passé à autre chose. Et surtout sauvegarder la réponse dans mon fichier d'aide sur Xoops que je me suis constitué. Merci

Posté le : 13/11 20:14
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Effectivement je connais l'auteur c'est le gars qui est atteint d'Alzheimer. Merci, honte à moi !

Pour le tuto je vous prépare ça, une traduction de Xoops.org avec en prime le code pour ceux qui ne voudront pas le télécharger.

Posté le : 13/11 08:04
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Vous lisez dans mes pensées !?
Pas de problème c'est ok ça va être du vite fait car pour la config Xoops pas grand chose à écrire et comme ils disent sur Xoops.org pour la partie certificat c'est au user de se débrouiller car il y as tellement d'hébergeur mutualisé que l'on peut expliqué. Il faut l'écrire où ?

Et je peut avoir la réponse à ma question sur
<{$xoops_module_header}>
car j'ai un problème sur un module il m'affiche des liens qui ne sont pas à jour & comme pour moi le contenu viens du fichier qui est dans : include/functions.php je ne comprends pas ce qui se passe j'ai vidé le cache etc. Mais rien y fait alors je commence à douter sur la provenance du code. Est-ce le bon fichier ?

C'est avec le module mylinks qui me fait ça sur les autres modules je n'ai pas ce problème.

Posté le : 12/11 18:35
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Merci Mage pour ton lien j'ai ajouté le code dans le mainfile.php ainsi qu'un S à mon url dans le même fichier et tout fonctionne parfaitement bon j'aurais du envoyer 7 Posts pour ça !

Alors qu'un tuto "Comment passer en https://" en Français sur Xoops.France aurais suffit. Non ?

Une dernière question !

<{$xoops_module_header}> appel des liens ils proviennent de quels fichier ?

C'est bien include/functions.php ?






Posté le : 12/11 16:59
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Oui il est visible mais fermé pour cause de travaux ... LOL

Le problème viens de <{$xoops_url}> car lorsque je regarde le code source d'une page toutes les urls des liens du menu sont toujours en http alors que la page en question est en https

Mon navigateur me dit "Des éléments de la page ne sont pas sécurisé ..." normal car les urls des images commence par http et <{$xoops_url}> affiche http:// & non https donc le problème viens de là.

Le code <{$xoops_url}> ne modifie pas les urls.
Et le fichier login ne change rien.


J'ai édité le code avec le débogueur de Mozilla puis ajouté un S sur tout mes liens commençant par http et au miracle ça fonctionne donc c'est sur que ça viens de <{$xoops_url}>

Il ne change pas le http en https

Posté le : 11/11 18:11
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
J'ai testé :
https://monsite.com
https://monsite.com/
https://monsite.com/login.php

bref j'ai testé avec tous un tas de possibilité étant du genre quand je veux un truc j'aime bien l'avoir & puis si les autres y arrive pourquoi pas moi ... LOL

Et j'ai aussi une bonne mémoire et donc je me suis souvenue que j'avais déjà testé y'as bien 2 ans de ça & à l'époque mon certificats était périmé mais celui que j'ai mis est valide à 100% & quand j'ai testé après avoir mis login.php c'est la que la mémoire est revenue et je peut dire que ça ne sert à rien pour preuve le code à mettre dans le .htaccess que tu ma donné il passe directement en https donc la page login.php et le reste ne servent pas à grand chose.

Il me semble qu'un autre user de XoopsFrance à son site en https mais pas chez o2switch ce qui n'est pas grave en soit (je pense). Il faut que je regarde c'est qui pour lui demander sinon je vais créer une page html simple pour voir comment se comporte le https c'est le week-end je devrais avoir un peu plus de temps.

Ça doit être un truc bête qui passe à la trappe des fois c'est sous nos yeux j'avais trouvé un tuto pour débugué l'histoire avec Mozilla le hic c'est que Firebug pour Quantum n'existe plus.

Sinon je viens de trouver ceci : https-everywhere
J'ai essayé, ça fonctionne sur mon site pas sur Xoops France le certificat est périmé !

Donc mon certificat est bon c'est bien dans les urls contenus dans mes pages qui pose problème

Posté le : 08/11 21:16
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Dans le fichier login.php j'ai remplis le path par :

/home/monserveur/public_html

et envoyé le fichier à la racine de mon site

Pour le certificats j'ai suivi pas à pas leur tuto vidéo:
https://www.youtube.com/watch?v=krYdlo7Thik

Mon bootstrap n'est pas BootstrapCDN les fichiers sont sur mon serveur.

Mais l'url qui pointe sur le Bootstrap hébergé sur mon serveur commence par <{$xoops_url}>/media/bootstrap/bootstrap.min.css

Toutes les URLS qui sont dans mon fichier theme.html commence par <{$xoops_url}> qui correspond (affiche) http://www.monsite.com

C'est sur je viens de vérifier en affichant le code source de la page via mon navigateur

Dans mon fichier mainfile.php à la ligne
define('XOOPS_URL', 'http://www.monsite.com');
c'est sans le S je le laisse comme ça ?

Posté le : 07/11 17:36
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer


Re: Tuto pour SSH & SSL sur Cpanel
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Merci je connaissais déjà le lien.

Je viens d'activer le SSL sur mon serveur ça fonctionne mais pas correctement alors encore quelques questions :

Dans Préférences générales de Xoops j'ai Nom de la variable POST SSL là j'ai mis toto_ssl je pense c'est bon ensuite j'ai Adresse URL où se situe la page de connexion SSL il est déjà mis ceci : https://

Est ce bon ou dois je compléter si oui comment ?

Pour être plus précis lorsque je me connecte via https dans mon navigateur le cadenas est gris avec un triangle jaune qui me dis que la connections n'est pas sécurisée des éléments tels que des images ne sont pas sécurisé.

Apparemment il ne charge pas Bootstrap ni les icônes de Font Awesome pourtant ils sont sur mon serveur je n'ai pas mis d'url distante je ne les charges pas depuis leur site.

D'après le support de Mozilla c'est du à du contenu mixte blabla ... pas d'exemple concret. Help me please !


Posté le : 07/11 12:42
_________________
Version Xoops
2.5.10
Transférer la contribution vers d'autres applications Transférer



 Haut
(1) 2 3 4 ... 51 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

58 Personne(s) en ligne (43 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 58 | Plus ...