Fork me on GitHub




« 1 2 (3) 4 5 »


Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3135
Tu fais ces essais en local ou sur un serveur web ?
Je viens d'ajouter XoopsTube sur mon Xoops 2.5.6 de test sur mon serveur dédié et je n'ai pas de problème pourtant.

Posté le : 18/06/2013 10:53

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2610
Peut être lié a ta configuration de PHP !

- première chose à faire dans le fichier header.php du module:

Après la ligne
include_once '../../mainfile.php';


Coller ces lignes
error_reporting (E_ALL E_STRICT);
ini_set('display_errors'true);
ini_set('html_errors'false);
ini_set('display_startup_errors',true);
ini_set('log_errors'false);
ini_set('error_prepend_string','<span="color: red;">');
ini_set('error_append_string','<br /></span>');
ini_set('ignore_repeated_errors'true);


Puis lancer le script et relever les erreurs PHP (Avec ce script tu as au moins toute les erreurs).

- seconde chose à faire :
dans le header.php du module tu as une ligne de ce genre
include_once XOOPS_ROOT_PATH '/modules/' $mydirname '/class/myts_extended.php';


remplace cette ligne par :

require_once XOOPS_ROOT_PATH '/modules/' $mydirname '/class/myts_extended.php';

De cette façon, tu pourras voir si le fichier est chargé (si un fichier appelé par 'require' n'est pas trouvé alors le script s'arrête avec une FATAL_ERROR, contrairement à include qui continu comme si rien ne s'était passé).


EDIT Cesag : correction du code.

Posté le : 18/06/2013 11:52
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Régulier
Inscrit: 07/09/2006 11:23
De So So Far
Messages: 478
Bonjour montuy337513,

Est ce normal que le scripte
ini_set('error_append_string','<br /></span>')


il y a pas a la fin le ";" ?

Sinon, je l'ai ajouté naturellement, procèdant LA PREMIÈRE CHOSE + LA SECONDE CHOSE et j'ai toujours les mêmes messages précédents, saut ils s'affichent cette fois-ci sans activer le mode debug dans l'admin.

Pas d'autre message d'erreur.

@Cesag: Je fais sur le serveur mutualisé, et sur 3 à 5jours, ce sera dans un serveur dédié.

Cdt.




Posté le : 18/06/2013 12:45

Un rêve se réalise quand on tente à  le faire
[Monde de plaisir]:[Magazine enligne] - [Troupe Théâtre]
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2610
Autant pour moi j'ai oublié un ;

Toujours dans le fichier header.php

ajoute cette ligne

echo XOOPS_ROOT_PATH '/modules/' $mydirname '/class/myts_extended.php';

avant le fameux include_once de tout a l'heure

cela va t'afficher une ligne quelque part, c'est histoire de vérifier la configuration de la génération des URL avec 'basename'.

Posté le : 18/06/2013 13:34
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Régulier
Inscrit: 07/09/2006 11:23
De So So Far
Messages: 478
Voici, ce qu'il s'est affiché :

/homepages/8/d145552240/htdocs/monsiteweb_root/modules/xoopstube/class/myts_extended.php Fatal errorCall to undefined method MyTextSanitizer::htmlSpecialCharsStrip() in /homepages/8/d145552240/htdocs/monsiteweb_root/modules/xoopstube/index.php on line 24

None All Errors 
(0Deprecated (2Queries (74Blocks (17Extra (12Timers(5)

à la page index.php

C'est comme avant, sauf qu'il a ajouté l'url en plus :
/homepages/8/d145552240/htdocs/monsiteweb_root/modules/xoopstube/class/myts_extended.php

Posté le : 18/06/2013 15:01

Un rêve se réalise quand on tente à  le faire
[Monde de plaisir]:[Magazine enligne] - [Troupe Théâtre]
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2610
ne reste plus qu'un conflit entre module, je ne vois que ça, désactive tous les blocs (sauf ceux du système) provenant des modules que tu as rajouté

Posté le : 18/06/2013 15:04
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Régulier
Inscrit: 07/09/2006 11:23
De So So Far
Messages: 478
Je désactive les blocs d'autres modules, ok, mais ... toujours les mêmes !!!

Rien ne fonctionne en interface client ...

Posté le : 18/06/2013 16:35

Un rêve se réalise quand on tente à  le faire
[Monde de plaisir]:[Magazine enligne] - [Troupe Théâtre]
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Régulier
Inscrit: 07/09/2006 11:23
De So So Far
Messages: 478
Ptit Up ...

Posté le : 20/06/2013 09:51

Un rêve se réalise quand on tente à  le faire
[Monde de plaisir]:[Magazine enligne] - [Troupe Théâtre]
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2610
Peux-tu me faire la liste détaillée des modules installés ainsi que leur version ?

Posté le : 20/06/2013 10:29
Partager Twitter Partagez cette article sur GG+
Re: Des belles pages blanches de Xoopstube après MàJ vers 2.5.6
Régulier
Inscrit: 07/09/2006 11:23
De So So Far
Messages: 478
Bonjour,
Désolé pour la réponse tardive pour cause d'un voyage.

Les modules installés dans Xoops et leur version:

System: 2.5.6
Protector: 3.51
RCCommon Utilities: 2.1.8.91 RC
Myworks: 2.1.2.6
xform: 1.2
Gallerie: 3.0.03
Newbb: 3.08
xTheme: 1.0.22

Merci pour votre aide.

Posté le : 27/06/2013 12:08

Un rêve se réalise quand on tente à  le faire
[Monde de plaisir]:[Magazine enligne] - [Troupe Théâtre]
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 2 (3) 4 5 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

53 Personne(s) en ligne (48 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 53 | Plus ...