Fork me on GitHub




« 1 2 (3)


Re: Potentielle mise à jour vers 2.5.6
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 247
Bonjour,

J'ai un problème avec l'éditeur (de base pourtant) dhtmltextaera dont je ne trouve pas la solution dans le forum. Lors de la rédaction d'un message (PM ou forum par exemple), la prévisualistation ne fonctionne pas et j'ai ce message :

Direct access is not allowed!!!

Pas d'erreur en debug.

Curieusement j'ai le message "Click the Prévisualiser to see the content in action." en partie en anglais.

(J'ai bien vidé les dossiers de cache et mis à jour les modules plusieurs fois). J'ai également renvoyé aussi les fichiers du dossier class/xoopseditor/dhtmltextarea de l'archive xoops_2.5.6_fr_utf8_30042013
Une piste ?

Merci à vous.

Posté le : 26/08/2013 19:32

Open in new window
17 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3138
Je pense que tu n'as pas vidé les caches correctement.
Depuis les dernières versions de Xoops, "vider les caches" c'est ça :

Open in new window

Posté le : 27/08/2013 09:57

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 247
Si si je l'ai bien fait, et même vérifié dans les dossiers que la maintenance était bien faite. ça ne change rien.

Posté le : 27/08/2013 11:47

Open in new window
17 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 247
En cherchant dans les fichiers, il semble que ce message d'erreur se trouve dans le fichier include/formdhtmltextarea_preview.php

ligne 27 :

if (!$GLOBALS['xoopsSecurity']->validateToken(@$_POST['token'], false)) {
    
$content 'Direct access is not allowed!!!';
}


Si ça peut aider à la compréhension du problème.
Et je n'ai pas d'erreur de prévisualisation avec textarea ou tinymce...

Posté le : 27/08/2013 12:11

Open in new window
17 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 247
Pour le message en anglais, facile, c'est juste une traduction manquante dans le fichier language/french/formdhtmltextarea.php

Ligne 79, remplacer

define('_XOOPS_FORM_PREVIEW_CONTENT','Click the <strong>' _PREVIEW '</strong> to see the content in action.');

par
define('_XOOPS_FORM_PREVIEW_CONTENT','Cliquez sur <strong>' _PREVIEW '</strong> pour afficher le contenu.');


Pour mon problème de prévisualisation, je m’aperçois que je n'ai pas de soucis sous Chrome, mais uniquement avec mon firefox (23.0.1). Je continue mes recherches.

Posté le : 28/08/2013 12:12

Open in new window
17 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3138
Citation :
escrime-info a écrit :
Pour le message en anglais, facile, c'est juste une traduction manquante dans le fichier language/french/formdhtmltextarea.php

Ligne 79


Je te remercie, je n'avais pas vu ce "define" non traduit

Je vais le corriger sur le sourceforge de Xoops France.

Posté le : 28/08/2013 12:55

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3138
Citation :
escrime-info a écrit :
En cherchant dans les fichiers, il semble que ce message d'erreur se trouve dans le fichier include/formdhtmltextarea_preview.php

ligne 27 :

if (!$GLOBALS['xoopsSecurity']->validateToken(@$_POST['token'], false)) {
    
$content 'Direct access is not allowed!!!';
}


Si ça peut aider à la compréhension du problème.
Et je n'ai pas d'erreur de prévisualisation avec textarea ou tinymce...




Je vais voir si on peut trouver d'où ça vient, si un développeur est disponible.

Posté le : 30/08/2013 11:56

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Potentielle mise à jour vers 2.5.6
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 247
Citation :
Cesag a écrit :
Je vais voir si on peut trouver d'où ça vient, si un développeur est disponible.

Mon problème à disparu, donc ce n'est peut-être pas utile de leur soumettre un problème difficile à reproduire.
Difficile de savoir pourquoi. Je pense que de vider le cache de mon navigateur à tout résolu. Temps que je suis le seul à rencontrer le problème...
Merci quand même !!!

Posté le : 31/08/2013 14:51

Open in new window
17 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 2 (3)




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

56 Personne(s) en ligne (47 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 56 | Plus ...