Fork me on GitHub




(1) 2 3 4 ... 31 »


EXTCAL version 2.26 / 2.32
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 1988
Bonjour
----------------------
J'ai repris le module extcal, en y apportant quelques arrangements:

- Ajout de la sélection des onglets à afficher dans les options du module.
- Correction du lien sur le mini calendrier.
Affiche maintenant la vue 'stat_page' paramétrée dans les options.
La vue 'start_page' doit être visible.
- Ajout d'un vue agenda jour sous forme de grille : affiche 1 ou plusieurs journées avec des tranches horaires.
Les événements sont affiché avec un carre coloré avec son titre.
- Ajout d'un vue agenda semaine sous forme de grille : affiche 1 ou plusieurs journées avec des tranches horaires.
Les événements sont affiché avec un carre.
Le titre et les heures de début et de fin sont affiché dans l'info-bulle au survol de la souris.
Permet d'avoir une vue synthétique de la semaine ou la quinzaine par exemple.
- Ajouts des options de paramétrages pour les deux vues 'agenda'
* heures de début de la journée
* heur de fin de la journée
* Nombre de minutes par tranche
* Nb de jours pour chacune des deux vues agenda.
- Renommage de toutes les fichiers php et template de vues avec ajout du préfixe 'view'
pour faciliter la maintenance;
- remplacement du tableau '$lang' dans les template par l'équivalent '$smarty;const'
- Modification des fonctions _getEventWeekCriteria et getEventWeek.
ajout du paramètres $nbJours pour récupérer les événements sur une plage
autre que 7 jours; '$nbjours' doit être > 0; attention à l'affichage de plus de 20 jours
dans l'agenda semaine peut ne pas être pratique.
Ce sont les deux paramètres ajoutés dans les options du module;
- Ajout du fichier 'agenda_fnc.php' qui contient les fonctions de création des tableaux
pour alimenter les agenda;
- remplacement du remplissage des liste de sélection des années, moi, jours et catégories,
par des fonctions génériques.
- remplacement des codes pour la sélection des vues par des constantes (fichier 'constantes.php')
- Ajouts des options 'agenda_nb_years_before' et 'agenda_nb_years_after'
pour le remplissage des listes déroulantes de sélection des années.
Permet de limiter les années antérieures par exemple.


Téléchargement :
Sur le SVN
ou
xoops.kiolo.fr


IMPORTANT : procédure d'installation:
A partir de la version 2.25, des fichiers ont été renommés, ajoutés ou supprimés.
Le modèle de données n'a pas été modifie.
Pour mettre a jour le module:

- Ne pas désinstaller le module pour ne pas perdre les données actuelles (sauf si vous voulez réinitialiser les données))
- Supprimer complétement le dossier 'extcal' du répertoire 'modules'
- Copier le dossier extcal version 2.25 ou plus dans le répertoire 'modules'
- Mettre à jour le modules extcal dans les options de xoops.
- N'oubliez pas de paramétrer les nouvelles options dans les préférences du module.

-------------------------------------------------------------
pour une première installation:
Installer le module selon la procédure standard de xoops;

Merci de vos retour
JJDAI

Posté le : 07/08/2011 11:38

Edité par Grom sur 30/10/2011 21:20:18
Edité par Cesag sur 02/09/2013 14:15:21

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Mouvement Français des Plieurs de Papier
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 1988
re bonjour
----------------------------
Pour les constantes de langue je suis preneur des corrections et traductions pour l'espagnol et l'anglais.
dans les ces fichiers j'ai complété, mais avec les versions françaises.

JJDAI

Posté le : 07/08/2011 12:19

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Mouvement Français des Plieurs de Papier
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Régulier
Inscrit: 28/04/2011 11:03
Messages: 191
Super merci beaucoup.

J'ai installé la nouvelle version sans aucun problème mais quand je clics sur le module, j'ai un message me disant qu'il manque le Frameworks.

Ou puis-je le télécharger ? Merci

Posté le : 07/08/2011 12:32
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Team FrXoops
Inscrit: 07/08/2006 13:03
Messages: 1717
Bonjour jjdai,
Je suis tes travaux avec assiduité, depuis que tu a décidé d'améliorer ce module. C'est une excellente nouvelle pour toute la communauté, je sais que nombre d'entre nous l'utilise.
Tout d'abord, merci d'avance pour ce temps passé.
ensuite, penses-tu que cette nouvelle mouture est compatible avec un xoops 2.4.5 ?
Quoiqu'il en soit, je te tiendrais au courant des que je l'aurais testé.
Bon dimanche à toi.

Posté le : 07/08/2011 12:46
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 1988
au temps pour moi j'ai complétement oublié d préciser qu'il fallait installé le framework moduleadmin qui devrait être intégré dans x3 ce pourquoi je n'ai pas intégré ce frammework dans le package.

Une fois téelecharge pour faire court il suffit de copier le dosier 'moduleadmin' ans le dossier '/Frameworks/moduleclasses/' du site.

voici les liens pour le module admin


frmamwork moduleadmin signalé ICI


et le lien direct : ICI

JJDAI

Posté le : 07/08/2011 12:53

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Mouvement Français des Plieurs de Papier
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 1988
Grom
Citation :
penses-tu que cette nouvelle mouture est compatible avec un xoops 2.4.5 ?
Quoiqu'il en soit, je te tiendrais au courant des que je l'aurais testé.
Bon dimanche à toi.


a priori elle devrait être compatible.
Mais je vais quand même vérifié, des que j'aurais retrouvé cette version dans mes archives.

JJDAI

Posté le : 07/08/2011 13:01

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Mouvement Français des Plieurs de Papier
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Supporter Xoops
Inscrit: 09/01/2005 13:37
De Breizh
Messages: 16972
Citation :
JJDai a écrit :
...le framework moduleadmin qui devrait être intégré dans x3 ...

Il n'est pas prévu d'être dans la x3, et pour la prochaine 2.5.2 la discussion sur son intégration est loin d'être close

Posté le : 07/08/2011 20:13

La connaissance s'accroît quand on la partage ...
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 1988
Au temps pour moi Kris, il m'avait semblé, mais bon pas grave l'essentiel est que ça fonctionne .
JJDAI

Posté le : 07/08/2011 20:38

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Mouvement Français des Plieurs de Papier
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Régulier
Inscrit: 28/04/2011 11:03
Messages: 191
J'ai 2 problèmes avec le module.

1. Les événements avant la mise à jour sont mis en attente d’approbation et rien n'indique où valider ces événements.

2. J'ai autorisé les utilisateurs à voir les événements mais ils n'y ont pas accès.

Open in new window


Sur la photo, on peut lire aussi qu'il faut au minimum la version xoops 2.5.0.

Posté le : 07/08/2011 20:42
Partager Twitter Partagez cette article sur GG+
Re: EXTCAL version 2.26
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 1988
Bonsoir
Je regarde ça
JJDai

Posté le : 07/08/2011 22:14

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Mouvement Français des Plieurs de Papier
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
(1) 2 3 4 ... 31 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

47 Personne(s) en ligne (40 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 47 | Plus ...