Fork me on GitHub




(1) 2 3 4 ... 6 »


xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
Salut à tous

je voudrais ajouter des éditeurs mais je ne trouve pas le fichier xoops_version.php dans /class/xoopseditor. Est-ce le bon fichier pour faire les modifications, sinon où se trouve-t'il ?

Ma version xoops : 2.5.5, venant d'une 2.4.3 mise à jour (elle-même provenant d'une 2.0.x)

J'ai quelques bugs provenant de mes versions 2.4.x suite à de nombreuses transitions d'hébergement Mysql et PHP, de mises à jour, de modifications quelques fois pour forcer l'intégration de modules et quelques fois dans la bdd (pour les modifications des chemins d'accès principalement) depuis 2004.

Voici les bugs qu'il y a encore :

Dans le module News/article V1.1 mis à jour en 1.66 , je dispose de toutes les options que cette version offre, mais lorsque je vais à la page : - Gestion des articles, il y a un bug de cette page et cela m'indique que je n'ai pas le droit d'en créer (j'ai vérifié les droits dans les groupes). Et cette page n'a pas la mise en page habituelle (grosses polices, pas de menu admin en haut) et retourne inexorablement à la page : Configuration des articles.

Dans le module Administrations des modules : lorsque je clique sur "installer des modules" : je tombe sur une page vide et je ne vois pas les (les 9) modules signalés non installés pourtant sur le serveur ftp et modules non buggés puisque j'ai pu en désinstaller un qui n'apparaît plus depuis.

On dirait que la plupart des problèmes sont liés, j'ai cru à un problème de session de cookies ou quelque chose comme ça, mais apparemment non, les dossiers cache sont vidés régulièrement pour tester toutes les possibilités. Dans la bdd, j'ai vidé la table `xoops_session` les XOOPS_TOKEN_SESSION & expire machin chose, comme possibilité du bug. Ca à permis de résoudre en partie le bug des articles.

Je précise qu'au début de l'import de ma backup bdd xoops v 2.4.3 les articles n'étaient plus accessibles, le bug est résolu.
Puis j'ai pu upgrader xoops en 2.5.5, une fois le gros de ce problème résolu.

Actuellement Serveur chez C-Webhosting php 5.3 & Mysql 5.1.61

Mais depuis que j'ai du quitter l'hébergement free avec version php/Mysql plus anciennes, j'ai récoltés tous ces bugs.


Désolé d'être aussi long, j'ai cherché depuis plusieurs jours sur le forum et le net à régler ces problèmes, et ne pas abuser.

Enfin, il y quelques années sur une v2.x.x , j'avais réussi à ajouter les éditeurs et dans mon avant dernière version la 2.4.3, j'avais réussi à régler à 97% ces problèmes, mais suite à des bugs ou attaques sur mon site chez free, j'ai perdu et oublié les hacks.

Merci pour toutes aides éventuelles, je m'appliquerais à remonter toute évolution de ce post.

Posté le : 05/06/2012 13:06
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 2255
Bonjour, pour News, essayes News 1.67.

Posté le : 05/06/2012 13:12

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
Ok, merci je vais essayer tout de suite.

Posté le : 05/06/2012 13:49
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
alors, j'ai maj la News1.67RC3 utf8 , mon bug existe toujours mais cette version est superbe !


Posté le : 05/06/2012 13:57
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
question : dans permissions ( module article) , pour webmestre est il normal qu'aucun onglet n'est sélectionné et lorsque je clique sur : tous, est il normal que cela m'indique ?

"Désolé, vous n'avez pas les permissions pour accéder à cette zone. "

et ensuite je suis redirigé sur la page d'accueil de mon site.

y'a comme un prob de droit d'accès ...

Car ça me fait le même prob lorsque mes articles n'étaient plus accessibles au début de ma réinstallation il y a qq jours ( bug résolu pour la lecture uniquement depuis)

Ha oui est puis ça m'indique avec cette nouvelle version :

Statistiques des articles Il y a 0 Catégories dans la base de données
Il y a 0 Catégories en ligne
Il y a 0 Articles dans la base de données
Il y a 0 Articles en ligne

Alors que mes articles existent bien dans ma bdd .

Il y a comme un prob d'accès ou de droit avec la bdd pour la partie création , gestion etc du module News, mais pas pour la lecture.

Tout est ok pour les version minimum php/mysql


Et dans lorsque je clique sur Statistiques par contre tout est là et mes sujets son ok aussi.

Posté le : 05/06/2012 14:01
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
Redoutable ce module, vraiment !

Posté le : 05/06/2012 14:17
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
Enfin je précise aussi que 95% des images ne sont pas visibles alors qu'elles se trouvent bien dans le serveur sauf celles de themes xoops... ?!

Et cela depuis que j'ai déplacé et renommé les répertoires xoops_data et xoops_lib dans un dossier parent à la racine du site...

peut être justement que j'ai mis trop loin ces dossiers ?

Posté le : 05/06/2012 16:48
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Semi pro
Inscrit: 20/02/2007 15:23
Messages: 1101
Salut,

j'ai le même pb que toi concernant le partie du module news avec 0 articles.

Pour les images je n'ai pas de pb.

Posté le : 05/06/2012 17:03
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Aspirant
Inscrit: 04/07/2004 20:04
Messages: 73
Salut aligato08

ok, intéressant ... et as tu remarqué ce prob de module news depuis un Maj de celui-ci ou depuis une installe vierge ?

Concernant le "déplacement et renommage" des répertoires xoops_data et xoops_lib cela n'a apparemment aucune incidence sur les images , elles n'apparaissent toujours pas.

Au sujet de l'installation d'un module, bien que le lien : " installer des modules" ne mène nulle part , cela ne m'a pas empêché d'installer le module slider par exemple en passant directement par l'url.
Donc le "moteur" d'installation est fonctionnel.

( le bonjour à Andromeda & Granp père Harlock ;-D )

Posté le : 05/06/2012 17:18
Partager Twitter Partagez cette article sur GG+
Re: xoops_version.php dans /class/xoopseditor : pour ajout editeur + Bugs module News
Semi pro
Inscrit: 20/02/2007 15:23
Messages: 1101
Je le constate sur un xoops 2.5.5 tout neuf.

les liens brisés dans l'admin des articles automatisés, je le vois dans ce nouveau xoops, mais également dans un site plus ancien xoops 2.5.4., dont j'avais fait une mise à jour fin d'année dernière.

Posté le : 05/06/2012 17:28
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
(1) 2 3 4 ... 6 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

23 Personne(s) en ligne (15 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 23 | Plus ...