Fork me on GitHub






Module Smallworld problème a l'installation
Régulier
Inscrit: 23/06/2009 14:42
Messages: 131
Bonjour,

J'ai installé ce module dans mon site qui tourne sur Xoops 2.4.5, pour voir à quoi il ressemblait.
L'installation s'est apparemment bien passé mais impossible de retourner sur le site ensuite.
Voici le message d'erreur :
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.25/lafermedy/www/equihens/modules/smallworld/class/db.php on line 504

Quelqu'un peut il m'aider ?

Cdt

Denis

Posté le : 21/11/2013 19:57
Partager Twitter Partagez cette article sur GG+
Re: Module Smallworld problème a l'installation
Régulier
Inscrit: 23/06/2009 14:42
Messages: 131
Pour relancer la discussion, j'ai installé en local le module sur xoops 2.5.5 et il fonctionne.
Je l'ai ensuite installé sur serveur distant (ovh) et j'ai le même message d'erreur.
Quelqu'un aurait une piste ?

Posté le : 24/11/2013 10:32
Partager Twitter Partagez cette article sur GG+
Re: Module Smallworld problème a l'installation
Xoops accro
Inscrit: 27/07/2005 16:10
De France
Messages: 2970
Surement un problème de version php

Posté le : 24/11/2013 11:08
Partager Twitter Partagez cette article sur GG+
Re: Module Smallworld problème a l'installation
Régulier
Inscrit: 23/06/2009 14:42
Messages: 131
Pour le module il préconise Php 5.2 et Mysql 5.0.7 mini.

En local je suis en php 5.3.0

Chez OVH j'ai du mal à trouver mais apparemment ils sont en php 5.3 ou 5.4 mini et Mysql je trouve pas.


Posté le : 24/11/2013 12:23
Partager Twitter Partagez cette article sur GG+
Re: Module Smallworld problème a l'installation
Xoops accro
Inscrit: 27/07/2005 16:10
De France
Messages: 2970
Pour savoir :
1 - Créé un fichier nommé phpinfo.php
2 - Colle dedans ceci <?php phpinfo(); ?>
3 - Transfert le fichier sur ton serveur
4 - Lance le fichier dans ton navigateur : http://tonsite/phpinfo.php

Tu trouvera ensuite dans la page ta configuration php

Posté le : 24/11/2013 12:43
Partager Twitter Partagez cette article sur GG+
Re: Module Smallworld problème a l'installation
Régulier
Inscrit: 23/06/2009 14:42
Messages: 131
Ok merci j'ai fait et voici :

PHP version 4.4.9

Forcément ça ne peut pas marcher mais comment faire alors ?

Posté le : 24/11/2013 13:42
Partager Twitter Partagez cette article sur GG+
Re: Module Smallworld problème a l'installation
Régulier
Inscrit: 23/06/2009 14:42
Messages: 131
Entre temps de mon dernier message j'ai fait un fichier .htaccess comme indiqué dans le guide OVH et ça marche.
Il faut en fait indiquer au fichier d'utiliser une version choisie de php, entre autre la 5.2 avec dedans :"SetEnv PHP_VER 5"

Merci d'avoir orienté mes recherches.

Bonne continuation

Denis

Posté le : 24/11/2013 13:50
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

28 Personne(s) en ligne (20 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 28 | Plus ...