Fork me on GitHub




(1) 2 »


Barre de navigation, perte de liens sauf sur l'accueil
Régulier
Inscrit: 23/06/2004 17:28
Messages: 284
Je tente d'intégrer un menu qui fonctionne bien sur la page d'accueil, mais lorsque je suis sur une autre page, mon menu ne s'affiche plus.

Afin d'être plus clair, voici mon menu sur l'accueil :
Open in new window


puis ce qu'il donne lorsque je suis sur une autre page ( ici dans /modules/pm/viewpmsg.php) :

Open in new window


toutes les images et le css pointent vers l'url du module sous lequel je suis, dans le cas de la capture d'écran, il pointe vers /modules/pm/themes/affilizine_orange2/css/images_menu/ens_01.jpg

Le thème est visible par défaut ici : http://netbio.fr
ça vous parlera mieux en vrai je pense.

Je ne comprends pas pourquoi mes liens ne restent pas à la source de mon theme.

Autre soucis qui est certainement lié, dans mon globanav je dois remplacer tous les "$theme_name" par "themes/affilizine_orange2" sinon mes liens se perdent là aussi. (affilizine_orange2 étant le nom de mon thème).


Si une âme charitable pouvait me donner un coup de main, j'en serais ravi car je sèche complètement pour le coup.

Merci

Posté le : 13/06/2016 15:37
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Bonjour, je veut bien essayer de vous aidez mais il me faudrait l'url du site avec le thème qui délire en action afin que je puisse voir & comprendre d'où viens le problème.

D'après votre explication & de la capture d'écran on dirais que le lien CSS n'est pas bon, faut faire un clic droit puis sélectionner Code Source de la Page (Firefox) et examiner l'url qui pointe sur le fichier CSS qui gère le thème cliquer dessus pour voir si il s'affiche

Posté le : 13/06/2016 21:30

Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
C'est bon j'ai pu voir ça viens de l'url des images dans fichier css du thème

../img/navbar-bg.png

L'url n'est pas complète pour toutes les images


http://netbio.fr/themes/nom_du_thème/img/navbar-bg.png


Apprendre le HTML : URL absolue et URL relative

Posté le : 13/06/2016 21:41

Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Régulier
Inscrit: 23/06/2004 17:28
Messages: 284
Merci beaucoup Niceman, je vais tacher de corriger cela et en profiter pour bien étudier votre lien.

Je vous tiendrais au courant.

Posté le : 13/06/2016 22:22
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3530
Hello,
nicemen, même si tu corriges le problème de notre ami,
je ne conseille pas cette réponse.

En effet, si un jour tu déplaces ton site entier vers un sous-dossier ou si le nom de domaine change, il faudra tout reprendre.

Je vous conseille plutôt d'utiliser les variables telles que l'on peut les trouver dans les thèmes par défaut. (xoImgUrl)

Exemple 1 : Fichier css

<!-- Sheet Css -->
<
link rel="stylesheet" type="text/css" media="all" title="Style sheet" href="<{xoAppUrl xoops.css}>" />
<
link rel="stylesheet" type="text/css" media="all" title="Style sheet" href="<{xoImgUrl style.css}>" />

Exemple 2 : image

<td id="headerlogo">
    <
a href="<{xoAppUrl /}>" title="<{$xoops_sitename}>"><img src="<{xoImgUrl xoops-logo.png}>" alt="<{$xoops_sitename}>" /></a>
</
td>





Posté le : 14/06/2016 00:55

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
J'avais pensé aux variables c'est comme ça sur mon site mais comme je ne sait pas comment il as organisé ses thèmes & qu'il n'avais pas l'air de connaitre les différents type d'url de comprendre le pourquoi du comment je me suis dit

Tout en sachant qu'un admin corrigerais mes propos si je disais une bêtise.

Sur mon site j'utilise ces variables juste pour un fichier CSS (style.css) car j'ai le même thème pour tout le site mais un thème pour chaque module pour plus de flexibilité donc mon fichier css principal (bootstrap) se trouve dans un répertoire à part un niveau au dessus.

Et dans chaque thème j'ai aussi un fichier meta & script différent (<{includeq file="$theme_name/script.php"}>) ce qui me permet de ne pas charger des scripts inutilement qui ne servent pas sur tous les modules & le meta pour mieux les gérer car avec twitter & facebook ça se complique.

Ainsi que les fichiers theme_blockcenter_l.html, theme_blockcenter_c.html, theme_blockcenter_r.html

Posté le : 14/06/2016 04:41

Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Régulier
Inscrit: 23/06/2004 17:28
Messages: 284
Merci a vous 2, effectivement je suis graphiste et j'ai toujours du mal dés que je dois coller mes doigts dans le code.
Je vais essayer de mettre tous vos conseils en application, en reprenant tout bien au calme, j'espère reussir a obtenir quelque chose de probant.

Je reviens vers vius dés que j'ai avancé dans tous les cas

Posté le : 14/06/2016 07:07
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Régulier
Inscrit: 23/06/2004 17:28
Messages: 284
Alors, j'ai avancé ...à moitié.

Pour les images, j'ai appliqu les modifs suivant la méthode de Alain et ça va bien.

Par contre, je ne parviens toujours pas à faire pointer vers mon css.

Sur le thème actuellement en prod, je fais appel à mon css de la manière suivante :

<link rel="stylesheet" href="themes/affilizine_orange2/css/menu_orange.css" type="text/css" media="screen" />


et j'ai toujours mon pb de pointage vers le css lorsque je suis sur une autre page que celle de l'accueil.

Donc toujours en essayant d'appliquer la méthode de Alain, j'ai tenté de remplacer par :

<!-- Sheet Css --> 
<
link rel="stylesheet" type="text/css" media="all" title="Style sheet" href="<{xoAppUrl css/menu_orange.css}>" />


Et là ça ne fonctionne pas ! j'ai merdé quelque part mais je ne parviens pas à trouver où. :(

j'ai également tenté de suivre les indications de Nicemen en essayant le code suivant :

<link rel="stylesheet" href="../css/menu_orange.css" type="text/css" media="screen" />


Mais sans succès là non plus

Posté le : 14/06/2016 11:25
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3530
C'est normal, toi, tu demandes :
href="themes/affilizine_orange2/css/menu_orange.css"

ou bien
href="../css/menu_orange.css"

comme ce n'est pas un chemin absolu, mais un chemin relatif, (les deux) ça ne marchera qu"a une position donnée.

Je pense que tu devrais relire l'explication sur les chemins relatifs et absolus, tu ne les as pas compris.

Le chemin absolu serait :
href="/themes/affilizine_orange2/css/menu_orange.css"

Pour mon exemple qui ne marche pas ?
Je te pose juste la question du lieu où tu places ce code ?
Il devrait être dans le fichier :
/themes/affilizine_orange2/theme.html,
c'est bien cela ?

Posté le : 14/06/2016 11:43

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Barre de navigation, perte de liens sauf sur l'accueil
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3530
Essaye aussi ceci : (exemple)
<link rel="stylesheet" type="text/css" href="<{xoImgUrl}>css/xoops.css">

c'est à dire sans les espaces...

Posté le : 14/06/2016 11:51

Open in new window
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
(1) 2 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

17 Personne(s) en ligne (10 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 17 | Plus ...