Fork me on GitHub

La version finale de la 2.4.0 de XOOPS est sortie

200901
Novembre
  grandoc Versions 7128
Versions

L'√©quipe des d√©veloppeurs de XOOPS est heureuse d'annoncer qu'une nouvelle version du syst√®me de CMS n¬į1 sur SourceForge - la 2.4.0 Finale de XOOPS est disponible en t√©l√©chargement.


Cette version inclut de nombreux correctifs et des améliorations provenant de l'expérience des utilisateurs, elle a été réalisée par L'équipe des développeurs du Core et la communauté de XOOPS. Parmi les principales améliorations:


* Une nouvelle interface graphique d'administration: Oxygen (Voltan): voir photo ci-dessus

* Un nouveau mécanisme de modularisation et d'extension du core par Preloads (Trabis)

* Un support centralisé pour jQuery (Trabis)

* Installateur amélioré (DuGris)

* WCAG 2.0 - des formulaires assistés pour malvoyants (Wishcraft)

* Une zone d'administration Personnalisable (Trabis)

* La prise en charge de nouveaux éditeurs WYSIWYG: CKEditor, WYMeditor, Xinha, et Spaw2 (Wishcraft et Luciorota)

* Un nouveau système de clé (Wishcraft)

* Le Support de PHP 5.3 (Trabis)

* Les modules Profil et pm améliorés par Trabis

* Correctifs de sécurité (Trabis, Wishcraft)


et encore beaucoup plus.


Veuillez vous Rappeler : Si vous l'installez par dessus une installation précédente, effectuez une sauvegarde d'abord!

Veuillez noter également que certains hacks fait pour les précédentes versions de XOOPS pourraient ne pas fonctionner avec cette version: les tests avant l'installation sont toujours un bon choix




Configuration requise

-----------------------------------


PHP:

Toutes les versions PHP> = 4.3 (PHP 4.2.x devrait fonctionner, mais n'est pas officiellement supportée, PHP 5.0 + est fortement recommandée)


MySQL:

Serveur MySQL 3.23 + (5,0 + MySQL est fortement recommandé)


Serveur Web:

Tout serveur supportant la version PHP requise (Apache fortement recommandé)



Téléchargement de XOOPS

-----------------------------------


Téléchargez la version française de Xoops 2.4.0 sur l'espace SourceForge de Xoops France (merci aux créateurs du package FR)



Installation de XOOPS

-----------------------------------


1. Copiez le contenu du dossier htdocs/ à un emplacement accessible par votre serveur

2. Assurez vous que les fichiers mainfile.php et uploads/ soient accessibles en écriture par le serveur web

3. Pour des considérations de sécurité, vous êtes encouragés à déplacer les répertoires "/xoops_lib" (pour les bibliothèques XOOPS ) et "/xoops_data" (pour les données XOOPS) en dehors de la racine du site, ou même de changer les noms des dossiers.

4. Faites que le répertoire xoops_data/ soit accessible en écriture; le créer (s'il n'est pas déjà présent) et faites que les répertoires xoops_data/caches/, xoops_data/cache/xoops_cache/, xoops_data/cache/smarty_cache/ et xoops_data/cache/smarty_compile/ soient de même accessibles en écriture.

5. Acc√©dez au dossier o√Ļ vous avez install√© les fichiers contenus dans htdocs/ √† l'aide de votre navigateur Web pour lancer l'assistant d'installation


Mise à jour depuis une version précédente

-----------------------------------


Mise à jour à partir de XOOPS 2.3.x (le plus facile)

1. Obtenir la bonne mise √† jour √† partir du d√©p√īt de fichiers sourceforge

2. Ecrasez les fichiers existants avec les nouveaux

* Assurez-vous que vous copiez le contenu de / xoops_lib dans le répertoire quelqu'il soit que vous avez créé sur le serveur (par exemple si vous l'avez déplacé en dehors de la racine du site). Il ne peut y avoir deux répertoires avec le contenu de / xoops_lib

3. Installez le dossier "upgrade" à l'intérieur du dossier "htdocs" (il a été mis à l'écart car il n'est pas nécessaire pour une installation complète) sur votre machine locale

4. Accédez au dossier /upgrade/ avec un navigateur, et suivez les instructions

5. Suivez les instructions pour mettre à jour votre base de données

6. Supprimer le dossier ¬ęupgrade¬Ľ de votre serveur

7. Mettez √† jour le module ¬ęsyst√®me¬Ľ, √† partir de l'interface d'administration des modules, il est aussi recommand√© de mettre √† jour d'autres modules, en particulier "profil".


Mise à jour de XOOPS 2.0.* supérieure à 2.0.14 et 2.2.* (en utilisant le package complet)

0. Décompressez l'archive sur votre ordinateur (PC, par exemple) dans un répertoire temporaire.

1. Installez le dossier "upgrade" à l'intérieur du dossier "htdocs" (il a été mis à l'écart car il n'est pas nécessaire pour une installation complète) sur votre machine locale

2. Supprimez htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ et htdocs/uploads/ à partir du dossier "htdocs" sur votre machine LOCALE

* Si vous avez créé le dossier XOOPS_TRUST_PATH sur votre serveur, copiez le contenu de /xoops_lib vers ce répertoire, et supprimez /xoops_lib du dossier "htdocs" sur votre ordinateur local

3. Envoyez le contenu du dossier htdocs présent sur votre machine LOCALE écraser vos fichiers présents sur votre serveur

4. Pour des considérations de sécurité, vous êtes encouragés à déplacer les répertoires "/xoops_lib" (pour les bibliothèques XOOPS ) et "/xoops_data" (pour les données XOOPS) en dehors de la racine du site, ou même de changer les noms des dossiers.

5. Faites que le répertoire xoops_data/ soit accessible en écriture; le créer (s'il n'est pas déjà présent) et faites que les répertoires xoops_data/caches/, xoops_data/cache/xoops_cache/, xoops_data/cache/smarty_cache/ et xoops_data/cache/smarty_compile/ soient de même accessibles en écriture.

6. S'assurer que le serveur peut écrire dans mainfile.php

7. Accédez au dossier /upgrade/ avec un navigateur, et suivez les instructions

8. Suivez les instructions pour mettre à jour votre base de données

9. Protégez à nouveau mainfile.php en écriture

10. Supprimez le dossier "upgrade" de votre serveur

11. Mettez √† jour le module ¬ęsyst√®me¬Ľ, √† partir de l'interface d'administration des modules, il est aussi recommand√© de mettre √† jour d'autres modules, en particulier "profil".


Mise à jour de la gamme de XOOPS 2.0.7 à 2.0.13.2 (en utilisant le package complet):

0. Décompressez l'archive sur votre ordinateur (PC, par exemple) dans un répertoire temporaire.

1. Installez le dossier "upgrade" à l'intérieur du dossier "htdocs" (il a été mis à l'écart car il n'est pas nécessaire pour une installation complète) sur votre machine locale

2. Supprimez htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ et htdocs/uploads/ à partir du dossier "htdocs" sur votre machine LOCALE

* Si vous avez créé le dossier XOOPS_TRUST_PATH sur votre serveur, copiez le contenu de /xoops_lib vers ce répertoire, et supprimez /xoops_lib du dossier "htdocs" sur votre ordinateur local

3. Envoyez le contenu du dossier htdocs présent sur votre machine LOCALE écraser vos fichiers présents sur votre serveur

4. Supprimez les dossiers et les fichiers suivants de votre serveur (ils appartiennent à une ancienne version):

* Class/smarty/core

* Class/smarty/plugins/resource.db.php

5. S'assurer que le serveur peut écrire dans mainfile.php

6. Pour des considérations de sécurité, vous êtes encouragés à déplacer les répertoires "/xoops_lib" (pour les bibliothèques XOOPS ) et "/xoops_data" (pour les données XOOPS) en dehors de la racine du site, ou même de changer les noms des dossiers.

7. Faites que le répertoire xoops_data/ soit accessible en écriture; le créer (s'il n'est pas déjà présent) et faites que les répertoires xoops_data/caches/, xoops_data/cache/xoops_cache/, xoops_data/cache/smarty_cache/ et xoops_data/cache/smarty_compile/ soient de même accessibles en écriture.

8. Accédez au dossier /upgrade/ avec un navigateur, et suivez les instructions

9. Protégez à nouveau mainfile.php en écriture

10. Supprimez le dossier "upgrade" de votre serveur

11. Mettez √† jour le module ¬ęsyst√®me¬Ľ, √† partir de l'interface d'administration des modules, il est aussi recommand√© de mettre √† jour d'autres modules, en particulier "profil"


Mise à jour d'un site non UTF-8 :

L'encodage UTF-8 a été introduit dans XOOPS 2.3 comme charset par défaut. Toutefois, il pourrait y avoir quelques problèmes avec la conversion de sites Web existants non UTF-8 en UTF-8.

Il y a cependant une assez bonne solution pour cette conversion, les paramètres suivants sont recommandés lorsque vous mettez à jour un site existant, si vous n'êtes pas un utilisateur expérimenté:

- S√©lectionnez l'option "Ne pas modifier" lors de l'√©tape "Param√©trage de la base de donn√©es¬Ľ du processus de mise √† niveau

- Modifiez /languages/Yourlanguage/global.php pour utiliser ISO-8859-1 si elle a été changée en UTF-8 dans votre nouveau fichier global.php


define '_CHARSET''UTF-8');


Mise à jour du dossier XoopsEditor:

Dans le dossier XOOPS, il y a quatre éditeurs inclus: dhtmltextarea et textarea pour du texte brut, CKeditor et TinyMCE pour du HTML WYSIWYG.

Il y a six nouveaux éditeurs WYSIWYG disponibles: FCKeditor, Koivi, NiceEdit, WYMeditor, Xinha, et Spaw2 que vous pouvez télécharger à partir du SourceForge de XOOPS (https://sourceforge.net/projects/xoops/files/XOOPS%20Editors/)

Comme il y a quelques changements à la fois dans les répertoires des deux éditeurs fckeditor et TinyMCE, nous vous recommandons de supprimer les éditeurs existant avant de télécharger les nouveaux.

Et si vous utilisez FCKeditor pour les modules, s'il vous pla√ģt modifiez la configuration sp√©cifique des modules en suivant les fichiers dans /FCKeditor/ modules/, surtout si vous utilisez le module "article".


niveau d'affichage des informations de débogage

-----------------------------------


Depuis XOOPS 2.3.1 le niveau d'affichage des informations de débogage est activée comme une solution temporaire pour 2.3* pour montrer les informations de débogage à différents niveaux d'utilisateurs: à tous les utilisateurs, aux membres ou aux administrateurs seulement.

La configuration peut être définie dans /xoops_data/configs/xoopsconfig.php

De nouveaux outils d'information de débogage seront disponibles dans la 2.4 avec Firebug (voir http://tinyurl.com/nmnjdp)


Fichiers de contr√īle d'int√©grit√©

-----------------------------------


Le dossier complet XOOPS est sorti avec un script capable de vérifier si tous les fichiers système ont été correctement envoyés sur le serveur. Pour l'utiliser, suivez ces instructions:


1. Transf√©rer les fichiers checksum.php et checksum.md5 qui se trouvent √† la racine du dossier XOOPS sur votre serveur (en les mettant √† c√īt√© de mainfile.php).

2. Exécutez checksum.php avec votre navigateur

3. Si nécessaire, re-télécharger les fichiers système manquants ou endommagés

4. Retirez checksum.php et checksum.md5 de votre serveur


Modules

-----------------------------------


Cette version ne contient que les "modules li√©s au syst√®me". Vous √™tes invit√©s √† parcourir le r√©f√©rentiel de modules XOOPS si vous avez besoin de fonctionnalit√©s suppl√©mentaires. Note: comme un nouveau r√©f√©rentiel est en cours de construction, le d√©p√īt n'est pas √† jour, VEUILLEZ VISITEZ LES SITES PERSONNELS DES D√ČVELOPPEURS AFIN DE VOUS ASSUREZ QUE VOUS UTILISEZ BIEN LA DERNI√ąRE VERSION DES MODULES.


Comment contribuer

-----------------------------------


Note: 0.00 (0 votes) - Noter cet article -

Partager Twitter Partagez cette article sur GG+
Format imprimable Envoyer cet article à un ami
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Supporter Xoops
Inscrit le: 09/01/2005
De: Breizh
Contributions: 16972
Kris Post√© le: 01/11/2009 19:16  Mis √† jour: 01/11/2009 19:16
 Re: La version finale de la 2.4.0 de XOOPS est sortie
Une version 2.4.1 avec quelques corrections de bugs devrait être publiée d'ici quelques jours
Je vous invite donc à attendre cette version pour l'actualisation de vos sites

Kris
Newbie
Inscrit le: 19/07/2004
De:
Contributions: 10
edyfred Post√© le: 01/11/2009 19:34  Mis √† jour: 01/11/2009 19:34
 Re: La version finale de la 2.4.0 de XOOPS est sortie
Bonjour,
je suis bien content de la nouvelle avec grande joie. J'ai juste une petite question pour l'utilisation de modules multilangue tel que xoopslanguage. A quel niveau dois-je maintenant faire l'inclusion du fichier ...modules/xoopslanguage/api.php dans le fichier include/common.php
Newbie
Inscrit le: 19/07/2004
De:
Contributions: 10
edyfred Post√© le: 01/11/2009 19:53  Mis √† jour: 01/11/2009 19:53
 La solution semble avoir √©t√© donn√©e
En fait c'est juste pour dire que la solution a été donnée sur le lien
xoops 2.4 multilangue
Aspirant
Inscrit le: 29/05/2003
De: Près de Paris
Contributions: 62
vfredy Post√© le: 03/11/2009 00:36  Mis √† jour: 03/11/2009 00:36
 Re: La version finale de la 2.4.0 de XOOPS est sortie
Salut,
j'ai upgradé la v2.4.0
ca marche nikel
merci, vous faite du bon taff les gas.
Newbie
Inscrit le: 30/09/2009
De:
Contributions: 18
Zyst Post√© le: 03/11/2009 21:00  Mis √† jour: 03/11/2009 21:00
 Re: La version finale de la 2.4.0 de XOOPS est sortie
Bonsoir,

Je ne comprends pas exactement ce que je dois faire pour passer de 2.3.x à 2.4.0, merci, je l'espère, pour vos futures explications.

Bonne soirée,
Zyst.
Aspirant
Inscrit le: 03/03/2007
De: Poitiers
Contributions: 76
DavidG Post√© le: 04/11/2009 14:15  Mis √† jour: 04/11/2009 14:15
 Re: La version finale de la 2.4.0 de XOOPS est sortie
Pour les sites hébergés chez FREE,doivent-ils toujours créer:
- un dossier vide "sessions"
- un fichier ".htaccess" à la racine

Merci d'avance.
Aspirant
Inscrit le: 03/03/2007
De: Poitiers
Contributions: 76
DavidG Post√© le: 04/11/2009 23:44  Mis √† jour: 04/11/2009 23:45
 Re: La version finale de la 2.4.0 de XOOPS est sortie
chez free, lorsque je veux faire une installation de xoops 2.4 le message d'erreur suivant apparait:

Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/mnt/100/sdc/9/3/xoops_lib/) is not within the allowed path(s): (/mnt/100/sdc/9/3/lesbranques) in /mnt/100/sdc/9/3/lesbranques/install/class/pathcontroller.php on line 81

Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/mnt/100/sdc/9/3/xoops_data/) is not within the allowed path(s): (/mnt/100/sdc/9/3/lesbranques) in /mnt/100/sdc/9/3/lesbranques/install/class/pathcontroller.php on line 87

Warning: Cannot modify header information - headers already sent by (output started at /mnt/100/sdc/9/3/lesbranques/install/class/pathcontroller.php:81) in /mnt/100/sdc/9/3/lesbranques/install/class/installwizard.php on line 204

Warning: Cannot modify header information - headers already sent by (output started at /mnt/100/sdc/9/3/lesbranques/install/class/pathcontroller.php:81) in /mnt/100/sdc/9/3/lesbranques/install/class/installwizard.php on line 206

Merci d'avance pour votre aide
Semi pro
Inscrit le: 06/09/2005
De: Royan
Contributions: 608
CPascal Post√© le: 07/11/2009 10:19  Mis √† jour: 07/11/2009 10:19
 Re: La version finale de la 2.4.0 de XOOPS est sortie
bonjour,

la sortie de la version 2.41 et elle toujours d'actualité va t'elle sortir (dans ce cas ont attendra le temps qu'il faut attendre pas de soucci) ou les corrections ont été apporter directement dans la 2.40 proposé actuellement en téléchargement

merci
Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

48 Personne(s) en ligne (2 Personne(s) connectée(s) sur Articles) | Utilisateur(s): 0 | Invité(s): 48 | Plus ...