Fork me on GitHub

Mise en ligne de la version 2.4.5 sur Frxoops

201031
Juillet
  tatane Versions 7493

L'équipe de FRXOOPS est heureuse de vous annoncer la sortie de XOOPS 2.4.5 version finale.

Cette édition est principalement destinée à corriger des bugs et supprimer les conflits des précédentes versions de la série 2.4.
Certaines caractéristiques, incluant tinyMCE/ckeditor sont améliorées.
Veuillez consulter changelog pour les détails.

Quelques autres problèmes connus seront traités dans XOOPS 2.4.6, qui sera probablement la dernière version de la série 2.4, principalement pour un nettoyage du code.


Caractéristiques système nécessaires:
-----------------------------------

PHP:
Toute version PHP >= 4.3 (PHP 4.2.x peut fonctionner mais n'est pas officiellement compatible, PHP 5.0+ est fortement recommandée)

MySQL:
MySQL server 3.23+ (MySQL 5.0+ est fortement recommandé)

Web server:
Tout serveur compatible avec la version PHP nécessaire (Apache hautement recommandée)

Téléchargement de XOOPS
-----------------------------------

Vous pouvez obtenir cette √©dition depuis le d√©p√īt du sourceforge de frxoops ici

La doc pour la mise à jour au format PDF ici

Installation de XOOPS
-----------------------------------

1. Copier le contenu du r√©pertoire htdocs/ √† l'endroit o√Ļ il sera accessible par votre serveur
2. Assurez vous que mainfile.php and uploads/ sont autorisés en écriture par le serveur web
3. Pour des raisons de sécurité, vous êtes encouragé à déplacer les répertoires "/xoops_lib" (pour les bibliothèques XOOPS) et "/xoops_data" (pour les données XOOPS) en dehors de la racine du site, ou même modifier les noms de ces répertoires.
4. Autorisez en écriture le répertoire xoops_data/; Créez (s'ils n'existent pas déjà) et autorisez en écriture les répertoires xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ et xoops_data/caches/smarty_compile/ .
5. Allez dans le r√©pertoire o√Ļ vous avez install√© les fichiers de htdocs/ en utilisant votre navigateur internet afin de lancer l'assistant d'installation.

Installation de Protector dans XOOPS
-----------------------------------
Nous recommandons fortement l'installation du module PROTECTOR qui apporte une protection et des possibilités d'identification additionnelles à votre site:

Upgrader depuis une version précédente
-----------------------------------

Upgrader depuis XOOPS 2.3.3 et 2.4.x (facile)

1. Procurez vous le bon package d'am√©lioration depuis le d√©p√īt sourceforge
2. Ecrasez les fichiers dans le répertoire XOOPS sur votre serveur avec le contenu de /htdocs
* assurez vous que vous copiez le contenu de /xoops_lib dans un quelconque répertoire placé sur le serveur (ce devrait être votre répertoire XOOPS_TRUST_PATH courant), puis détruisez le répertoire /xoops_lib. Il NE PEUT y avoir deux répertoires avec le contenu de /xoops_lib
3. Si Protector était précédemment installé, ouvrez le fichier "mainfile.php", et supprimez les lignes Pre-check et Post-check (si elles existent):

include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;

4. Si vous upgradez depuis XOOPS 2.4.x, rendez le fichier /include/license.php autorisé en écriture (permission 0777 sous Linux)
5. Ouvrez le répertoire /upgrade/ avec un navigateur, et suivez les instructions
6. Suivez les instructions pour mettre à jour votre base de données
7. Détruisez le répertoire "upgrade" du serveur
8. Mettez à jour le module "system" depuis l'interface d'administration des modules. Il est également recommandé d'actualiser d'autres modules, spécialement "Profile" et "Protector".

Upgrader depuis XOOPS 2.0.* supérieur à 2.0.14, et 2.2.* (en utilisant le package complet)

0. Décompressez l'archive sur votre ordinateur, en local (e.g. PC) dans un répertoire temporaire.
1. Déplacez le répertoire "upgrade" à l'intérieur du répertoire "htdocs" (il a été placé à l'extérieur car il n'est pas nécessaire pour une installation complète) de votre ordinateur local.
2. Détruisez htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/template_c/, htdocs/themes/ et htdocs/uploads/ dans le répertoire "htdocs" de votre ordinateur local.
* si vous avez créé le répertoire XOOPS_TRUST_PATH sur votre serveur, copiez le contenu de /xoops_lib dans ce répertoire, et détruisez /xoops_lib dans le répertoire "htdocs" de votre ordinateur local.
3. Uploadez le contenu du répertoire /htdocs de votre ordinateur local par dessus les fichiers existants sur le serveur.
4. Pour des raisons de sécurité, vous êtes encouragé à déplacer les répertoires xoops_lib (pour les bibliothèques XOOPS) et xoops_data (pour les données XOOPS) en dehors de la racine du site, et modifier les noms de répertoires.
5. Autorisez en écriture le répertoirexoops_data/; Créez et autorisez en écriture les répertoires xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ et xoops_data/caches/smarty_compile/ (permission 0777 sous Linux).
6. Assurez vous que le serveur peut écrire dans le fichier mainfile.php (permission 0777 sous Linux)
7. Si Protector était précédemment installé, ouvrez le fichier "mainfile.php", et supprimez les lignes Pre-check et Post-check (si elles existent):

include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;

8. Ouvrez le répertoire /upgrade/ avec un navigateur, et suivez les instructions
9. Suivez les instructions pour mettre à jour votre base de données
10. Protégez à nouveau en écriture le fichier mainfile.php (permission 0444 sous Linux)
11. Détruisez le répertoire "upgrade" sur le serveur
12. Actualisez le module "system" depuis l'interface d'administration des modules, il est également recommandé d'actualiser les autres modules.

Upgrader depuis toute version XOOPS depuis 2.0.7 jusqu'à 2.0.13.2 (en utilisant le package complet):

0. Décompressez l'archive sur votre ordinateur local(e.g. PC) dans un répertoire temporaire.
1. Déplacez le répertoire "upgrade" à l'intérieur du répertoire "htdocs" de votre ordinateur local (il a été séparé car il n'est pas nécessaire pour une installation complète)
2. Détruisez les répertoires htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/template_c/, htdocs/themes/ et htdocs/uploads/ du répertoire "htdocs" sur votre ordinateur local.
* si vous avez créé le répertoire XOOPS_TRUST_PATH sur votre serveur, copiez le contenu de /xoops_lib dans ce répertoire, et détruisez /xoops_lib dans le répertoire "htdocs" de votre ordinateur local.
3. Uploadez le contenu du répertoire htdocs de votre ordinateur local par dessus les fichiers existants sur le serveur.
4. Détruisez les répertoires et fichiers suivants sur votre serveur (ils appartiennent à une ancienne version):
* class/smarty/core
* class/smarty/plugins/resource.db.php
5. Assurez vous que le serveur peut écrire dans le fichier mainfile.php (permission 0777 sous Linux)
6. Si Protector était précédemment installé, ouvrez le fichier "mainfile.php", et supprimez les lignes Pre-check et Post-check lines (si elles existent):

include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;

7. Pour des raisons de sécurité, nous vous encourageons à déplacer les répertoires xoops_lib (pour les bibliothèques XOOPS) et xoops_data (pour les données XOOPS) en dehors de la racine du site, ou même modifier les noms des répertoires.
8. Autorisez en écriture le répertoire xoops_data/ writable; Créez et autorisez en écriture les répertoires xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ et xoops_data/caches/smarty_compile/ (permission 0777 sous Linux).
9. Ouvrez le répertoire /upgrade/ avec un navigateur, et suivez les instructions.
10. Protégez à nouveau en écriture le fichier mainfile.php (permission 0444 sous Linux)
11. Détruisez le répertoire "upgrade" sur votre serveur.
12. Actualisez le module "system" depuis l'interface d'administration des modules, il est également recommandé d'actualiser.

Upgrader un site non UTF-8:

L'encodage UTF-8 a été introduit comme jeu de caractère par défaut dans XOOPS 2.3. Cependant, il peut y avoir quelques problèmes dans la conversion de sites depuis un jeu de caractère non UTF-8 vers l'UTF-8.
En attendant d'avoir une bonne solution pour cette conversion, si vous n'êtes pas un utilisateur expérimenté les paramètres suivants sont recommandés pour upgrader un site existant:
- Sélectionnez l'option "Ne pas changer" dans l'étape "Jeu de caractère et collationnement de la base de données" de la procédure d'upgrade.
- Modifiez /languages/yourlanguage/global.php pour utiliser la valeur _CHARSET existante si elle a été changée en UTF-8 dans le nouveau fichier global.php par

define('_CHARSET''UTF-8');


Upgrader les éditeurs XOOPS:

Dans le package XOOPS, sont inclus quatre éditeurs: dhtmltextarea et textarea pour le texte plein, CKeditor et TinyMCE pour WYSIWYG HTML.
Il y a six éditeurs WYSIWYG additionnels disponibles: FCKeditor, Koivi, NiceEdit, Wymeditor, Xinha, et Spaw2, que vous pouvez télécharger depuis XOOPS SourceForge (https://sourceforge.net/projects/xoops/files/XOOPS%20Editors/).
Comme il y a quelques modifications dans la structure des répertoires dans fckeditor et tinyMCE, nous vous recommandons de supprimer les éditeurs existants avant d'uploader les nouveaux.
Et si vous utilisez FCKeditor dans les modules, veuillez modifier les configs spécifiques des modules dans /fckeditor/modules/, en particulier si vous utilisez le module "Article".

Niveau d'information de débogage
-------------------------------

Depuis XOOPS 2.3.1 le niveau d'information de debogage est activé comme solution temporaire à 2.3.*, pour afficher les informations de debogage selon le niveau des utilisateurs: à tous les utilisateurs, aux membres ou aux administrateurs seulement.
La configuration peut être paramétrée dans /xoops_data/configs/xoopsconfig.php.
De nouveaux outils de débogage seront disponibles pour 2.4 en utilisant FireBug (voir http://tinyurl.com/nmnjdp).

Vérification de l'intégrité des fichiers
----------------------------------------

Le package complet de XOOPS comprend un script capable de vérifier si tous les fichiers système ont été correctement uploadés sur le serveur. Pour l'utiliser suivez ces instructions:

1. Uploadez les fichiers checksum.php et checksum.md5, situ√©s √† la racine du package XOOPS, vers le r√©pertoire XOOPS sur le serveur (les mettre √† c√īt√© de mainfile.php).
2. Executez checksum.php avec votre navigateur.
3. Si nécessaire, ré-uplodez les fichiers systèmes manquants ou corrompus.
4. Supprimez checksum.php et checksum.md5 du serveur.

Modules
-----------------------------------

Cette √©dition ne contient que les modules syst√®me ou li√©s au syst√®me. Vous √™tes invit√©s √† naviguer dans le d√©p√īt des modules XOOPS si vous souhaitez de nouvelles fonctionnalit√©s. Remarque: comme un nouveau d√©p√īt a √©t√© cr√©√©, le d√©p√īt courant n'est plus tenu √† jour, VEUILLEZ VISITER LES SITES DES DEVELOPPEURS INDIVIDUELS POUR VOUS ASSURER QUE VOUS UTILISER LES DERNIERES VERSIONS DES MODULES.

Comment contribuer
-----------------------------------
Signaler un bug: http://sourceforge.net/tracker/?group_id=41586&atid=430840
Patch et amélioration: http://sourceforge.net/tracker/?group_id=41586&atid=430842
Conception: http://sourceforge.net/tracker/?group_id=41586&atid=430843
Annonce d'édition: https://lists.sourceforge.net/lists/listinfo/xoops-announcement

Equipe de développement XOOPS
Le 04 juillet 2010

Nous tenons à remercier les membres de l'équipe traduction Fabrice59 pour la traduction de cette version ainsi que LionHell pour la traduction de cet article

Note: 0.00 (0 votes) - Noter cet article -

Partager Twitter Partagez cette article sur GG+
Format imprimable Envoyer cet article à un ami Créer un fichier PDF à partir de cet article
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

33 Personne(s) en ligne (1 Personne(s) connectée(s) sur Articles) | Utilisateur(s): 0 | Invité(s): 33 | Plus ...