Fork me on GitHub

Sortie du Framework ModuleClasses 1.1

201115
Août
  mage Modules 4120

Je suis heureux de vous annoncez la sortie du Framework "ModuleClasses" en version 1.1

Ce Framework vise Ă  faciliter et Ă  standardiser les parties d'administration des modules des modules XOOPS.

moduleclasses

La classe "ModuleAdmin" gère complètement le côté admin du module. Il vous permet de:

  • CrĂ©er la page d'index.
  • CrĂ©er la page "about".
  • CrĂ©er des boutons d'action sur toutes les pages admin.

Je recommande d'utiliser ce framework pour tous vos nouveaux modules - de cette façon ils peuvent tous partager la même interface d'administration. Les modules du prochain pack de module XOOPS utilisent tous le framework ModuleClasses.

Vous pouvez également mettre à jour vos modules existants - voir ce forum . La version 1.1 apporte quelques améliorations pour rendre plus facile la mise à niveau, et Mamba travaille sur un tutoriel. J'ai fais une documentation sur l'utilisation de la class "moduladmin" dans l'archive.

Merci à tous ceux qui ont aidé à l'élaboration de ce Framework, et à tous les utilisateurs qui l'utilise déjà dans leurs modules.

Vous pouvez télécharger le Frameworks ModuleClasses sur SourceForge

Note: 10.00 (2 votes) - Noter cet article -

Partager Twitter Partagez cette article sur GG+
Format imprimable Envoyer cet article Ă  un ami
Les commentaires appartiennent Ă  leurs auteurs. Nous ne sommes pas responsables de leur contenu.
RĂ©gulier
Inscrit le: 26/02/2007
De:
Contributions: 494
aquaportail PostĂ© le: 27/08/2011 08:06  Mis Ă  jour: 27/08/2011 08:06
 Re: Sortie du Framework ModuleClasses 1.1
Est-ce que ce module sera suivi dans la future version 3 de Xoops?
Supporter Xoops
Inscrit le: 09/01/2005
De: Breizh
Contributions: 16972
Kris PostĂ© le: 27/08/2011 11:02  Mis Ă  jour: 27/08/2011 11:02
 Re: Sortie du Framework ModuleClasses 1.1
RĂ©gulier
Inscrit le: 26/02/2007
De:
Contributions: 494
aquaportail PostĂ© le: 27/08/2011 19:20  Mis Ă  jour: 27/08/2011 19:20
 Re: Sortie du Framework ModuleClasses 1.1
Ok, merci pour les précisions, même si elles ne sont pas idéales...
Supporter Xoops
Inscrit le: 26/10/2003
De: Bordeaux
Contributions: 78
recupsoft PostĂ© le: 03/12/2011 21:12  Mis Ă  jour: 03/12/2011 21:12
 Re: Sortie du Framework ModuleClasses 1.1
Correction Ă  apporter (idem dans les packages de Xoops 2.5.4)
dans moduleclasses\moduleadmin\language\french\main.php

define("_AM_MODULEADMIN_CONFIG_DB'","Version minimale requise : %s (votre version est %s)");
doit devenir
define("_AM_MODULEADMIN_CONFIG_DB","Version minimale requise : %s (votre version est %s)");
(une apostrophe en trop)
Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

24 Personne(s) en ligne (4 Personne(s) connectée(s) sur Articles) | Utilisateur(s): 1 | Invité(s): 23 | Heyula, Plus ...