A la recherche des extensions php perdues

Date 30/04/2008 | Sujet : Documentations

Bonjour,

Au cours de l'installation de Xoops 2.0.18 le programme passe par une phase de "Vérification du paramétrage de votre serveur". Durant cette phase sont vérifiées les versions d'apache, php, mysql etc...
Et une liste des extensions php recommandées est présentée avec ce message :

"Ces extensions ne sont pas obligatoires pour un usage standard, mais peuvent être nécessaires pour utiliser quelques fonctions spécifiques. Nous préconisons leur installation."

Si toute la liste est en vert, tout roule et vous pouvez passer à phase suivante.
Les ennuis commencent si vous avez du rouge car si il y a une description de ces extensions leur nom réel n'est pas indiqué, donc :
1/ vous êtes en local et vous aimeriez activer ces extensions mais vous n'en connaissez pas le nom
2/ vous êtes chez votre hébergeur et ne connaissant pas le nom des extensions manquantes vous allez avoir bien du mal à déterminer les modules ou fonctions qui risquent de vous poser des problèmes.

En voici la liste :

Encodage des caractères extension ------> MBString
Conversion jeu de caractères extension -> Iconv
Analyse XML extension ------------------> XML
Compression Zlib extension -------------> Zlib
Fonctions image extension --------------> GD Bundled
Données meta image extension -----------> Exif

Nota : L'extension Exif nécessite que l'extension MBString soit chargée avant.


Signé Indiana Jones, à qui il manquait des tas d'extensions


Cet article provient de Communauté Francophone des Utilisateurs de Xoops
http://www.frxoops.org

L'adresse de cet article est :
http://www.frxoops.org/modules/news/article.php?storyid=1484