Fork me on GitHub

Rapport de message :*
 

Re: xoopspoll dans newbb

Titre du sujet : Re: xoopspoll dans newbb
par JJDai sur 18/04/2021 17:30:11

L'erreur n'est peut pas la ou l'on croit !!!
Je viens de d'installer ces deux modules sur un site de test.
newbb : 5.01 beta 4
xoopspoll : 2.01 beta 1
xoops : 2.5.10

Impossible de créer un sondage à partir du forum.
Je n'ai pas trop de de temps a consacrer à ce problème, mais ça se passe a priori dans le fichier polls.php du forum à partir de la ligne 371. Il y a un test sur la version :

// new xoopspoll module
        
if ($pollModuleHandler->getVar('version') >= 201) {
            
/** @var XoopsModulesXoopspollOptionHandler $xpOptHandler */
            
$xpOptHandler XoopspollHelper::getInstance()->getHandler('Option');
            
/** @var XoopsModulesXoopspollLogHandler $xpLogHandler */
            
$xpLogHandler XoopspollHelper::getInstance()->getHandler('Log');
        } elseif (
$pollModuleHandler->getVar('version') >= 140) {


Hors xoopspoll est en version 2.01 (201)
et dans ce cas j'ai l'impression qu'il n'y a pas de création de sondage a priori.
J'ai tenté de forcer sur une autre version, mais là, plantage total.

Une solution serait peut être d'installer une version plus ancienne qui fonctionne, mais la c'est une autre histoire.

Je laisse pour l'instant, j'ai d'autres urgences.

JJDai

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

110 Personne(s) en ligne (101 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 110 | Plus ...