Fork me on GitHub

Rapport de message :*
 

httpS

Titre du sujet : httpS
par Skype-Fr sur 03/08/2018 18:03:23

Bonjour à tous,

J'ai essayé d'utiliser le protocole httpS pour mes sites Xoops (version actuelle v 2.5.7.2).

Coté hébergement OVH, j'ai activé le certificat SSL et ajouté les redirections 301 dans un htaccess.

Coté CMS, j'ai modifié l'url dans le fichier "mainfile.php" pour y mettre "https://monsite.fr" au lieu de "http://...".

Bon ben, je dois être naïf mais cela ne marche pas.
Les sites Xoops ainsi modifiés fonctionnement normalement et d'ailleurs le navigateur n'indique plus le désagréable "non sécurisé" MAIS bien que le Certificat SSL soit validé par Chrome et les autres, il y a le message d'avertissement suivant :
"Votre connexion à ce site n'est pas totalement sécurisée" etc.

Certes, c'est un progrès mais cela ne suffit pas !!

Je précise que tout est parfait pour mes autres sites statiques écrit purement en html/css. J'ai bien le joli cadenas vert. Le problème vient donc bien du CMS ...

Est-ce impossible pour le moment d'obtenir un fonctionnement sécurisé SSL avec Xoops ? Sinon, quelle est la bonne procédure ? Si oui, dois-je me tourner vers un autre CMS (ce qui est toujours possible mais 12 années de Xoops vont me contrarier) ...

Alors les amis, que dois-je faire ???

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

26 Personne(s) en ligne (12 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 26 | Plus ...