Fork me on GitHub




« 1 (2) 3 »


Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 518
mylinks (version du 04/24/2016) fonctionne sous 2.5.8.1 même les blocks.

En mode debug j'ai eu 2 erreurs en rapport avec le module la première dans le fichier /modules/mylinks/index.php à la ligne 29 & 32 il faut supprimé le : &

La deuxième vient du fichier /modules/mylinks/include/functions.php à la ligne 202 j'ai essayé en supprimant le & mais rien y fait l'erreur persiste ?

Alors que l'erreur est la même : Only variables should be assigned by reference in

J'ai aussi cette erreur dans le fichier header.php (racine xoops) à la ligne 58 et là aussi je n'ai pas trouvé la solution mais ça n'empêche pas le module mylinks de fonctionner mmais dans le modules xoopstube ça m'empêche d'afficher les blocks.

Posté le : 10/01/2017 01:30

Version Bootstrap
4.5.3
Version font-awesome
5.15.1
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 518
Le module News 1.68 Final (07/11/2012) sur xoops 2.5.8.1

les données s'affichent mais, c'est impossible de les éditer et on ne peut pas corriger les permissions ça bug avec toujours la même erreur :
Only variables should be assigned by reference in
et y'en as un paquet :

Unknown: Only variables should be assigned by reference in file /modules/news/index.php line 130
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.sfiles.php line 46
Unknown: Only variables should be assigned by reference in file /header.php line 58
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newstopic.php line 45
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newstopic.php line 186

Unknown: Non-static method NewsStory::getAllPublished() should not be called statically in file /modules/news/index.php line 181
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 179
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 180
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 54

Unknown: Only variables should be assigned by reference in file /modules/news/xoops_version.php line 201
Unknown: Only variables should be assigned by reference in file /modules/news/xoops_version.php line 210
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 653
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 1309
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 1278

Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 605

Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 583

Unknown: Non-static method NewsStory::countPublishedByTopic() should not be called statically in file /modules/news/index.php line 217
Unknown: Only variables should be assigned by reference in file /modules/news/class/class.newsstory.php line 533
Unknown: Only variables should be assigned by reference in file /modules/news/include/functions.php line 276
Unknown: Only variables should be assigned by reference in file /modules/news/index.php line 303

je vais essayer de les corriger

Posté le : 10/01/2017 02:17

Version Bootstrap
4.5.3
Version font-awesome
5.15.1
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Semi pro
Inscrit: 08/03/2006 21:08
Messages: 1163
Salut,

Pour corriger ce type d'erreur, c'est très simple.

Tu vas à la ligne indiquée et il te suffit d'enlever le caractère "&". Exemple:

$variable_A =& $variable_B;

Devient:

$variable_A = $variable_B;

C'est tout...

Posté le : 10/01/2017 07:54
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3298
Citation :
nicemen a écrit :
Le module News 1.68 Final (07/11/2012) sur xoops 2.5.8.1

les données s'affichent mais, c'est impossible de les éditer et on ne peut pas corriger les permissions ça bug avec toujours la même erreur :
Only variables should be assigned by reference in

Dernière version anglaise de News, compatible Xoops 2.5.8.x, disponible ici :

News 1.71 Final

Posté le : 11/01/2017 13:57

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 518
Merci ! je viens juste de finir la correction de toutes les erreurs sauf celle-ci :

'/class/xoopstory.php' is deprecated since XOOPS 2.5.4, please create your own class instead.

Unknown: Non-static method NewsStory::getAllPublished() should not be called statically in file /modules/news/index.php line 181
Unknown: Non-static method NewsStory::countPublishedByTopic() should not be called statically in file /modules/news/index.php line 217

j'ai rien compris & pas trouver de solution avec Gogole

Si on peut m'expliquer comme ça à l'avenir je pourrais peut être vous aider à mettre à jour.


@Cesag: j'ai corrigé les erreurs de xoopstube mais malgré ça j'arrive pas à voir le contenu de mes blocks rien ne s'affiche et je n'ai plus d'erreur ?

Posté le : 12/01/2017 05:24

Version Bootstrap
4.5.3
Version font-awesome
5.15.1
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3298
La dernière version anglaise de Xoopstube, compatible avec Xoops 2.5.8.x se trouve ici.

Posté le : 12/01/2017 20:18

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 518
Merci !

J'ai un petit problème avec la version anglaise de xoops 2.5.8.1, j'ai mis les fichiers de langage french de xoops, des modules système, pm, profile sélectionner dans les préférences french langage mais tout s'affiche encore en anglais dans la partie administration du site ?

J'ai des templates personnalisés (modules/system) & lorsque je quitte mon site il ne m'affiche pas mon template site_closed perso ?

J'ai vidé le cache, activer Consultez les modèles pour des modifications & même essayer sans le dossier templates du modules system & c'est toujours pareil ?

Je comprends rien ... c'est les Russes ?

Posté le : 13/01/2017 12:24

Version Bootstrap
4.5.3
Version font-awesome
5.15.1
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 518
@Cesag :

J'ai téléchargé la nouvelle version de xoopstube & vue que j'ai hacker le module je suis entrain d'apporter mes modifications sur la nouvelle version & dans le dossier include de ma version j'ai un fichier function.php qui n'est pas dans la nouvelle version & comme je n'ai pas installé le module je ne sait pas si il fonctionne sans ce fichier ou si il as été oublié ?

xoopstube/admin/main.php

ce fichier aussi n'est pas pareil le miens est plus long celui la s'arrête à // Video Expire Date

C'est normal ?
moi j'ai la version 1.06 Beta1 (01-01-2013) & elle fonctionne sous xoops 2.5.8.1 à part les blocks qui ne s'affiche pas !

Posté le : 13/01/2017 15:12

Version Bootstrap
4.5.3
Version font-awesome
5.15.1
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3298
Citation :
nicemen a écrit :
Merci !

J'ai un petit problème avec la version anglaise de xoops 2.5.8.1, j'ai mis les fichiers de langage french de xoops, des modules système, pm, profile sélectionner dans les préférences french langage mais tout s'affiche encore en anglais dans la partie administration du site ?

J'ai des templates personnalisés (modules/system) & lorsque je quitte mon site il ne m'affiche pas mon template site_closed perso ?

J'ai vidé le cache, activer Consultez les modèles pour des modifications & même essayer sans le dossier templates du modules system & c'est toujours pareil ?

Je comprends rien ... c'est les Russes ?


lol bienvenue au club des bogues inexpliqués de l'informatique

Il y a aussi le cache de l'explorateur internet, à vider à l'aide de CCleaner au pire.

Vu qu'il y a une centaine de fichiers de langues à installer dans Xoops, je suppose aussi que tu dois en mettre certains qui font appel à d'autres etc.

Le mieux c'est soit tu mets ces centaines de fichiers dans Xoops, soit rien, sinon ça posera problème et en plus tu risques de rencontrer des bogues que tu vas signaler alors qu'ils ne sont pas dûs à une installation normale.

Il ne faut AUCUN bidouillage afin d'aider aux tests de Xoops

Posté le : 14/01/2017 11:09

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Compatibilité XOOPS 2.5.8 et 2.6.0
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3298
Citation :
nicemen a écrit :
@Cesag :

J'ai téléchargé la nouvelle version de xoopstube & vue que j'ai hacker le module je suis entrain d'apporter mes modifications sur la nouvelle version & dans le dossier include de ma version j'ai un fichier function.php qui n'est pas dans la nouvelle version & comme je n'ai pas installé le module je ne sait pas si il fonctionne sans ce fichier ou si il as été oublié ?

xoopstube/admin/main.php

ce fichier aussi n'est pas pareil le miens est plus long celui la s'arrête à // Video Expire Date

C'est normal ?
moi j'ai la version 1.06 Beta1 (01-01-2013) & elle fonctionne sous xoops 2.5.8.1 à part les blocks qui ne s'affiche pas !


Même chose que dit précédemment, il vaut mieux éviter les bidouillages. Nous ne pouvons pas régler les bogues dûs à des grosses modifications faites par les utilisateurs. Nous avons assez de travail comme ça

Concernant XoopsTube et ses fichiers ajoutés ou supprimés par les développeurs, je ne peux te renseigner, ils ont peut-être fait ça pour une meilleure compatibilité du module.

Posté le : 14/01/2017 11:14

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 (2) 3 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

120 Personne(s) en ligne (114 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 120 | Plus ...