Fork me on GitHub




« 1 (2) 3 4 »


Re: Alerte : Le module FAQ a disparu !
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2530
Vaudrait mieux récupérer les donnée des tables si il y a des faq désinstaller l'ancien mettre le nouveau, ajouter le plugin showhide (voir le redme.txt) et recharger la table avec les anciennes données. attention j'ai ajouté des champs, il faudra peut adapter le sql.

Si il y a des soucis avec ce module je corrigerais cette version qui est en prod chez moi.

JJDai

Posté le : 22/02 09:42

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2530
Citation :
davidm78 a écrit :
Entendu, je vais prendre ton module dans son ensemble...
J'imagine que les adaptations que tu y a faites vont m'être profitable

Je l'espère en tout cas ce n'est pas pour rien que j'ai fait les modifs.

Posté le : 22/02 09:45

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2530
En gros voici ce qui a été fait sur le module:

=> version 2.30 du 15/12/2020 (JJDai jjdelalandre@orange.fr)
------------------------------------------------------
Ajout du plugin jquery "showHide.jr" pour l'affichage "lire la suite"
Copier ou coller :
xoopsfaq_ressources/showHide.js
dans :
/xoops_lib/Frameworks/jquery/plugins/showHide.js

- Déplacement du code HTML des functions "displayAdminListing" dans des templates
class contents->displayAdminListing : admin/xoopsfaq_contents.html
class category->displayAdminListing : admin/xoopsfaq_category.html
- "color_set"
table category ajout du champ "categorys_color_set" qui permet un affichage des category par couleur
ajout des css nécéssaires dans assets/css
- Refonte complete du front office avec affichage par catégorie et utilisation du plugin "showhide"
- Ajout des permissions "admin du module", "admin des categorys", "admin des questions"
- Ajout des permissions de "visualisation par categorie" dans le front office
- Ajout des boutons d'
éditionajout et suppression pour les categories dans le front office (soumis à parmissions)
Ajout des boutons d'édition, ajout et suppression pour les questions dans le front office (soumis à parmissions)
- nettoyage partiel du code
- optimisation partielle du code
- Harmonisation du nom des constantes de langues
- Ajout d'
une option dans "xoops_version.php" permettant de conserver l'anciene interface (nouvelle inerface pa défaut)
- Categories ajout des propriétés:
show_hidetext : affiche ou non le texte "fermer" des div une fois avoir cliquer sur "lire la suite"
hidetext_align : permet d'
aligner à drite le texte "lire la suite"
Ajout de l'onglet "About"
- Révision de l'
interface admin
divers corrections:
----- 
affichage des commentaires,
----- 
constantes de langue,
----- 
indice de tableau inexistant, ...

Ajout des boutons "edit"delete", ... dans le font office soumlis à permissions


=> version 2.10 du 25/01/2016 (JJDai - jjdelalandre@orange.fr)
------------------------------------------------------
- Intégration du framework "
moduleadmin"
- adaptatation du fichier "
menu.php" pour le "blue move"
- Suppresion des images d'onglet devenues inutiles
- Ajout des icones 32x32 pour admin
- Ajout du champ "
answer" pour une réponse affichée dans les sommaire du module
- Ajout des champs seealso1 libseealso1 seealso2 libseealso2 seealso3 libseealso3
pour ajouter des liens externes sur des documentations par exemple
- Ajout des fonctions install, uninstall et update.
la fonction "
update" ajoute les nouveaux champs si nécessaires
- modification des templates pour intégrer les nouveaux champs
- correction et mise à jour des fichiers de langues

Posté le : 22/02 09:47

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 36
Arg:
[b]Installation de Xoops FAQ[/b]
You have an error in your SQL syntaxcheck the manual that corresponds to your MySQL server version for the right syntax to use near ') ENGINE=MyISAM AUTO_INCREMENT=0' at line 8


Bon, je vais voir dans le fichier sql pour adapter ça.


Également, Je me pose une question, pour installer le showHide.
Dans ton chemin, c'est .../xoops_lib/... et moi j'ai .../xoops_lib2/... , surement un choix que j'ai fait durant l'installation, mais bon, je l'ai copié dedans, j’imagine que tu as utilisé les constantes Xoops plutôt qu'un appel en absolu.

Posté le : 22/02 09:57
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2530
Citation :
j’imagine que tu as utilisé les constantes Xoops plutôt qu'un appel en absolu

tout à fait, le plugin doit être dans :
/xoops_lib/Frameworks/jquery/plugins/showHide.js


Pour le sql je regarde d'ou ça vient, je l'ai tester pourtant sur plusieurs site.

Posté le : 22/02 11:43

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 36
Je suis sur un OVH standard, sans savoir touché la config de base (je sais qu'il est sensible à la casse)

Etrange, j'ai changé par ça mais ça ne passe toujours pas:
CREATE TABLE `xoopsfaq_categories` (
  `
category_idsmallint(5unsigned NOT NULL AUTO_INCREMENT,
  `
category_titlevarchar(255NOT NULL DEFAULT '',
  `
category_ordertinyint(3unsigned NOT NULL DEFAULT '0',
  `
category_activeTINYINT(1NOT NULL DEFAULT '1',
  `
category_color_setVARCHAR(50NOT NULL default '',
  `
category_show_hidetextTINYINT(1NOT NULL DEFAULT '0',
  `
category_hidetext_alignTINYINT(1NOT NULL DEFAULT '0',
  
PRIMARY KEY (`category_id`)
ENGINE=MyISAM;


Alors que le script de mon module est passé:
CREATE TABLE comin_statuts (
  
id int(5unsigned NOT NULL auto_increment,
  
name varchar(200NOT NULL default '',
  
PRIMARY KEY (id),
  
KEY name (name)
ENGINE=MyISAM;

L'encodage des mes 2 fichiers est bien en UTF-8.
0_0

Posté le : 22/02 11:52
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2530
je suis en train de vérifier

Posté le : 22/02 11:53

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 36
Pour info, j'ai essayé les minuscules pour l'auto_increment et d'ôter les ':
CREATE TABLE xoopsfaq_categories (
  
category_id smallint(5unsigned NOT NULL auto_increment,
  
category_title varchar(255NOT NULL DEFAULT '',
  
category_order tinyint(3unsigned NOT NULL DEFAULT '0',
  
category_active TINYINT(1NOT NULL DEFAULT '1',
  
category_color_set VARCHAR(50NOT NULL default '',
  
category_show_hidetext TINYINT(1NOT NULL DEFAULT '0',
  
category_hidetext_align TINYINT(1NOT NULL DEFAULT '0',
  
PRIMARY KEY (category_id)
ENGINE=MyISAM;

mais j'ai le même problème:
Impossible d'installer xoopsfaq. Erreur(s) :
Installation de Xoops FAQ

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '
ENGINE=MyISAM' at line 8


Posté le : 22/02 12:00
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2530
Il y a une virgule en trop dans la dernière table.
Mais il y a un autre soucis, je corrige et je te tiens informer des que j'ai rectifié le module.
Il y a un problème avec les permissions.

Posté le : 22/02 12:03

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Alerte : Le module FAQ a disparu !
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 36
Bien vu la virgule, j'ai pu l'installer (le message d'erreur nous met sur une mauvaise piste)

Par contre, j'ai ce message dans ton module:
/home/takdgjg/xoops_lib/Frameworks/jquery/plugins/showHide.js
En fait, il ne cible même pas mon installation Xoops car le nom de mon utilisateur n'est pas le bon.
C'est pas "takdgjg", mais "takdgjg-monlogin".

Tant qu'à faire des modifs, il n'y a pas moyen d'embarquer ce fichier js dans le module ?

Posté le : 22/02 12:26
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 (2) 3 4 »



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

10 Personne(s) en ligne (4 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 10 | Plus ...