Fork me on GitHub






mauvaise incrémentation table user ; uid
Guest_
Bonjour,
Spirit ayant posté dans le mauvais sujet mais c'était un peu la meme chose, je poste ici pour lui puisque c'est du meme site qu'il s'agit

Alors le voila le probleme
La table x00ps_users contient "uid" en primary. lorsqu'un nouveau membre s'enregistre, il a comme "uid" : 16777215

Symptômes :
1. Le dernier membre de la liste a l'ID 165, il y a 100 enregistrements (donc des sauts d'ID, mais si je change les uid, y'aura un prob de permissions ... bref). Cela fait que le membre suivant ne peut pas s'enregistrer.

2. On remarque quand on veut exporter la bdd que quand y'a pas le nouvel utilisateur, il indique
TYPE=MyISAM AUTO_INCREMENT=166 ;

Cette ligne change après l'inscription d'un nouvel utilisateur
TYPE=MyISAM AUTO_INCREMENT=16777215 ;


Solutions envisagées :
1. Vidange des tables x00ps_online et session
2. Suppression, recréation de la table en exportant/réimportant mais je n'ai pas essayé la récréation de la table sans importer
3. Tenter de changer les uid, ca fait foirer tout au niveau permissions

Que me proposez vous? (help

Posté le : 02/03/2006 22:16

Edité par Christian sur 03/03/2006 00:51:54
Partager Twitter Partagez cette article sur GG+
Help :)
Guest_
Toute solution est la bienvenue

Posté le : 02/03/2006 22:35
Partager Twitter Partagez cette article sur GG+
Re: Help :)
Xoops accro
Inscrit: 04/02/2003 01:54
De Le Mans
Messages: 12273
Tu commences par exéctuter cette requête dans phpmyadmin afin de connaitre l'uid maximum qui a été utilisée :

select max(uid) from xoops_users;

Ensuite
- tu cliques sur la table xoops_users dans la colonne de gauche de phpMyadmin
- tu cliques sur l'onglet Opérations
- tout en bas de la page tu as "options pour cette table" auto_increment avec une valeur.
- tu mets dans la case la valeur de max(uid)+1 puis tu cliques sur le bouton Exécuter sur la droite.

Posté le : 02/03/2006 22:48
Partager Twitter Partagez cette article sur GG+
Re: Help :)
Guest_
Hem ...

requête SQLModifier

ALTER TABLE 
`x00ps_usersPACK_KEYS =0 CHECKSUM =0 DELAY_KEY_WRITE =0 AUTO_INCREMENT max(uid)+1

MySQL a répondu
:Documentation
#1064 - You have an error in your SQL syntax near 'max(uid)+1' at line 1


EDIT :
euh j'ai du mal comprendre .... je dois mettre la valeur du max(uid)( ici 166) ou max(id) , et je dois mettre des espaces quelque part?

Posté le : 02/03/2006 23:29
Partager Twitter Partagez cette article sur GG+
Re: Help :)
Xoops accro
Inscrit: 04/02/2003 01:54
De Le Mans
Messages: 12273
- fais une sauvegarde de ta table xoops_users
- dans phpmyadmin, structure, modifie le champ uid , tout au bout à droite dans extra et supprime le champ autoincrément, tu valides
- tu recommences pour le remettre
- tu observes ce qui se passe (j'ai pas essayé)

Posté le : 02/03/2006 23:39
Partager Twitter Partagez cette article sur GG+
Re: Help :)
Guest_
Apparemment, cela fonctionne

Citation :
Edit Delete 166 test1 jibi049 at hotmail.com


Merci beaucoup

Posté le : 02/03/2006 23:53
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

10 Personne(s) en ligne (4 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 10 | Plus ...