Fork me on GitHub






Probleme UFT-8 - Page accueil
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
Bonjour et bon Week End !

Pour feter l'arrivee de Noel, j'ai changé mon theme pour un theme de Noel . j'y ai adjoint neige en java et fond sonore.

Tout semble correct sauf un probleme de caracteres UFT-8 qd je reclicke sur accueil .
Toutes les autres pages semblent correctes , et des que je reviens en page d'accueil : zou probleme de caracteres.

Meme en retirant la neige et le fond sonore le probleme semble identique.

Xoops 2.5
Theme Maitsco Noel

Script theme.html :

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<
html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<{$xoops_langcode}>" lang="<{$xoops_langcode}>">


<
head>
<
meta http-equiv="content-type" content="text/html; charset=windows-1252" />
<
meta http-equiv="content-language" content="<{$xoops_langcode}>" />
<
meta name="robots" content="<{$xoops_meta_robots}>" />
<
meta name="keywords" content="<{$xoops_meta_keywords}>" />
<
meta name="description" content="<{$xoops_meta_description}>" />
<
meta name="rating" content="<{$xoops_meta_rating}>" />
<
meta name="author" content="<{$xoops_meta_author}>" />
<
meta name="copyright" content="<{$xoops_meta_copyright}>" />
<
meta name="generator" content="Microsoft FrontPage 5.0" />
<
meta name="ProgId" content="FrontPage.Editor.Document">
<
title><{$xoops_sitename}> - <{$xoops_slogan}></title>
<
link href="<{$xoops_url}>/favicon.ico" rel="SHORTCUT ICON" />
<
link rel="stylesheet" type="text/css" media="screen" href="<{$xoops_url}>/xoops.css" />
<
link rel="stylesheet" type="text/css" media="all" title="Spring coming" href="<{xoImgUrl /style.css}>" />
<
link rel="alternate stylesheet" type="text/css" title="Valentine" href="<{xoImgUrl /red.css}>" />
<
link rel="alternate stylesheet" type="text/css" title="Spaces" href="<{xoImgUrl /blue.css}>" />

<
link href="style.css" rel="stylesheet" type="text/css" />

<{
$xoops_module_header}>

<
script type="text/javascript" src="http://www.hkrag.fr/themes/hkrag-noel/snow/script/snowstorm.js"></script>
<script type="text/javascript" src="http://www.hkrag.fr/themes/hkrag-noel/js/styleswitcher.js"></script>

<!--[if lt IE 7]>
    <script type="text/javascript">
        var WEBFX_PNG_PATTERN=".*/images/.*.png";
        var WEBFX_PNG_BLANK = "<{xoImgUrl images/blank.gif}>";
    </script>
    <style type="text/css">
        img { behavior: url(<{xoImgUrl /js/pngbehavior.htc}>); }
        }
    </style>
<![endif]-->    

<script type="text/javascript" src="<{$xoops_imageurl}>/js/styleswitcher.js"></script>
</head>


Sur le Site
http://www.hkrag.fr

Si une ame charitable pouvait m'aider ... pour Noel !

Par avance MERCI

Posté le : 27/11/2010 06:13
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Xoops accro
Inscrit: 27/07/2005 16:10
De France
Messages: 2970
As tu essayer de mettre ce code dans ton theme?

<meta http-equiv="content-type" content="text/html;charset=UTF-8" />

Posté le : 27/11/2010 08:46
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
Merci
L'idee etait belle et simple, et donc me plaisait bcp !
Mais helas ca ne suffit pas ... le probleme persiste
Merci

Posté le : 27/11/2010 08:57

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Xoops accro
Inscrit: 27/07/2005 16:10
De France
Messages: 2970
ta vidé tes caches xoops ?

Posté le : 27/11/2010 08:58
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
Oui et aussi cache sur mon pc.

Posté le : 27/11/2010 08:59

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Xoops accro
Inscrit: 27/07/2005 16:10
De France
Messages: 2970
dans les paramètres généraux de xoops, la ligne Actualisation des thèmes et templates pour voir les modifications ? est bien sur oui

Posté le : 27/11/2010 09:00
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
oui
mais je n'ai pas regeneré les templates dans le theme ... ca me fait une erreur

Error : Smarty error: [in db:news_block_top.html line 915]: syntax error: unidentified token '#039;counter'' (Smarty_Compiler.class.php, line 1410)

j'ai donc supprimé le dossier module dans le theme (mais je ne pense pas que les 2 problemes aient un rapport) ?

Posté le : 27/11/2010 09:03

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
avec firebug il semble ne pas trouver un
style.css (partie html) a la racine de mon site
??? mais il le trouve dans css.

En partie Js il semble charger 2 fois le styleswitcher.js
??? edit : ce point la est resolu mais ca ne resoud pas le probleme UFT-8

Posté le : 27/11/2010 09:07

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Xoops accro
Inscrit: 20/02/2008 20:27
De Belgium
Messages: 2708
<meta http-equiv="content-type" content="text/html; charset=windows-1252" />

<
meta http-equiv="content-type" content="text/html;charset=UTF-8" />

Vous avez 2 meta pour le charset. Enlevez une.

Posté le : 27/11/2010 10:08

Salutations, Gerard.
PS: Excusez mon mauvais français.
De la bonne manière de poser les questions
Partager Twitter Partagez cette article sur GG+
Re: Probleme UFT-8 - Page accueil
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
oups et Merci,
là, il faut que je m'excuse platement ...
j'aurais du la voir celle là

donc,

Toutes mes excuses et Merci

Posté le : 27/11/2010 10:59

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

45 Personne(s) en ligne (29 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 45 | Plus ...