Fork me on GitHub




« 1 ... 3 4 5 (6) 7 »


Re: Module léger pour boutique en ligne
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2619
ah oui, il faut au minimum GD2 version 2.1 minimum, il faudrait que je pense a le préciser mieux. En général les hébergeurs mettent à jour leurs librairies (du moins ceux que je connais). Mais c'est vrai que pour les serveurs de tests les mises à jour ne sont pas automatique.
Je te conseillerai même de changer de version PHP (5.3.x) car les version 5.2.x ne sont plus supportés et pour faire les tests sous Xoops, beaucoup de modules fonctionnent sans problème sous PHP 5.2 mais ont des bugs (ou carrément des pages blanches coté admin) sous PHP 5.3.x

Posté le : 21/04/2013 16:37
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 07/08/2006 13:03
Messages: 1717
Bonjour,
J'ai fait mise a jour, et nouvelle installation avec la dernière archive.
Pas de probleme majeur, au dela des petits soucis de mails et de tva. Comme il semble que je n'ai pas une GD2 suffisament recente , je n'ai pas les miniatures.

Posté le : 21/04/2013 21:51
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 08/11/2011 16:26
Messages: 92
1) Comme j'ai Mamp Version 2.1.1 (2.1.1) gratuit sur Mac, je n'ai pas encore PHP 5.3 (version PRO), mais 5.2 et 5.4; immédiatement, je suis passé à 5.4; MiniBoutique fonctionne, puis remis à 5.2 (en attente d'achat de Mamp Pro). MiniBoutique fonctionne. J'ai le catalogue des produits, J'ai les vignettes (en catalogue de produit) et les images agrandies en fiche produit. (qu'apporte GD2.1 sur cet état de fait, qui semble correct ?)

2) il serait bon, quand on clique sur "commander" qu'un message furtif apparaisse (ou qu'un champ texte soit renseigné): "commande passée", pour que l'on soit bien assuré d'avoir cliqué correctement sur le bouton "commander";
à moins de préférer qu'une modification d'apparence d'icone se manifeste quelque part (icône de produit pré-commande/disponible/indisponible (stock)-acheté/commandé/disponible (utilisateur))
Enfin, l'essentiel serait qu'on ne clique pas deux fois sur le bouton "commander" par scrupule, par absence d'information sur l'action faite immédiatement.

3) Si je renseigne le champ "Complément d'adresse", le renseignement n'apparait pas, pour autant dans "mes coordonnées", mais apparait bien sur le bon de commande. C'est peut-être justifié, auquel cas...ne pas prendre en compte.


4) si j'imprime le bon de commande en pdf (php 5.2 et 5.4), crash :

Citation :
TCPDF ERROR: Some data has already been output, can't send PDF file
Aucun Tout Erreur(s) (14) Deprécié(s) (0) Requête(s) (76) Bloc(s) (0) Extra (5) Temporisation(5)
Erreur(s)
Avertissement(s): include_once(/modules/multisite/class/formcheckboxdomains.php) [function.include-once]: failed to open stream: No such file or directory dans le fichier /class/xoopsformloader.php - ligne 53
Avertissement(s): include_once() [function.include]: Failed opening '/modules/multisite/class/formcheckboxdomains.php' for inclusion (include_path='.:/Applications/MAMP/bin/php/php5.2.17/lib/php') dans le fichier /class/xoopsformloader.php - ligne 53
Avertissement(s): include_once(/modules/multisite/class/formselectdomains.php) [function.include-once]: failed to open stream: No such file or directory dans le fichier /class/xoopsformloader.php - ligne 54
Avertissement(s): include_once() [function.include]: Failed opening '/modules/multisite/class/formselectdomains.php' for inclusion (include_path='.:/Applications/MAMP/bin/php/php5.2.17/lib/php') dans le fichier /class/xoopsformloader.php - ligne 54
Message(s): Use of undefined constant _MI_MARQUEE_NAME - assumed '_MI_MARQUEE_NAME' dans le fichier /modules/marquee/xoops_version.php - ligne 28
Message(s): Use of undefined constant _MI_MARQUEE_NAME - assumed '_MI_MARQUEE_NAME' dans le fichier /modules/marquee/xoops_version.php - ligne 28
Message(s): Constant _MI_RSSC_ADMENU_CONFIG already defined dans le fichier /modules/rssc/language/french/modinfo.php - ligne 43
Message(s): Constant _MI_RSSC_ADMENU_LINKLIST already defined dans le fichier /modules/rssc/language/french/modinfo.php - ligne 44
Message(s): Use of undefined constant _MI_RSSC_BNAME_MAP - assumed '_MI_RSSC_BNAME_MAP' dans le fichier /modules/rssc/xoops_version.php - ligne 119
Message(s): Undefined variable: i dans le fichier /modules/xhelp/xoops_version.php - ligne 494
Message(s): Constant _XA_HTACCESS already defined dans le fichier /modules/xreaggregator/language/english/modinfo.php - ligne 38
Message(s): Constant _XA_HTACCESS_DESC already defined dans le fichier /modules/xreaggregator/language/english/modinfo.php - ligne 39
Message(s): Constant _MI_LX_TERM_APPROVE_NOTIFYSBJ already defined dans le fichier /modules/lexikon/language/french/modinfo.php - ligne 253
Message(s): Use of undefined constant _AM_LX_IMPORT - assumed '_AM_LX_IMPORT' dans le fichier /modules/lexikon/admin/menu.php - ligne 54


Posté le : 22/04/2013 11:21
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 07/08/2006 13:03
Messages: 1717
il y a un Javascript qui ouvre un pop up, pour la validation de la commande . Je ne pense pas qu'on puisse cliquer deux fois. D'autre part, a l'issue de la commande, on est redirigé sur l.historique des commandes passées . Il me semble que c'est suffisamment explicite, non?

Je n'ai aucun problème d'affichage lors de l'impression d'un pdf .

De mon côté, je suis sur un site déjà en production.

Posté le : 22/04/2013 12:15
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 08/11/2011 16:26
Messages: 92
J'en conclus que c'est mon installation propre (en mode local) qu'il me faut vérifier.

Posté le : 22/04/2013 12:37
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 07/08/2006 13:03
Messages: 1717
Ainsi que les permissions !!! Je suis un imbécile . Mes dossiers d upload étaient en 770. En 755, j'ai maintenant les images! Idiot que je suis ...

@montuy, pour l'instant je suis sur un iPad, c pas très pratique. Des que j'ai accès à mon Pc, je pourrais approfondir les tests avec motifs de fichiers...

Posté le : 22/04/2013 13:00
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2619
Le problème de l'impression du PDF est dû à la version du Frameworks que tu utilises, à la rigueur tu peux installer la dernière version du Frameworks sur un PHP 5.2 malgré le message d'avertissement, il fonctionnera à 98%, seul des fonctionnalités spécifiques (comme le QR-code) ne fonctionneront pas.

Et il est impossible de commander 2 fois, vu que le panier est systématiquement détruit lors de la création de la commande.

Citation :

Mes dossiers d upload étaient en 770. En 755

C'est vrai que certains hébergeurs sont laxistes côté configuration !!!

Posté le : 22/04/2013 13:02
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 08/11/2011 16:26
Messages: 92
Comme j'avais cette information :
Citation :
Frameworks TCPDF_for_xoops version 1.05 minimum : Présent

je m'en inquiétais pas.
situation : tcpdf_for_xoops_1.06 installé dans htdocs/frameworks/

toujours page blanche avec message d'erreur:

Citation :
TCPDF ERROR: Some data has already been output, can't send PDF file

Peut-il y avoir un conflit, voire un simple état chaotique sous-jacent à l'aspect normal du fonctionnement du site local, avec les moults modules anciens et récents que j'ai pu installer, désinstaller, réinstaller, redésinstaller ?

Ceci dit, je ne vais pas trop vous prendre la tête avec çà; je vais regarder tranquillement; temps au temps.

Posté le : 22/04/2013 14:58
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Team FrXoops
Inscrit: 07/08/2006 13:03
Messages: 1717
Je vote pour la miniboutique comme module de l'année !

Change ton tcpdf par celui indiqué dans l'admin du module

Posté le : 22/04/2013 15:08
Partager Twitter Partagez cette article sur GG+
Re: Module léger pour boutique en ligne
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2619
je vais mettre en ligne une version 1.23 qui corrige une petite coquille qui était resté en arrière.

Posté le : 22/04/2013 15:38
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 ... 3 4 5 (6) 7 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

48 Personne(s) en ligne (40 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 48 | Plus ...