Fork me on GitHub




« 1 2 (3) 4 5 »


Re: xoops 2.5.7 final - fr
Semi pro
Inscrit: 13/02/2006 17:40
De Belgique
Messages: 812
Citation :
Pour t'aider il nous faut plus de précision, quels fichiers te manque-t-il réellement ? Certainement pas tous, ou alors tu t'es trompé d'endroit où mettre les fichiers checksum. Si tu suis les instructions, il est dit dans le fichier " README_UPGRADE_TO_2.5.7.txt", je cite : Citation : 12) Lancez le fichier : http://VOTRESITE.com/checksum.php et assurez-vous que vous avez tous les fichiers. Bien sûr, le dossier /install et ses fichiers n'y seront pas, de même pour les dossiers /xoops_lib et /xoops_data, si vous les avez déplacé ailleurs. Si il te manque des fichiers ou dossiers, il faut que tu saches lesquels et que tu les envois sur ton ftp.


Je te confirme Cezag, TOUS LES FICHIERS S'AFFICHENT COMME ÉTANT ABSENTS

Je t'envoie copie en MP



Posté le : 31/07/2014 12:51
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3129
Mon pseudo c'est Cesag au fait

En attendant une correction, ceux qui ont besoin de tester, prenez les fichiers "checksum" sur le Sourceforge de xoops.org

Posté le : 01/08/2014 07:58

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Semi pro
Inscrit: 13/02/2006 17:40
De Belgique
Messages: 812
Donc, je précise que j'avais bien placé le checksum.php au premier niveau du site.

Je viens de prendre le checksum.php de la 2.5.7 et effectivement le résultat n'est pas le même. (Il n'est déjà plus en français, mais en anglais)

Avec celui-ci je me rends compte que:

Ces fichiers sont absents:

./class/cache/apc.php content invalid
./class/cache/file.php content invalid
./class/cache/memcache.php content invalid
./class/cache/model.php content invalid
./class/cache/xcache.php content invalid
./class/file/file.php content invalid
./class/file/folder.php content invalid

Je les ai rajouté


Que celui-ci est présent, mais pas le même:

./images/logo.gif content invalid

Je l'ai remplacé

Que licence.php existe, mais le nouveau possède une licence
000000-000000-000000-000000-000000

./include/license.php content invalid

Dois-je aussi le remplacer ?

Il y a bien-sûr d'autres fichiers dits "manquants", et en grand nombre, que je devrais vérifier. Mais n'aurais-je pas plutôt intérêt à recommencer une mise à jour ?

J'ai du mal à comprendre que mon site fonctionne malgré tout

A moins qu'il y ai des paramètres non-fonctionnels que je n'ai pas encore constaté.





Posté le : 01/08/2014 14:42
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2610
ou que le checksum.php ne soit pas à jour.


Posté le : 01/08/2014 14:47
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Semi pro
Inscrit: 13/02/2006 17:40
De Belgique
Messages: 812
Voici un return complet des différents problèmes constatés:


Suite à ceux relatés par le contrôle avec checksum.php...



J'ai placé les fichiers dont "mention ci-dessus" (ils n'y étaient pas):

./class/cache/apc.php content invalid
./class/cache/file.php content invalid
./class/cache/memcache.php content invalid
./class/cache/model.php content invalid
./class/cache/xcache.php content invalid
./class/file/file.php content invalid
./class/file/folder.php content invalid

... mais après relance du checksum.php, malgré qu'ils sont placés sur le serveur, les mêmes messages reviennent



Ce fichier ne s'y trouvait pas, je l'ai rajouté:

./modules/protector/admin/advisory2.php missing !


Ceux-ci s'y trouvaient, et après les avoir confondu (programme WinMerge)avec les fichiers du dossier Xoops 2.5.7, il s'avère qu'il n'y avait que des différences de dates, ou des décalages de codes. Rien d'important. MAIS checksum.php signale cependant ces différences:

./modules/system/admin/groupperm.php content invalid
./modules/system/admin/modulesadmin/main.php content invalid
./modules/system/admin/groupperm.php content invalid
./modules/system/admin/modulesadmin/main.php content invalid
./modules/system/admin/modulesadmin/modulesadmin.php content invalid



Idem pour ce type de fichier:

./uploads/avatars/blank.gif content invalid



Concernant les premiers problèmes cités:


- En mode debug, ce problème apparait encore:

Avertissement: preg_match(): Delimiter must not be alphanumeric or backslash dans le fichier xoops_lib/modules/protector/class/protector.php ligne 1043



- Celui-ci demeure aussi: Les champs apparaissent ... voir ces images:


Citation :
TinyMCE 3.5.11 qui est avec la nouvelle version Xoops 2.5.7 (PHP 5.4), j'ai des champs qui apparaissent lorsque je clique sur le petit "point d'interrogation" = aide. http://www.ayeti.be/xoops/Aide-TinyMC ... problemes-de-champs-1.jpg http://www.ayeti.be/xoops/Aide-TinyMC ... problemes-de-champs-2.jpg

Ce problème apparait également en cliquant sur "insérer une ancre" ou en cliquant sur "Editer le code source html"



- TinyMCE est prioritaire dans les "préférences générales", et je tombe toujours sur l'éditeur basic. Comment avoir directement TinyMCE comme éditeur par défaut ?


- Rien de changé non plus pour ceci (très important cependant):


Citation :
2) Alors, j'avais déjà le problème avant la mise à jour, mais elle demeure avec 2.5.7 : Lorsque je clique sur le pseudo d'un membre pour voir son profil et/ou lui écrire, il me dirige vers mon profil au lieu du sien. Pourtant je suis admin du site.






Posté le : 01/08/2014 18:13
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Admin Frxoops
Inscrit: 05/03/2005 05:20
De Vaucluse
Messages: 959
Citation :
Avertissement: preg_match(): Delimiter must not be alphanumeric or backslash dans le fichier xoops_lib/modules/protector/class/protector.php ligne 1043
Peux tu nous en dire plus (théme utilisé, à quel endroit tu trouves cette erreur) Personnellement sur une 2.5.7 neuve, je n'arrive pas à trouver cette erreur.

Citation :
Alors, j'avais déjà le problème avant la mise à jour, mais elle demeure avec 2.5.7 : Lorsque je clique sur le pseudo d'un membre pour voir son profil et/ou lui écrire, il me dirige vers mon profil au lieu du sien. Pourtant je suis admin du site.
Pas lié à la 2.5.7, je pencherai plutôt pour un problème de droits quelquepart.

Posté le : 01/08/2014 19:04

Open in new window

Xoops 2.5.7.2 - Debian 8.2 - Apache 2.4.10 - MySQL 5.5.47 - Php 5.6.17
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Semi pro
Inscrit: 13/02/2006 17:40
De Belgique
Messages: 812
Bonjour Slider,merci pour ton aide.

Citation :
Peux tu nous en dire plus (théme utilisé, à quel endroit tu trouves cette erreur) Personnellement sur une 2.5.7 neuve, je n'arrive pas à trouver cette erreur.


J'utilise Morphogenesis 3.1.4, le dernier.
Cette erreur s'affiche sur tous les modules et pages que je visite. Dans mon cas il s'agit d'une mise à jour.

Citation :
Pas lié à la 2.5.7, je pencherai plutôt pour un problème de droits quelquepart.



J'ai fait tout le tour, je ne vois pas où je pourrais encore changer ces "problèmes de droits"

Posté le : 03/08/2014 03:41
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Semi pro
Inscrit: 13/02/2006 17:40
De Belgique
Messages: 812
Y a quelqu'un ?

Posté le : 06/08/2014 14:35
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2610
c'est pas un problème lié a Smarty et au thème ???

Je n'utilise pas ce thème (et je ne l'ai pas sous la main) donc je peux pas tester plus loin, mais, possible que l'URL vers la fiche user n'est pas la bonne, et comme tu es admin, il te renvoi bêtement à la tienne (et suffit qu'il y a un bug jQuery, tu n'as pas le message d'erreur qui s'affiche dans sa bulle)
Idem en poussant encor plus loin la réflexion, vérifier les fichiers htaccess pour voir si il n'y a pas de redirection défini et qui font pointer vers une fausse URL (ou un faut id)


Posté le : 06/08/2014 15:43
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5.7 final - fr
Semi pro
Inscrit: 13/02/2006 17:40
De Belgique
Messages: 812
Les deux problèmes que tu évoques ne semblent pas les bons.

Je rappelle que j'avais déjà ce problème avec la version de Xoops 2.5.6. et un thème zetagenesis.
Que j'ai essayé tous les thèmes, y comprit bien-sûr celui par défaut, et rien ne change.

Pour le jQuery, n'aurait-il pas été remplacé avec la mise à jour à la 2.5.7 ?

Pour les htaccess, je ne trouve rien non plus. Ce serait lequel ?

Posté le : 08/08/2014 23:46
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 2 (3) 4 5 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

34 Personne(s) en ligne (26 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 1 | Invité(s): 33 | Sylvie, Plus ...