Fork me on GitHub






Erreur à l'installation du module Mytube
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Bonjour, voilà je viens télécharger la nouvelle versions de Easy PHP ainsi que xoops 2.5.5 & 2.6.1 !

Alors xoops 2.5.5 à l'install me génère un roman d'erreur donc j'ai laissé tombé, j'ai testé l'install du 2.6.1 & la parfait !

Ensuite j'ai voulu installer les modules dont je me sert le plus, & pour commencer Mytube mais voilà je me retrouve avec une erreur !?

xoops_getHandler('module') is deprecated. See how to replace it in file C:\EasyPHP\www\Website\xoops 2.6.1\include\functions.php line 30

Auriez vous la solution au problème ?
Est ce qu'une mise à jour de ce module est prévu ?

Car j'ai une base de donnée bien remplis & si je perd ce module alors je laisse tomber le web (xoops) car je n'ai pas envie de recommencer un travail en permanence qui me rapporte rien ! Surtout qu'as chaque mise à jour du Core de Xoops je permet en moyenne 1 module ainsi que sa base données !

Euh ... je sait que c'est gratuit mais mon travail (administration xoops) est lui aussi gratuit & je ne peux avancer si à chaque fois je reviens en arrière ;)

Merci, m’en vais tester l'install de mes autres modules

Posté le : 08/11/2012 03:33

Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Erreur à l'installation du module Mytube
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Ah ... j'ai deux autres erreur sur ce module, + des erreurs sur le module rssc ? voici la liste :

Strict: Only variables should be assigned by reference in file /modules/mytube/xoops_version.php line 170
Strict: Only variables should be assigned by reference in file /modules/mytube/xoops_version.php line 171
Notice: Use of undefined constant _MI_RSSC_NAME - assumed '_MI_RSSC_NAME' in file /modules/rssc/xoops_version.php line 45
Notice: Use of undefined constant _MI_RSSC_DESC - assumed '_MI_RSSC_DESC' in file /modules/rssc/xoops_version.php line 46
Notice: Use of undefined constant _MI_RSSC_SMNAME_HEADLINE - assumed '_MI_RSSC_SMNAME_HEADLINE' in file /modules/rssc/xoops_version.php line 76
Notice: Use of undefined constant _MI_RSSC_BNAME_LATEST - assumed '_MI_RSSC_BNAME_LATEST' in file /modules/rssc/xoops_version.php line 87
Notice: Use of undefined constant _MI_RSSC_BNAME_HEADLINE - assumed '_MI_RSSC_BNAME_HEADLINE' in file /modules/rssc/xoops_version.php line 95
Notice: Use of undefined constant _MI_RSSC_BNAME_REFRESH - assumed '_MI_RSSC_BNAME_REFRESH' in file /modules/rssc/xoops_version.php line 103
Notice: Use of undefined constant _MI_RSSC_BNAME_BLOG - assumed '_MI_RSSC_BNAME_BLOG' in file /modules/rssc/xoops_version.php line 111
Notice: Use of undefined constant _MI_RSSC_BNAME_MAP - assumed '_MI_RSSC_BNAME_MAP' in file /modules/rssc/xoops_version.php line 119
Strict: Only variables should be assigned by reference in file /modules/mytube/xoops_version.php line 170
Strict: Only variables should be assigned by reference in file /modules/mytube/xoops_version.php line 171
Notice: Use of undefined constant _MI_RSSC_NAME - assumed '_MI_RSSC_NAME' in file /modules/rssc/xoops_version.php line 45
Notice: Use of undefined constant _MI_RSSC_DESC - assumed '_MI_RSSC_DESC' in file /modules/rssc/xoops_version.php line 46
Notice: Use of undefined constant _MI_RSSC_SMNAME_HEADLINE - assumed '_MI_RSSC_SMNAME_HEADLINE' in file /modules/rssc/xoops_version.php line 76
Notice: Use of undefined constant _MI_RSSC_BNAME_LATEST - assumed '_MI_RSSC_BNAME_LATEST' in file /modules/rssc/xoops_version.php line 87
Notice: Use of undefined constant _MI_RSSC_BNAME_HEADLINE - assumed '_MI_RSSC_BNAME_HEADLINE' in file /modules/rssc/xoops_version.php line 95
Notice: Use of undefined constant _MI_RSSC_BNAME_REFRESH - assumed '_MI_RSSC_BNAME_REFRESH' in file /modules/rssc/xoops_version.php line 103
Notice: Use of undefined constant _MI_RSSC_BNAME_BLOG - assumed '_MI_RSSC_BNAME_BLOG' in file /modules/rssc/xoops_version.php line 111
Notice: Use of undefined constant _MI_RSSC_BNAME_MAP - assumed '_MI_RSSC_BNAME_MAP' in file /modules/rssc/xoops_version.php line 119

Aidez moi S.V.P


Posté le : 08/11/2012 03:49

Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Erreur à l'installation du module Mytube
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2611
Les modules pour Xoops 2.5.5 ne sont pas 100% compatible avec Xoops 2.6.x, un énorme travail devra être fait pour adapter les modules, de plus la plupart des modules sont conçu pour fonctionner sur PHP 5.0 , 5.1 et 5.2 (voir 4.x), Xoops 2.5.5 génère des erreurs en PHP 5.4 (dû a l'abandon de certaines fonctions PHP), idem certains modules ne fonctionnent pas sous PHP 5.3.

Posté le : 08/11/2012 09:00
Partager Twitter Partagez cette article sur GG+
Re: Erreur à l'installation du module Mytube
Team FrXoops
Inscrit: 07/08/2006 13:03
Messages: 1717
J'ajoute que 2.6 n'est pas en version finale.
Je t'invite a commencer par 2.5.4. et éventuellement à tenter une mise à jour vers 2.5.5 si toutes les fonctions souhaitées fonctionnent

Posté le : 08/11/2012 09:04
Partager Twitter Partagez cette article sur GG+
Re: Erreur à l'installation du module Mytube
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 509
Ok message reçu merci !
Mon site tourne actuellement avec xoops 2.5.4 !
Et comme j'essaye de suivre le mouvement j'ai installer le 2.6 en Local pour tester. Mais en local j'ai souvent des problème car j'ai pas une bonne connaissance en PHP & les serveur wamps & Easy PHP mais j'ai vu qu'il y'avait différent version de Appache donc merci pour l'infos !
Jusqu'as maintenant je me suis surtout pris la tête pour faire des modules, templates personalisé & rentrer des données ...
Encore merci !

Posté le : 10/11/2012 13:45

Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

32 Personne(s) en ligne (25 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 32 | Plus ...