Fork me on GitHub




« 1 (2) 3 »


Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
En effet j'ai supprimé 2 fichiers .htaccess

dans :

uploads/
et
uploads/avatars/

car sinon j'avais ce message :

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Posté le : 28/11/2010 08:40
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
et le fait de les supprimer a t il resolu le probleme d'avatars ?

Posté le : 28/11/2010 08:42

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Le fait de les supprimer, me permet de voir toutes les images qui ne s'affichaient pas dans le dossier uploads et a permis à ce que je choisisse un avatar dans la liste d'avatars.
Mais lorsque je confirme la selection de mon avatar, j'ai une popo up qui me dit "votre profil a été mis à jour!", mais en fait non, l'avatar n'a pas été pris en compte.

Posté le : 28/11/2010 09:08
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Voici mes erreurs log du serveur quand je laisse les fichiers .htaccess:

/uploads/.htaccessAddHandler not allowed hererefererhttp://xxx.com/modules/newbb/viewtopic.php?topic_id=4

/uploads/.htaccessAddHandler not allowed hererefererhttp://xxx.com/modules/newbb/viewtopic.php?topic_id=4

/uploads/.htaccessAddHandler not allowed here

Posté le : 28/11/2010 09:16
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Régulier
Inscrit: 11/10/2010 10:47
Messages: 204
la ca depasse un peu mes competences, mais peut etre essayer de uploader un avatar perso , et d'utiliser celui la ...

Posté le : 28/11/2010 09:19

Retrouvez moi sur http://www.hkrag.fr
Autre : http://www.cdf-groupe.org
Solutions Hebergement Xoops: http://www.cdfi-hebergement.com
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Oui en téléchargeant un avatar à partir de mon ordinateur tout fonctionne mais je souhaite que tous mes membres choisissent leur avatar dans la liste d'avatars, voilà pourquoi je demande l'aide de gens plus compétents que moi

Merci à vous d'avoir tenté de m'aider ;)

Posté le : 28/11/2010 09:24
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Xoops accro
Inscrit: 20/02/2008 20:27
De Belgium
Messages: 2708
Probablement, votre serveur ne donne pas permission pour adapter certaines variables du php.ini
Enlevez un par un des lignes dans l'.htacces en gardant le maximum.

Posté le : 28/11/2010 11:27

Salutations, Gerard.
PS: Excusez mon mauvais français.
De la bonne manière de poser les questions
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Merci Ghia pour votre réponse.

Sur :


# secure directory by disabling script execution
AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi .php5 .php4 .php3 .phps
Options -ExecCGI -Indexes


Les lignes ci-dessous empêchent que les images s'affichent et m'indiquent une erreur lorsque je veux afficher ces images :

AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi .php5 .php4 .php3 .phps
Options 
-ExecCGI -Indexes


Mais même si je laisse cette ligne dans le .htaccess :

# secure directory by disabling script execution


les avatars que je sélectionne dans la liste ne sont toujours pas pris en compte.

Le propriétaire du serveur est un ami, que dois t'il faire pour autoriser ces commandes sur son serveur?

Posté le : 28/11/2010 12:02
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Le propriétaire du serveur a autorisé les commandes du .htaccess

Maintenant, même avec les .htaccess remis comme à l'origine, cela ne fonctionne toujours pas.

Je n'ai plus d'erreurs de log du serveur.

Que faire?

Posté le : 28/11/2010 12:31
Partager Twitter Partagez cette article sur GG+
Re: xoops 2.5 problèmes avatars
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Bonsoir,

j'ai modifié :

if (=== strpos($oldavatar_pathXOOPS_UPLOAD_PATH) && is_file($oldavatar_path)) {


par

if (false === strpos($oldavatar_pathXOOPS_UPLOAD_PATH) && is_file($oldavatar_path)) {



du modules/profile/edituser.php

mais toujours pas de changement, je n'arrive pas à valider un avatar de ma liste d'avatars.

J'ai vu que suite à ma demande, une autre personne a eut ce soucis mais les réponses données ne m'ont toujours pas aidées à résoudre le problème.

Je repose les questions :

-quelqu'un aurait une solution ou idée du bug que je rencontre?

- est-ce quelqu'un aurait installé Xoops 2.5 vierge et que vous arrivez à valider un avatar de la liste des avatars?

J'ai activé le mode debug mais aucune erreur s'affiche.

Posté le : 29/11/2010 00:50
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 (2) 3 »



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

25 Personne(s) en ligne (19 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 25 | Plus ...