Fork me on GitHub




(1) 2 3 4 ... 6 »


xoopspoll dans newbb
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 309
Bonjour,

Je n'arrive pas à activer les sondages dans le forum. Dans l'admin de newbb (préférences), rien ne s'affiche dans le menu de sélection en face de "Module de sondage Xoops :"

Xoopspoll est bien installé, et fonctionnel indépendamment de newbb.

Je ne vois pas d'erreur, sauf deux warning :

NotificationUndefined variablei dans le fichier /modules/xoopspoll/admin/menu.php ligne 48
Notification
Undefined variablei dans le fichier /modules/xoopspoll/admin/menu.php ligne 54


Merci de votre aide !

---------------
XOOPS 2.5.10
PHP 7.3
newbb : 4.34 Final
xoopspoll : 1.4 Final

Posté le : 01/04 11:27

Open in new window
18 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3389
Je te conseille d'essayer avec la dernière version de Newbb :

Newbb 5.01 beta 4

Posté le : 02/04 01:28

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3389
Sinon, vu que nous en sommes à la version 2.01 beta 1 de XoopsPoll, je vais la traduire et la proposer en téléchargement.
Tu ne devrais plus avoir de messages d'erreurs éventuellement dus à une version PHP plus récente.

Posté le : 03/04 01:54

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 309
Merci Cesagonchu, je regarde tout ça vite.

Posté le : 03/04 15:28

Open in new window
18 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 309
Malheureusement même sur une instal neuve de newbb 5.01 et xoopspoll 1.4 ou 2.01 je n'arrive pas à les faire cohabiter, diverses erreurs selon des pages. J'ai pas le temps pour l'instant d'y voir plus clair. Juste, dites moi si quelqu'un utilise encore les sondages dans les forums avec succès, dans ce cas je regarderai plus précisément !

Posté le : 06/04 10:51

Open in new window
18 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3389
Alors, dans ton install toute neuve, tu as testé avec quel Xoops ?

Car si je comprends bien, tu testes avec un Xoops 2.5.10 FR, un Newbb FR et un XoopsPoll anglais ?

Car là je suis en train de traduire le XoopsPoll 2.01 Beta 1.

Posté le : 06/04 11:18

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 309
Citation :
Cesagonchu a écrit :
Car si je comprends bien, tu testes avec un Xoops 2.5.10 FR, un Newbb FR et un XoopsPoll anglais ?

C'est ça !

Citation :
Car là je suis en train de traduire le XoopsPoll 2.01 Beta 1.

Top, merci ! Pas contre il va falloir quand même passer par le debugage car les fichiers de langue ne vont pas résoudre le problème.

Posté le : 07/04 20:43

Open in new window
18 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3389
Justement, je n'ai pas de bogue moi, c'est pour ça que j'essaye de comprendre ta configuration mais peut-être que c'est ta façon d'installer qui n'est pas bonne.

Peux-tu préciser tout ce que tu as fait pas à pas ?

Posté le : 08/04 04:10

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Régulier
Inscrit: 04/02/2003 08:53
De Paris
Messages: 309
Si ça fonctionne chez toi, je vais recommencer à fouiller !

J'ai juste installé les deux modules, et j'ai vérifié dans les permissions de newbb que je pouvais créer un sondage et voter.

Lorsque je clique sur "Ajouter un sondage" depuis le forum, je peux créer une nouvelle discussion, mais aucune trace de sondage, et j'ai ça comme erreur :

Avertissement: Use of undefined constant _MI_XOOPSPOLL_OVERVIEW assumed '_MI_XOOPSPOLL_OVERVIEW' (this will throw an Error in a future version of PHPdans le fichier /modules/xoopspoll/xoops_version.php ligne 142
Avertissement
: Use of undefined constant _MI_XOOPSPOLL_DISCLAIMER assumed '_MI_XOOPSPOLL_DISCLAIMER' (this will throw an Error in a future version of PHPdans le fichier /modules/xoopspoll/xoops_version.php ligne 143
Avertissement
: Use of undefined constant _MI_XOOPSPOLL_LICENSE assumed '_MI_XOOPSPOLL_LICENSE' (this will throw an Error in a future version of PHPdans le fichier /modules/xoopspoll/xoops_version.php ligne 144
Avertissement
: Use of undefined constant _MI_XOOPSPOLL_SUPPORT assumed '_MI_XOOPSPOLL_SUPPORT' (this will throw an Error in a future version of PHPdans le fichier /modules/xoopspoll/xoops_version.php ligne 145
Erreur
ErrorUndefined constant '_AM_XOOPSPOLL_CREATENEWPOLL' dans le fichier /modules/xoopspoll/class/Poll.php ligne 223


Et si je suis sur un message déjà existant, et que je clique sur "Ajouter un sondage", j'ai la page d'erreur de xoops (avec le logo) et :


Citation :
A problem has occurred on our server!
Page is currently unavailable

We are working on a fix
Please come back soon ...

Error : Error: Undefined constant '_AM_XOOPSPOLL_CREATENEWPOLL'


Voilà où j'en suis !

Posté le : 08/04 10:24

Open in new window
18 ans sous XOOPS !
Partager Twitter Partagez cette article sur GG+
Re: xoopspoll dans newbb
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3389
Ok, tu me donneras les erreurs lorsque tu auras le module XoopsPoll en français.
Cela fait des années que je le dis, soit vous avez TOUT en anglais, soit TOUT en français, sinon vous aurez des erreurs qui ne sont pas dues au module.

Posté le : 08/04 10:57

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
(1) 2 3 4 ... 6 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

87 Personne(s) en ligne (74 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 87 | Plus ...