Fork me on GitHub






Xoops 2510 install impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 515
Je n'arrive pas à installer Xoops version 2.5.10 il bloque à l'étape 7 :

Impossible de copier le fichier "secure.php"

Tout est correct les répertoire :

xoops_data/caches
xoops_data/caches/xoops_cache
xoops_data/caches/smarty_cache
xoops_data/caches/smarty_compile
xoops_data/configs
xoops_data/data
xoops_data/protector

on été créés & ouvert en écriture mode 0777

Alors je sèche j'ai vidé le cache du navigateur je l'ai aussi fermé puis recommencer l'install mais à chaque fois le même message.


Posté le : 16/12 13:54

Version Bootstrap
4.4.1
Version font-awesome
5.12.0
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3828
Hello,

Je ne suis pas devant, et je n'ai plus la mémoire des étapes, peux tu faire une capture d'écran stp ?

Posté le : 16/12 18:37

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3828
Si c'est l'étape de création des tables, et si tu es en local avec un WAMP,

Si tu utilises mariadb, Il faut ajouter un numéro de port, je pense, et pour mysql, c'est un autre numéro de port.

Il faut dont que tu nous dises :

- Installation locale sous windows ?
- Si oui, quel outil WAMP ?
- Quelle BDD utilises tu ? Mariadb, MySQL ?


Posté le : 16/12 18:41

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 515
Je ne suis pas en local je suis sur mon hébergeur toujours le même o2switch.

En local je ne peux pas l'installer car pour l'instant le seul OS que j'ai sous la main c'est Ubuntu 19.10 et y'as un problème avec phpmyadmin y'as une faille de sécurité j'ai trouvé un nouveau PPA etc pour l'installer mais j'ai aucun privilège j'ai essayer de désinstaller puis réinstaller toujours pareils.

Le port mySsql je savais pour en local.
Mais, la je n'ai pas de Input ou rentrer le port mySql ?

J'utilise mySql

La version 2.5.10 je l'ai télécharger sur Xoops.org

Capture d'écran : https://ibb.co/F6LQQGK

C'est un site d'hébergement d'image n’ayez crainte !

J'ai l’impression que ça viens encore de mon hébergeur la dernière fois mon problème venais d'eux mise à jour du Cpanel & PHP 7.4 mais comme ils disent rien ...

Infos :

Chez eux j'ai LiteSpeed (LSCache) & XtremCache mais les deux demande une extension à installer & elle n'est pas dispo pour Xoops juste sur d'autres CMS.

Mais je pense que Xoops en à pas besoin c'est pour gérer le cache & lui à le sien.


Posté le : 16/12 19:13

Version Bootstrap
4.4.1
Version font-awesome
5.12.0
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3828
Tu n'aurais pas un fichier nommé mainfile.dist.php.protector ?
Dans ce cas, renomme le en mainfile.dist.php avant de lancer l'installation

Posté le : 16/12 21:44

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3828
Chez O2Switch, tu as l'outil PHP Selector pour choisir la version de PHP que tu veux.



Posté le : 16/12 22:37

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 515
Non je n'ai pas de fichier mainfile.dist.php.protector

Mais, j'avais un fichier index.html qui avais été créé auparavant pour dire que le site était en construction vu que c'est le deuxième xoops que j'installe sur le même hébergement mutualisé j'ai deux nom de domaine pour deux site différent le premier je l'ai mis à jour en 2.5.10 avec PHP 7.4 et en renommant le fichier index.html (_index.html) c'est passé donc je suppose que c'était ça qui faisait buguer l'installation mais la c'est bon.

C'est partit pour le deuxième site,

Je pense au tuto pour le HTTPS j'ai pas oublié ;)


Posté le : 18/12 01:56

Version Bootstrap
4.4.1
Version font-awesome
5.12.0
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3828
Humm,

déjà,

XOOPS 2.5.10 => PHP 7.3 compatibility

pas PHP 7.4
Disons, on garantie PHP 7.3 pour XOOPS 2.5.10

Pourquoi utiliser index.html ?
Tu vas dans les préférences, côté BackOffice, et tu choisis de mettre le site en mode maintenance.

Par défaut, seul les admins pourront se connecter pour travailler e, live sur le site.

Posté le : 18/12 10:33

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Semi pro
Inscrit: 19/08/2006 03:45
De Paris
Messages: 515
Parce que c'était avant d'installer Xoops que j'avais mis ce fichier html pour ne pas laisser vide !

En 7.4 j'ai pas de problème il m'affiche tout pas de page blanche pas bug apparent maintenant je verrais avec le temps en testant les fonctions de chaque module je verrais bien si ça bug quelque part !

Le module XoopsTube je l'ai renommer & j'ai rencontrer un problème dans le fichier header.php y'avais un
$moduleDirName .
qui n'était pas déclaré donc j'ai corriger le problème maintenant j'ai accès au module mais il m'affiche pas les templates je précise j'ai essayer en PHP 7.3 des fois que mais non c'est pareils donc j'ai fait un débug en ligne et la réponse est
AvertissementSmarty errorunable to read resource"db:xoopstube_index.tpl" dans le fichier /class/smarty/Smarty.class.php ligne 1100
j'ai été voir la ligne en question dans le fichier mais ça ma pas aidé donc je sèche ça viens de quoi ???

Posté le : 18/12 14:57

Version Bootstrap
4.4.1
Version font-awesome
5.12.0
Version Xoops
2.5.10
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2510 install impossible
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3828
Autre demande, hors sujet en rapport avec le titre, je replace ce sujet en résolu.

Posté le : 18/12 16:57

Open in new window
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

138 Personne(s) en ligne (130 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 138 | Plus ...