Fork me on GitHub






Mauvaise redirection après identification
Newbie
Inscrit: 13/04 19:24
Messages: 3
Bonjour

Je suis devenu administrateur d'un vieux site sous xoops 2 de 2005 avec pas mal de personnalisation.
Je l'ai changé d'hébergeur (passé chez o2switch) avec pour objectif de migrer son contenu vers un nouveau site.
Initialement il y avait une redirection du site (clubventuri.fr) vers une autre adresse (clubventuri.phpnet.org)
Cette redirection n'est plus nécessaire.
Suite à ce changement d'hébergeur, la redirection me provoque une erreur après identification.
On arrive sur l'adresse https://clubventuri.phpnet.org/user.php
et ce joli message :
"Not Found
The requested virtual host was not found on this platform."

Le site chez l'ancien hébergeur n'étant plus disponible, c'est un plantage direct.
je n'ai pas trouvé sur quel fichier se passe la redirection.
A vrai dire je ne sais plus où chercher.
Ce n'est pas sur .htacess
Est-ce sur index.php, sur la page d'identification ou ailleurs ?

J'ai cherché sur le site et n'ai pas trouvé la solution. Si elle est bien sur le site, je suis preneur.

merci pour votre aide.

(ps pour les modo : vous pouvez supprimer mon post côté support Module, c'est une erreur. Merci)

Posté le : 13/04 23:27
Partager Twitter Partagez cette article sur GG+
Re: Mauvaise redirection après identification
Admin Frxoops
Inscrit: 04/02/2003 06:41
Messages: 852
Bonjour Alex et bienvenue sur Xoops

Dans ce cas, il faut changer simplement l'url du site dans mainfile.php, supprimer les caches et supprimer ou modifier toutes les URL et chemins non relatifs dans la base de données de l'ancien domaine vers le nouveau domaine.

Ne pas oublier de vérifier dans le thème du site s'il n'y a pas des URL en "dur".

Posté le : 14/04 07:52

Quand tu montres la lune du doigt, l'imbécile regarde le doigt.
Infos sur TSO et tutos PC sur Tutoriaux PC
Partager Twitter Partagez cette article sur GG+
Re: Mauvaise redirection après identification
Newbie
Inscrit: 13/04 19:24
Messages: 3
Merci pour ce retour.
J'ai corrigé ce fichier mainfile, et maintenant je me rend compte que j'ai en fait du phpnet.org dans tout le menu.
Je m'attaque à la base de donnée et je verrai le reste après.

Posté le : 14/04 09:09
Partager Twitter Partagez cette article sur GG+
Re: Mauvaise redirection après identification
Admin Frxoops
Inscrit: 04/02/2003 06:41
Messages: 852
Dans ce cas, tu télécharges ton thème en local et avec Notepad++ par exemple, tu remplaces le mauvais domaine par le bon. Le Ctrl H est ton ami

Pour la base de données, je me sers de Search-Replace-DB-master qui doit bien sûr être testé sur une copie de base de données avant de le faire "pour de vrai". Sinon, à faire en requête directement depuis l'interface sql.

Posté le : 14/04 10:15

Quand tu montres la lune du doigt, l'imbécile regarde le doigt.
Infos sur TSO et tutos PC sur Tutoriaux PC
Partager Twitter Partagez cette article sur GG+
Re: Mauvaise redirection après identification
Newbie
Inscrit: 13/04 19:24
Messages: 3
Super. Merci
Problème résolu.

Posté le : 14/04 18:33
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

58 Personne(s) en ligne (53 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 58 | Plus ...