Fork me on GitHub




« 1 2 (3) 4 »


Re: Newbb 5.1.0 Beta 7
Semi pro
Inscrit: 26/07/2011 14:05
De Fleurus (W-B) (Belgique)
Messages: 795
Citation :
Cesagonchu a écrit :
Oui je suis en train de faire des tests.

En fait le soucis que tu as sur ton thème c'est que tous tes "define" sont obsolètes.

Par exemple avant les "define" étaient :

_MD_TYPE_


mais maintenant elles sont nommées :

_MD_NEWBB_TYPE_


Je fais les modifications, je test en anglais et ensuite je test en français.
Après tous mes tests je t'envoi ton thème avec les bonnes modifications.


Super sa je serai vraiment content de pouvoir conserver mon thème, un grand Merci Christelle

Posté le : 17/02/2023 17:44

Je suis souvent copié mais "copié = Synonyme de célébrité" Alors continuez mes fans.
Site Radioamateur Belge
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 4051
Si Greg est sur la bonne piste cela montre encore une fois pourquoi on insiste encore et encore sur vos demandes de support,
A savoir :
- Version de XOOPS utilisée
- Version PHP
- Nom du module
- Version du module
- Thème utilisé si besoin.


Oui, si tu es en PHP8, il est clair que cette version est bien moins permissive que les versions précédentes.
Un warning en PHP 5.x ou 7.x devient une erreur en 8.x.

Si c'est le cas, bravo Greg pour la bonne piste !

Posté le : 17/02/2023 18:46

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Semi pro
Inscrit: 26/07/2011 14:05
De Fleurus (W-B) (Belgique)
Messages: 795
Citation :
alain01 a écrit :
Si Greg est sur la bonne piste cela montre encore une fois pourquoi on insiste encore et encore sur vos demandes de support,
A savoir :
- Version de XOOPS utilisée
- Version PHP
- Nom du module
- Version du module
- Thème utilisé si besoin.


Oui, si tu es en PHP8, il est clair que cette version est bien moins permissive que les versions précédentes.
Un warning en PHP 5.x ou 7.x devient une erreur en 8.x.

Si c'est le cas, bravo Greg pour la bonne piste !


Version de XOOPS 2.5.11-Beta2
Version de PHP 8.0.27
Version de mySQL 10.3.36-MariaDB-1:10.3.36+maria~ubu2004

Posté le : 17/02/2023 19:06

Je suis souvent copié mais "copié = Synonyme de célébrité" Alors continuez mes fans.
Site Radioamateur Belge
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 4051
donc Greg avait raison !
Bravo Greg.

Oui, en PHP8, tu ne peux plus avoir des defines manquants !
Il faut donc les ajouter dans le fichier de traduction.

Posté le : 17/02/2023 19:12

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Non alain ce n'était pas ça, après avoir corrigé les define obsolètes, il n'y a plus l'erreur, je vois enfin le forum et l'administration du forum mais je me retrouve avec une erreur en bas de page telle que :

WarningUndefined array key "highlight" in file /xoops_dataxx/caches/smarty_compile/6e4a5552-system-fiblue3d-default^%%3E^3EB^3EB718E5%%db%3Asystem_block_mainmenu.tpl.php line 11


Quelqu'un saurait comment corriger ça ?

Posté le : 17/02/2023 19:34

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 4051
vide le cache / maintenance ?

Posté le : 17/02/2023 20:51

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Je l'ai même supprimé manuellement sur le ftp mais il se refabrique.

Posté le : 17/02/2023 21:17

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Semi pro
Inscrit: 08/03/2006 21:08
Messages: 1176
Citation :
Cesagonchu a écrit :
Non alain ce n'était pas ça, après avoir corrigé les define obsolètes, il n'y a plus l'erreur, je vois enfin le forum et l'administration du forum mais je me retrouve avec une erreur en bas de page telle que :

WarningUndefined array key "highlight" in file /xoops_dataxx/caches/smarty_compile/6e4a5552-system-fiblue3d-default^%%3E^3EB^3EB718E5%%db%3Asystem_block_mainmenu.tpl.php line 11


Quelqu'un saurait comment corriger ça ?


Ce n'est pas important, tu peux laisser comme ça (c'est juste un warning). C'est simplement une variable smarty qui n'est pas définie.

Si vraiment tu veux corriger alors cherche la variable "highlight" dans le template system_block_mainmenu.tpl(il doit être en surcharge dans le thème module system) et la condition doit ressembler à ça:

<{if $module.highlight}>


Tu remplace comme ceci:

<{if $module.highlight|default:false}>


Mais si tu commence à corriger tout ce vieux thème, je te souhaites bon courage

Posté le : 17/02/2023 21:19
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
Merci je vais essayer ça :)

Posté le : 17/02/2023 21:24

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 5.1.0 Beta 7
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3528
J'ai fait quelques corrections, tu me diras ce qu'il en est.
Je l'ai renommé fiblue3dNEW pour que tu saches lequel est nouveau.

EDIT Cesagonchu : suppression du fichier attaché, c'était temporaire le temps d'un échange.

Posté le : 17/02/2023 23:03

Edité par Cesagonchu sur 19/02/2023 13:16:50

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 2 (3) 4 »



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

10 Personne(s) en ligne (7 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 10 | Plus ...