Fork me on GitHub






Module compatibilité
Aspirant
Inscrit: 07/11/2018 13:08
Messages: 68
Bonsoir,
Tous les anciens module de xoops que l'on trouve dans les téléchargement du site, sont il compatibles avec xoops 2.5.10
Merci
Bonne année 2023 a tous

Posté le : 01/01/2023 18:48
Partager Twitter Partagez cette article sur GG+
Re: Module compatibilité
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2554
Bonjour, Je crains que non, mais ce n'est pas tant la compatibilité avec xoops 2.5.10 que celle avec php 7 et supérieure qui peut poser problème.
Pour la plus part des modules que j'utilise, ça a été des corrections liés au passage à php 7.
JJDai

Posté le : 01/01/2023 19:02

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Module compatibilité
Aspirant
Inscrit: 07/11/2018 13:08
Messages: 68
que faut il modifier pour que cela fonctionne et surtout comment?
j'ai php 7.4

Posté le : 01/01/2023 19:15
Partager Twitter Partagez cette article sur GG+
Re: Module compatibilité
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2837
Tout dépend de l'age du module.
deja voir ici :
https://github.com/XoopsModules25x

ça rassemble les dernières versions disponibles.

Avec de la chance, tu en auras une version compatible PHP 7.4

Sinon, il faut mettre la main dans le cambouis.
Voilà déjà un peu de lecture, la migration de PHP 5 vers PHP 7 https://www.php.net/manual/fr/migration70.php

Ensuite, se baser sur les messages debug pour corriger où ça coince

Posté le : 01/01/2023 21:24
Partager Twitter Partagez cette article sur GG+
Re: Module compatibilité
Aspirant
Inscrit: 07/11/2018 13:08
Messages: 68
Merci beaucoup pour ces infos
cdt

Posté le : 02/01/2023 13:31
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

15 Personne(s) en ligne (12 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 15 | Plus ...