Fork me on GitHub

Xoops 2.0.17

200728
Ao√Ľt
  Christian Versions 43391

Open in new window

Nous avons le plaisir de vous annoncer la sortie de la version XOOPS 2.0.17. C'est une version de maintenance qui corrige quelques bugs et apporte des améliorations fonctionnelles. La consultation du changelog en bas de cet article vous procurera le détail de tous les changements

Spécifications système

PHP
version PHP >= 4.3.0+ (PHP 4.2.x peut fonctionner mais n'est pas officiellement supporté)
MySQL
serveur MySQL 3.23+
Serveur Web
Un serveur supportant la version PHP requise (Apache fortement recommandé)


Installer XOOPS

  1. Décompressez le package dans un répertoire temporaire
  2. Copier le contenu (et pas le dossier) du dossier htdocs/ à la racine de votre serveur
  3. Assurez-vous que le fichier mainfile.php et les dossiers cache, templates_c et uploads sont accessibles en lecture-écriture par le serveur
  4. Acc√©dez au dossier o√Ļ vous avez install√© les fichiers du dossier htdocs en utilisant votre navigateur pour lancer l'assistant d'installation

Dans le répertoire docs du package, vous trouverez un fichier install_fr.html avec plus d'indications.

Important : Cette version contient le module Protector qui protégera votre site des attaques malveillantes. Prenez connaissance du contenu de la documentation dans xoops_trust_path/modules/protector/doc pour réaliser son installation, afin de pouvoir installer avec succès d'autres modules ensuite.

Mise à jour à partir d'une version antérieure

Par précaution, veuillez préalablement effectuer une sauvegarde de vos fichiers et des tables de votre base de données

Mise à jour à partir de XOOPS 2.0.16

  1. Effectuez une sauvegarde de votre base de données et de vos fichiers
  2. Décompressez le package de mise à jour dans un répertoire temporaire
  3. Copiez le contenu du répertoire htdocs à la racine de votre site par dessus vos fichiers existants
  4. Dans admin system, modules, faites une mise à jour du module system
  5. Supprimez le dossier upgrade

Mise à jour à partir de XOOPS 2.0.14/2.0.15 (package upgrade)

  1. Effectuez une sauvegarde de votre base de données et de vos fichiers
  2. Décompressez le package de mise à jour dans un répertoire temporaire
  3. Copiez le contenu du répertoire htdocs à la racine de votre site par dessus vos fichiers existants
  4. Dans votre navigateur, saisissez l'adresse de votre site suivie de /upgrade/ ce qui donne /upgrade/
  5. Suivez les instructions pour la mise à jour
  6. Dans admin system, modules, faites une mise à jour du module system
  7. Supprimez le dossier upgrade

Mise à jour à partir de XOOPS 2.0.14/2.0.15 (version complète)

  1. Effectuez une sauvegarde de votre base de données et de vos fichiers
  2. Décompressez le package de mise à jour dans un répertoire temporaire
  3. Déplacer le dossier "upgrade" dans le dossier "htdocs"
  4. Supprimer le fichier htdocs/mainfile.php, et le dossier htdocs/install
  5. Copiez le contenu du répertoire htdcos à la racine de votre site par dessus vos fichier existants
  6. Dans votre navigateur, saississez l'adresse de votre site suivie de /upgrade/ ce qui donne /upgrade/
  7. Suivez les instructions pour la mise à jour
  8. Dans admin system, modules, faites une mise à jour du module system
  9. Supprimez le dossier upgrade

Mise à jour à partir des versions XOOPS 2.0.7 à 2.0.13.2 (avec la version complète)

  1. Effectuez une sauvegarde de votre base de données et de vos fichiers
  2. Décompressez le package de mise à jour dans un répertoire temporaire
  3. Déplacer le dossier "upgrade" dans le dossier "htdocs"
  4. Supprimer le fichier htdocs/mainfile.php, et le dossier htdocs/install
  5. Copiez le contenu du répertoire htdcos à la racine de votre site par dessus vos fichier existants
  6. Supprimez les fichiers et dossiers suivants de votre serveur (ils appartiennent à une ancienne version):
    • class/smarty/core
    • class/smarty/plugins/resource.db.php
  7. Supprimez les fichiers du répertoire templates_c (sauf index.html)
  8. Vérifiez que le serveur peut écrire dans le fichier mainfile.php
  9. Dans votre navigateur, saississez l'adresse de votre site suivie de /upgrade/ ce qui donne /upgrade/
  10. Suivez les instructions pour la mise à jour
  11. Protégez à nouveau le fichier mainfile.php (chmod=444)
  12. Dans admin system, modules, faites une mise à jour du module system
  13. Supprimez le dossier upgrade

Contr√īle de l'int√©grit√© des fichiers

Cette version de Xoops est livrée avec un script capable de vérifier si tous les fichiers du "system" (le noyau xoops) ont bien été uploadés sur le serveur.

Pour l'utiliser, suivez ces instructions :

  1. uploader les fichiers xoops_md5.php et xoops.md5, situé à la racine du package dans le répertoire racine de votre serveur
  2. exécutez xoops_md5.php dans votre navigateur
  3. si nécessaire, réuploader les fichiers manquants ou corrompus
  4. supprimer les fichiers xoops_md5.php et xoops_.md5 de votre serveur

Découvrir les indications cachées en cas de page blanche

Xoops affiche une page d'erreur basique pour prévenir les erreurs fatales.

Pour vous aider à diagnostiquer la cause de l'erreur, cette page contient des informations supplémentaires qui sont cachées par défaut.

Pour les découvrir utilisez le menu "sélectionner tout" de votre navigateur ; sur la plupart d'entre eux vous pouvez utiliser la combinaison de touches "ctrl+A".

Accès aux templates non supportés

Il a été porté à notre connaissance que quelques modules contiennent une version modifiée de la routine d'installation des modules et accèdent directement aux tables de la base de données pour les templates et les blocs, contournant ainsi les procédures régulières de déclaration des templates.

A cause de cela, quelques changements récents dans le système de manipulation des templates ont rendu ces modules incapables d'accéder à leurs données templates. Si vous utilisez l'un de ces modules, vous pouvez corriger ce problème en remplaçant le fichier resource.db.php situé dans le dossier class/smarty/xoops_plugins/ par celui fourni dans le dossier extras de ce package.

Veuillez noter cependant qu'en contournant l'interface standard en insérant des modifications dans le noyau, celles-ci ne sont pas supportées et ces modules ne fonctionneront plus avec les futures versions.

Modules

Les packages Xoops ne contiennent pas de modules en dehors du module system. Vous pouvez parcourir notre espace téléchargement de modules.

Quelques uns des meilleurs modules peuvent être trouvés sur les sites suivants :

Si vous utilisez l'un des modules de xoopsforge (CBB 3.08,planet, article (et non news),etc... vous devez actualiser le composant Framework. Un package français avec cette dernière version, xoopseditor et cbb 3.08 sera publié dans la semaine

Sécurité

Nous recommandons fortement l'installation du module Protector ce qui apportera une protection additionnelle et des possibilités de journalisation à votre site.

La dernière version(3.13) du module Protector a été intégrée dans le package francophone. Consulter le fichier protector/doc/documentation_protector-3-13_french.pdf pour la procédure d'installation.

Bonus

Kris a proposé un nouveau thème par défaut qui n'a pas encore été retenu. Nous l'avons néanmoins intégré dans notre package, il porte le nom de default_simple.

Télécharger Xoops 2.0.17

Xoops 2.0.17fr format zip (2Mo)

Mise à jour 2.0.16 vers 2.0.17

Changelog : 24/08/2007 - Version 2.0.17

  • Correction d'une m√©thode js d√©sapprouv√©e captureEvents et d'erreurs de style de propri√©t√© (phppp/skenow)
  • Correction d'erreurs pour conformit√© xhtml/css (phppp/skenow/kris_fr/studioC/malanciault)
  • Correction bug #1656854 : quotes et id manquants dans XoopsObjectTree->makeSelBox (hthouzard/dugris)
  • Correction bug #1716980 : le nom du site est tronqu√© dans le formulaire d'envoi de mails aux utilisateurs (rowd/dugris)
  • Correction bug #1763214 : probl√®me dans le champ pr√©f√©rence couleur du module (zoullou/dugris)
  • Correction bug #1707436 : la compression gzip ne fonctionnait pas correctement (rowd/young-pee/dugris/phppp)
  • Correction : √©criture des templates avec un pr√©fixe (template_set-theme_set) pendant l'installation et la mise √† jour des modules (dugris)
  • Correction bug #1767284 : pr√©visualisation du code des templates dans l'administration des templates (dugris/Kris_fr)
  • Correction bug #1744332 : r√©paration de la boucle dans les tableaux de blocs d√©finies dans xoops_version.php (malanciault/dave_l/dugris)
  • Correction bug #1767457 : l'association de {X_SITEURL} et [URL] dans les blocs personnalis√©s n'√©tait pas proprement compil√©(phppp/domecc)
  • Correction bug #1767018 : le menu popup n'est pas correctement r√©√©crite quand le langage par d√©faut est modifi√© dans les param√®tres g√©n√©raux - r√©√©criture compl√®te de la fonction xoops_module_get_admin_menu (dugris/phppp)
  • Correction : sauvegarde de la r√©elle version du module system pendant l'installation (dugris)
  • Correction bug #1746179 : Interpr√©tation incorrecte des BBcodes pour les images avec ID et Alt (dugris/mboyden)
  • Correction bug #1751011 : ajout de la compatibilit√© avec l'extension smarty pour xoops pour la page de redirection et la page de fermeture du site, alimentation des variables smarty pour la redirection de page et fermeture du site, alimentation des balises Meta lorsque le site est ferm√©(dugris/phppp)
  • Correction d'un probl√®me de permissions dans l'installation des modules et la gestion des blocs, qui sont seulement appliqu√©es aux groupes dont d√©pend l'utilisateur qui installe le module ; maintenant les permissions pour l'acc√®s aux modules et aux blocs seront assign√©es par d√©faut aux trois groupes basiques (webmestres, utilisateurs enregistr√©s, visiteurs anonymes)(phppp/dugris/alainternet01)
  • Correction d'un probl√®me dans authfactory : la configuration pour la m√©thode d'authentification n'√©tait pas contr√īl√©e correctement (phppp)
  • Correction d'un bug dans la page de redirection apr√®s la connexion d'un membre qui n'avait pas la permission d'acc√®s, ce qui g√©n√©rait une boucle infinie (phppp)
  • Correction bug #1734811 : ex√©cution de la commande popen dans phpmailer ::sendmail (phppp/larholm/judas_iscariote/m0nty_)
  • Correction d'une valeur erron√©e pour "disposition-type" dans le champ d'en-t√™te Content-Disposition de la class downloader : inline => attachment (ref: http://www.ietf.org/rfc/rfc2183.txt) (phppp)
  • Correction bug #1745032 : probl√®me d'assignation √† un groupe quand on cr√©e un utilisateur dans l'administration (phppp/malanciault/dugris/felix)
  • Correction bug #1745057 : am√©lioration de la s√©lection pour les sites avec un grand nombre de membres (phppp/malanciault)
  • Correction d'un bug dans XoopsMultiMailer pour le param√©trage de $xoopsMailerConfig['smtphost'] qui est une cha√ģne au lieu d'un tableau (phppp/domecc)
  • Correction bug #1748019 : probl√®me d'authentification LDAP avec le symbole Euro (pemen)
  • Correction bug #1764107 : probl√®me d'authentification avec AD dans Windows 2003. Ajout de l'option LDAP_OPT_REFERRALS (pemen)
  • Correction bug #1610461 : Probl√®me dans l'√©dition d'un utilisateur en supprimant l'url dans son profil 2.0.16 (rowd/malanciault)
  • Correction bug #1610461 : impossibilit√© de retirer 'toujours attacher ma signature' lorque l'option a √©t√© s√©lectionn√©e (rowd/malanciault)
  • Correction bug #1610461 : suppression de 4 notices PHP 'undefined variable'; deux pour des champs qui ne sont plus utilis√©s, deux pour des champs de case √† cocher (rowd/malanciault)
  • Correction bug #1626243 : quand le site est arr√™t√© et que le d√©bug Smarty est activ√©, la fen√™tre popup √©tait affich√©e aux visiteurs anonymes (rowd/malanciault)
  • Correction bug #1015557 : probl√®me dans undoHtmlSpecialChars lors d'une conversion (phpp/malanciault)
  • Correction bug #1689884 : code embrouill√© dans le formulaire EditUser dans l'administration (rowd/malanciault)
  • Correction d'une erreur de syntaxe dans la gestion des banni√®res (phppp/gibaphp)
  • Correction bug dans le contr√īle d'un formulaire Xoops quand un √©l√©ment est requis (phppp)
  • Correction d'un bug dans un formulaire Xoops lors de l'ajout d'un √©l√©ment requis qui n'est pas pris en compte par le formulaire (phppp)
  • Mise √† jour class Smarty (version 2.6.18) (dugris)
  • Mise √† jour class snoopy (version 1.2.3) (dugris)
  • Am√©lioration de la gestion des pr√©f√©rences syst√®me : utilisation de la fonction register_shutdown pour garantir le nettoyage du cache des fichiers (phppp)
  • Am√©lioration : ajout d'un d√©limiteur pour XoopsFormRadio et XoopsFormCheckBox (dugris)
  • Am√©lioration : ajout d'un dossier css pour les th√®mes (dugris)
  • G√©n√©ration am√©lior√©e de l'ID cache : protection des groupes ou langage de contenu sensible (phppp)
  • Am√©lioration de l'extension Xoops pour Smarty : skip fetching tpl resource from DB for "default" template set (phppp)
  • Am√©lioration : mise √† jour cosm√©tique de l'affichage des messages d'erreurs dans register.php (phppp)
  • Am√©lioration de la class uploader : localisation des messages d'erreurs (phppp)
  • Am√©lioration de la s√©lection des membres en pr√©sence d'un grand nombre de comptes utilisateurs (phppp/ncnynl/huzhenghui)
  • Am√©lioration de la localisation dans la navigation de l'administration syst√®me (phppp)
  • Am√©lioration de la gestion des sessions : ajout d'un contr√īle IP et session_regenerate_id pour chaque requ√™te (phppp/intron)
  • Ajout d'un fonctionnalit√© de requ√™te #1745040 (temporaire) en activant le choix d'un groupe (phppp/malanciault)
  • Abandon de la m√©thode du formulaire renderValidationJS √† chaque √©l√©ment pour un meilleur contr√īle du code de validation (phppp/dugris)
  • Added email as required and disclaimer if is required in registerform (phppp/dugris)
  • Ajout d'un rep√®re pour les √©l√©ments requis dans les formulaires XOOPS themeform (phppp)
  • Ajout d'un id aux blocs assign√©s dans les templates (comme dans XOOPS 2.2*) pour manipuler des blocs sp√©cifiques (phppp)
  • Ajout d'un contr√īleur de "d√©chets" pour les cas o√Ļ la fonction gc dans session handler ne s'ex√©cute pas comme pr√©vu (phppp/skalpa)
  • Ajout d'un contr√īle type d'√©l√©ment de formulaire qui provoque une erreur fatale si un √©l√©ment est une cha√ģne (phppp)
  • Ajout d'un signal "required" aux √©l√©ments de formulaires qui lorsqu'ils sont requis ne sont pas enregistr√©s correctement (phppp)
  • Ajout d'un param√®tre "name" √† l'√©l√©ment de formulaire label pour permmettre le positionnement quand un template est utilis√© (phppp/ncnynl)
  • Ajout d'une propri√©t√© "overflow" pour XoopsCode dans /themes/default/style.css (phppp)
  • Ajout du support TLS pour l'authentification LDAP avec une nouvelle option de configuration #1697107 (pemen)
  • Ajout d'une nouvelle constant dans la configuration de la base de donn√©es pour TLS (pemen)
  • Ajout d'un programme de mise √† jour 2.0.16-to-2.0.17 (pemen)
  • Ajout de la constante _NOT_NOTHINGTODELETE qui √©tait manquante (malanciault)
  • Suppression du param√®tre "list-style" de la class li dans /themes/default/style.css qui provoquait un trouble avec ol et li (phppp/huzhenghui)
  • Modification de la proc√©dure d'installation et ajout TLS (pemen)
  • Nettoyage du code de mise √† jour, suppression des dossiers et fichiers inutiles (phppp)
  • Ajout dans les fichiers langages :
    • /language/english/findusers.php (phppp)
    • /language/english/uploader.php (phppp)
  • Fichiers langages modifi√©s :
    • /modules/system/language/english/admin/findusers.php (malanciault)
    • /modules/system/language/english/admin.php (phppp)
    • /modules/system/language/english/admin/users.php (phppp)
    • /modules/system/language/english/admin/preferences.php (pemen)
    • /languages/english/auth.php (pemen)
    • /languages/english/notification.php (malanciault)

Note: 6.00 (3 votes) - Noter cet article -

Partager Twitter Partagez cette article sur GG+
Format imprimable Envoyer cet article à un ami
Les commentaires appartiennent à leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Semi pro
Inscrit le: 04/08/2005
De: Quelque part dans les étoiles...
Contributions: 1141
xmouse Post√© le: 28/08/2007 07:40  Mis √† jour: 28/08/2007 07:40
 Re: Xoops 2.0.17
Merci Christian pour cette traduction publiée vers les 4h00 du mat et que certains attendaient avec impatience...

Régulier
Inscrit le: 28/08/2005
De: Bordeaux
Contributions: 455
kjame Post√© le: 28/08/2007 10:37  Mis √† jour: 28/08/2007 10:37
 Re: Xoops 2.0.17
Merci ;)
Régulier
Inscrit le: 07/01/2005
De: Angers
Contributions: 230
cricri Post√© le: 28/08/2007 11:59  Mis √† jour: 28/08/2007 11:59
 Re: Xoops 2.0.17
Juste une infos, pour faire la mise à jour depuis la version 2.0.16, il faut supprimer le dossier "instal" qui est dans le htdocs??

Christophe
Régulier
Inscrit le: 06/09/2005
De: Tours
Contributions: 306
kryxx Post√© le: 28/08/2007 11:59  Mis √† jour: 28/08/2007 11:59
 Re: Xoops 2.0.17
Ben dis donc, c'est pas lesvacances pour tout le monde
merci la team
Régulier
Inscrit le: 04/02/2003
De:
Contributions: 203
lolothom Post√© le: 28/08/2007 14:28  Mis √† jour: 28/08/2007 14:28
 Re: Xoops 2.0.17
bonjour

j'ai xoops 2.0.13.2 avec protector je desisntalle protector avant la mise à jour ?
Semi pro
Inscrit le: 27/10/2004
De:
Contributions: 566
grandoc Post√© le: 28/08/2007 15:53  Mis √† jour: 28/08/2007 16:56
 Re: Xoops 2.0.17
Bonjour à tous, et bravo à l'équipe, mais ...
je conseille de ne pas se pr√©cipiter sur la mise √† jour, car de nombreux modules ne fonctionnent plus apr√®s. En particulier, j'ai eu des probl√®mes avec une s√©rie de la smartfactory : smartpartner, et deux clones que j'avais cr√©√©; le module Chess etc...j'ai d√Ľ vite fait faire marche arri√®re, en r√©installant une version 2.0.16.
D'ailleurs, il serait bien de laisser au téléchargement la 2.0.16, car j'ai eu un peu de mal à la récupérer.
Bon courage
Semi pro
Inscrit le: 04/02/2003
De: Qc.ca
Contributions: 1389
king76 Post√© le: 28/08/2007 17:02  Mis √† jour: 28/08/2007 17:02
 Re: Xoops 2.0.17
Beau travail de traduction, merci !
Xoops accro
Inscrit le: 25/02/2004
De: Région parisienne
Contributions: 2526
DuGris Post√© le: 28/08/2007 23:53  Mis √† jour: 28/08/2007 23:53
 Re: Xoops 2.0.17
@grandoc : etonnant !!!
Et si tu faisait état des problèmes et messages d'erreur que tu as rencontré sur le site de la smartfactoyr pour smartpartner !
Régulier
Inscrit le: 22/05/2006
De: XoopS
Contributions: 241
skynet Post√© le: 29/08/2007 00:55  Mis √† jour: 29/08/2007 00:55
 Re: Xoops 2.0.17
comme toujour xoops se progrèsse vère le top des top des CMS
bravo
Xoops accro
Inscrit le: 04/02/2003
De: Le Mans
Contributions: 12273
Christian Post√© le: 29/08/2007 02:03  Mis √† jour: 29/08/2007 02:03
 Re: Xoops 2.0.17
Suite à ce message les deux fichiers en téléchargement ont été corrigés pour prendre en compte la remarque qui a été faite.
Régulier
Inscrit le: 22/05/2006
De: XoopS
Contributions: 241
skynet Post√© le: 29/08/2007 02:12  Mis √† jour: 29/08/2007 02:12
 Re: Xoops 2.0.17
bonjour
je voi que cette version va répondre à la majotité des besoins des sites xoopsé.
mais je veux savoir est ce que cette version adabte bien les keyword parceque l'antérieur ne fonction pas correction au niveau des keyword!

a+
Newbie
Inscrit le: 09/02/2005
De:
Contributions: 11
alexzuka Post√© le: 29/08/2007 05:06  Mis √† jour: 29/08/2007 05:06
 Re: Xoops 2.0.17
Je me permets d'attirer l'attention sur :

L'installation des modules News 1.55 et smartsection 2.13 ne fonctionne pas.

Pour le reste, c'est du tout bon, le nouveau de thème de Kris est sobre et très sympa.

J'espère juste qu'une correction sera apportée prochainement, parce que là je suis en stand by avec l'un de mes sites ; et trop confiant j'ai pas gardé ma version 2.016 en réserve.
Semi pro
Inscrit le: 27/10/2004
De:
Contributions: 566
grandoc Post√© le: 29/08/2007 08:20  Mis √† jour: 29/08/2007 08:20
 Re: Xoops 2.0.17
Je vois que je ne suis pas le seul à avoir eu quelques soucis avec certains modules ...
Pour Alexzuka, tu peux récupérer la 2.0.16 ici :
http://www.phpsources.org/ressources-portail-php.htm
Régulier
Inscrit le: 19/01/2007
De:
Contributions: 144
smart Post√© le: 29/08/2007 08:58  Mis √† jour: 29/08/2007 09:00
 Re: Xoops 2.0.17
Merci pour la trad et le travail.
J'ai quelques souci pour accéder aux préférences de certains modules après la mise à jour (notamment smartsection et clones et clientspace), je retourne là ou j'étais.
Smartsetcion retourne des "Undefined index" coté public.
A tester avant de le mettre en prod, sauvegardez bien votre site avant d'effectuer la mise à jour.
Semi pro
Inscrit le: 05/06/2004
De:
Contributions: 750
Niluge Post√© le: 29/08/2007 13:51  Mis √† jour: 29/08/2007 13:51
 Re: Xoops 2.0.17
En parlant du .zip xoops 2.0.17fr:
Dans le répertoire docs, le fichier "install_fr.html" est en double : il y a aussi un fichier "install_fr.html.bak", qui à mon avis vu son nom aurait du être supprimé non?

Voilà juste histoire d'améliorer encore des releases Xoops!

Bon boulot de la team core et de la team FR! (et de ceux qui font parti des 2!)
Supporter Xoops
Inscrit le: 09/01/2005
De: Breizh
Contributions: 16972
Kris Post√© le: 29/08/2007 17:12  Mis √† jour: 29/08/2007 17:12
 Re: Xoops 2.0.17
Concernant le thème "default_simple", vous avez une version corrigée à cette adresse.

Les versions Portable USB avec la version 2.0.17 sont également téléchargeable sur cette adresse.

Kris

@++
Xoops accro
Inscrit le: 15/07/2004
De:
Contributions: 4763
blueteen Post√© le: 29/08/2007 19:56  Mis √† jour: 29/08/2007 20:00
 Re: Xoops 2.0.17
Merci pour la traduction !

@grandoc : il y a des grandes chances que tu aies le même problème que d'autres, à savoir un souci de traduction, et une apostrophe de trop dans une traduction.
abordé sur les forums, et bien repris par Christian, qui a posté ici dans les commentaires d'ailleurs :)
http://www.frxoops.org/modules/news/a ... _mode=thread&#comment5136

l'activation du mode debug t'aurais sans doute dépanné (et les développeurs aussi).

Et pour la version 2.0.16 (fr) que tu voulais récupérer, vous pouvez aller dans le menu de gauche, rubrique 'noyau'.
Puis sur : Xoops 2.0.x versions complètes (1)
Et tout en haut de la page, en assez gros, il est noté :
La dernière version stable est la version 2.0.16 disponible à partir de cet article (avec le lien vers l'article en question).
@++ :)
Régulier
Inscrit le: 01/04/2006
De: IDF - RP
Contributions: 393
coincoin Post√© le: 29/08/2007 23:02  Mis √† jour: 29/08/2007 23:02
 Re: Xoops 2.0.17
non a cet endroit c'est la Xoops 2.0.13.2

j'ai pas trouvé non plus

sur l'autre 2.0.17 xoopsmember ne fonctionne pas :(
Semi pro
Inscrit le: 05/06/2004
De:
Contributions: 750
Niluge Post√© le: 29/08/2007 23:28  Mis √† jour: 29/08/2007 23:28
 Re: Xoops 2.0.17
Les anciennes versions de xoops sont disponibles sur le compte frxoops sur sourceforge
Régulier
Inscrit le: 01/04/2006
De: IDF - RP
Contributions: 393
coincoin Post√© le: 29/08/2007 23:33  Mis √† jour: 29/08/2007 23:33
 Re: Xoops 2.0.17
2.0.16 est ici :

http://www.frxoops.org/modules/news/article.php?storyid=1141

pourquoi faire simple quand on peut faire compliqué
Newbie
Inscrit le: 09/02/2005
De:
Contributions: 11
alexzuka Post√© le: 30/08/2007 00:04  Mis √† jour: 30/08/2007 00:11
 Re: Xoops 2.0.17
Merci pour la version 2.016.

Par contre j'aimerais savoir, si l'équipe de développement compte apporter une correction sur la 2.017 du problème d'installation de certains modules.


L'installation aboutit sur une page blanche, et le module n'est pas utilisable par la suite.
En mode debug, y'a que dalle.

Autre chose, j'ai vu que GIJOE, le concepteur de protector, n'a pas apprécié la 2.017 du fait des nombreuses incompatibilités avec les modules et pense à l'avenir ne plus assurer un soutien à cette version et ses suites.

C'est un peu dommage, surtout quand on voit que Protector est juste essentiel pour Xoops...


Le lien de la discussion de GIJOE sur son forum à propos de la 2.017
Xoops accro
Inscrit le: 25/02/2004
De: Région parisienne
Contributions: 2526
DuGris Post√© le: 30/08/2007 03:10  Mis √† jour: 30/08/2007 03:10
 Re: Xoops 2.0.17
Suite aux diverses interrogations sur le fonctionnement de la version 2.0.17 et de certain module, j'ai fait quelques tests :

Installation et fonctionnement du module news : Ok
Installation et fonctionnement de smartsection : Ok
Installation et fonctionnement de smartpartner : Ok (sauf l'ajout de partenaire qui n'est pas compatible avec mysql 5)

Concernant la réponse de GIJOE, en effet certain module du site peak.ne.jp ne fonctionne pas.
La raison en est très simple, dans ces modules la gestion des templates est différente de celle implémentée dans Xoops (les templates ne sont pas défini lors de l'installation dans le fichier xoops_version.php des modules, mais dans le paramétrage des blocks par les utilisateurs).
Il faut donc en effet télécharger et installer la version modifiée du fichier /class/smarty/xoops_plugins/resource.db.php.

Pour autant, je ne définirai pas cela comme un bug, a partir du moment ou GIJOE a décidé de gérer les templates des modules de façon différente à celle prévue dans Xoops.

Pour info complémentaire, j'ai utilisé la version proposée en téléchargement plus haut dans l'article, et pour les modules il s'agit bien évidement des dernières versions !!!
Xoops accro
Inscrit le: 16/08/2005
De: Nanterre
Contributions: 2331
eparcyl92 Post√© le: 30/08/2007 08:58  Mis √† jour: 30/08/2007 08:58
 Re: Xoops 2.0.17
Bonjour,
Après une nuit blanche et avant de pieuter, la Hack d'inscription de membres des Nullos est téléchargeable et complètement ré-écrit pour Xoops 2.0.17 fr
Il y a des petits plus dans les "findusers" mais le module "xoopsmembers" n'est pas installable malheureusement (pour le moment).
Bravo pour le boulot de Xoops 2.0.17 et la traduc..
Je l'ai dans un site test, mais je vais attendre un peu avant de le mettre en produc...
Bonne nui... heu.. bonne journée
HACH DES NULLOS POUR XOOPS 2.0.17 FR
Xoops accro
Inscrit le: 15/07/2004
De:
Contributions: 4763
blueteen Post√© le: 30/08/2007 12:24  Mis √† jour: 30/08/2007 12:24
 Re: Xoops 2.0.17
Citation :

Auteur: coincoin Posté le: 29/8/2007 23:02:18

non a cet endroit c'est la Xoops 2.0.13.2

j'ai pas trouvé non plus


Je réitère et confirme ce que j'ai dit plus haut :

Et pour la version 2.0.16 (fr) que vous vouliez récupérer, vous pouvez aller dans le menu de gauche, rubrique 'noyau'.
Puis, cliquer sur : Xoops 2.0.x versions complètes (1)
Et tout en haut de la page, en assez gros, il est noté :
La dernière version stable est la version 2.0.16 disponible à partir de cet article (avec le lien cliquable vers l'article en question).
Et dans l'article, vous trouvez bien le lien vers la version 2.0.16

Pourquoi faudrait-il laisser en avant la version 2.0.16 alors qu'une plus récente (et conseillée) est disponible...
Régulier
Inscrit le: 07/09/2006
De: So So Far
Contributions: 478
Monoroom Post√© le: 30/08/2007 13:55  Mis √† jour: 30/08/2007 13:55
 Re: Xoops 2.0.17
bonjour et merci pour le travail

je vais faire la mise a jour ce WE

A+
Aspirant
Inscrit le: 06/07/2005
De:
Contributions: 37
isotropic Post√© le: 30/08/2007 15:47  Mis √† jour: 30/08/2007 15:54
 Re: Xoops 2.0.17
Bien la màj mais je n'arrive plus à accéder aux préférences des News (1.53) Smartsections (2.13) SmartFAQ (1.08) etc...

Quelqu'un qui saurais quoi corriger ou je dois repasser à la 2.0.16

Réedition:

Bon, suis passé en mode débug et j'ai trouvé qu'il s'agissait du fichier de langue "notification.php" ligne 87 à remplacer par

define ('_NOT_NOTHINGTODELETE'"Il n'y a rien √† supprimer.");


Etonnant qu'avant de publier le pack personne n'aie remarque cette faute d'erreur
Xoops accro
Inscrit le: 25/02/2004
De: Région parisienne
Contributions: 2526
DuGris Post√© le: 30/08/2007 19:10  Mis √† jour: 30/08/2007 19:10
 Re: Xoops 2.0.17
@isotropic : il n'y a que ceux qui font rien qui ne se trompent jamais et ne font jamais d'erreur.
Une lecture des commentaires en amont t'aurai permis de voir q’une correction avait été apporté à ce problème et ça en moins de temps qu’il faut pour l’écrire sur ce forum
Régulier
Inscrit le: 01/04/2007
De: Ile de France
Contributions: 461
RC78 Post√© le: 30/08/2007 22:56  Mis √† jour: 30/08/2007 23:00
 Re: Xoops 2.0.17
Merci pour cette nouvelle version de xoops, encore un jolie travail réalisé.
Pour moi aucun soucis après l'adaptation du fichier de langue "notification.php" ligne 87 et l'adaption de mon hack concernant mes champs déroulants complémentaires (profil des membres).
Pour le module xoopsmembers 1.0, News 1.55, CBB 1.16,...pas de soucis non plus
A suivre...

Titi
Aspirant
Inscrit le: 06/07/2005
De:
Contributions: 37
isotropic Post√© le: 31/08/2007 09:28  Mis √† jour: 31/08/2007 09:28
 Re: Xoops 2.0.17
@DuGris: Tout à fait d'accord avec toi, dans ce sens c'est bien pour ça que je suis revenu sur ce forum pour y déposer directement la solution de manière clair .

On ne le dit jamais assez alors merci encore aux concernés pour le boulot fourni.
Aspirant
Inscrit le: 04/02/2003
De: Longjumeau (91)
Contributions: 22
NotOlik Post√© le: 31/08/2007 13:17  Mis √† jour: 31/08/2007 13:17
 Re: Xoops 2.0.17
Super!
Je vais tester ca ASAP...

Sinon, d'après le changelog, il y a quand même pas mal d'améliorations. Ce n'est pas qu'une version "corrective"!!

Et c'est tant mieux!
Team FrXoops
Inscrit le: 14/05/2004
De:
Contributions: 2554
JJDai Post√© le: 31/08/2007 14:58  Mis √† jour: 31/08/2007 14:58
 Version de XOOPS
Bonjour à tous
Je vien d'installer la version 2.0.17, ok pas de problème pour l'instant, ce qui m'amène a vérifier les numéro de version hors avant j'avais installé la 2.0.16 qui indiquait dans la liste des module 1 et 1.02 dans le fenêtre d'info de systemAdmin.
maintenant avec cette version j'ai 1.02 dans la lise des modules et toujours 1.2 dans le fenêtre d'info. Du coup j'ai des doutes et je souhaiterais savoir comment êtr sur que c'est bien la 2.0.17.
Aspirant
Inscrit le: 13/06/2003
De: Metz
Contributions: 69
jmini Post√© le: 31/08/2007 15:34  Mis √† jour: 31/08/2007 15:34
 Re: Version de XOOPS
Tu peux voir ta version de Xoops dans le pied de page de l'interface d'administration.
Semi pro
Inscrit le: 05/06/2004
De:
Contributions: 750
Niluge Post√© le: 31/08/2007 16:27  Mis √† jour: 31/08/2007 16:27
 Re: Version de XOOPS
C'est bien la 2.0.17, j'avais lu dans le changelog que le bug du numéro de version du module système (qui restait toujours à 1 dans la base de donnée, malgré l'indication du numéro dans le fichier xoopsversion.php) avait été corrigé par dugris :

Citation :

Correction : sauvegarde de la réelle version du module system pendant l'installation (dugris)


La correction n'aurait pas été totale?
Team FrXoops
Inscrit le: 14/05/2004
De:
Contributions: 2554
JJDai Post√© le: 31/08/2007 16:47  Mis √† jour: 31/08/2007 16:47
 Re: Version de XOOPS
bin il affiche 2.0.16, pourtant il a du faire quelque chose car le module ppNews est parti en vrille (pour ceux que ca interrese une balise "br" qu'il faut supprimer dans modinfo.php, la constante "_WEPPLETTER" ).
Régulier
Inscrit le: 27/03/2005
De: Pen ar bed
Contributions: 147
vinyz Post√© le: 01/09/2007 11:52  Mis √† jour: 01/09/2007 11:52
 Re: Version de XOOPS
Merci à toute l'équipe pour votre travail et votre dévouement
Semi pro
Inscrit le: 05/06/2004
De:
Contributions: 750
Niluge Post√© le: 02/09/2007 00:28  Mis √† jour: 18/12/2007 01:48
 Re: Xoops 2.0.17
Il faudrait mettre en gros :

Sécurité

Nous recommandons fortement l'installation du module Protector ce qui apportera une protection additionnelle et des possibilités de journalisation à votre site.

La dernière version(3.13) du module Protector a été intégrée dans le package francophone. Consulter le fichier protector/doc/documentation_protector-3-13_french.pdf pour la procédure d'installation.
Régulier
Inscrit le: 04/02/2003
De: Nord de la France
Contributions: 130
yerac Post√© le: 02/09/2007 04:43  Mis √† jour: 02/09/2007 04:43
 Re: Xoops 2.0.17
Eh bien ca fait une belle évolution en attendant la fusion des deux branches et le prochain Xoops.

Par contre question bete :

Si on utilise le "Multilangage" de la Smartfactory je suppose qu'il ne faut pas passer à cette 2.0.17 pour le moment ?
Semi pro
Inscrit le: 21/11/2004
De: Un petit coin de Belgique
Contributions: 826
satanas Post√© le: 03/09/2007 09:11  Mis √† jour: 03/09/2007 09:11
 Re: Xoops 2.0.17
Effectivement, faut attendre la sortie du hack ML de la smartfactory pour la version 2.0.17
Newbie
Inscrit le: 19/08/2007
De:
Contributions: 4
ylg Post√© le: 03/09/2007 09:19  Mis √† jour: 03/09/2007 09:19
 Re: Xoops 2.0.17
Bonjour

Concernant protector, j'ai bien une version "embarquée" mais qui ne semble pas fonctionner. J'utilise xoops 2.0.17, et la version protector est annoncée comme la 3.13.

Dans les modules, protector apparait à moitié (pas d'icone), et comme non installé. Quand j'essaye de l'installer il me dit que le module est déjà installé, et la documentation citée un peu plus haut n'aborde pas ce bug. Je suis un vilain noob, et je voudrais pas tout casser :)

Please help (comme dirait Leelou à Bruce Willis)...

PS: je n'arrive plus à changer mes thèmes, alors que ça fonctionnait bien la semaine dernière oO...
Régulier
Inscrit le: 07/09/2006
De: So So Far
Contributions: 478
Monoroom Post√© le: 03/09/2007 18:52  Mis √† jour: 03/09/2007 18:52
 Re: Xoops 2.0.17
Citation :
Mise à jour à partir de XOOPS 2.0.16

...
3. Copiez le contenu du répertoire htdocs à la racine de votre site par dessus vos fichiers existants
...


Mais pas le fichier mainfile.php !!!

J'ai essayé avec le pack spécial
Mise à jour de 2.0.16 vers 2.0.17
Mais ceci ne marchait pas bien, Dont j'ai décidé d'utilisé le pack original !!!

A part de quelque souci de la compatibilité avec certain module (MPmanager 2.5, ...) je peux le certifier qu'il marche à merveil !!!

Vive XOOPS !!!
Merci à l'équipe
Monom.
Newbie
Inscrit le: 18/07/2005
De:
Contributions: 2
steff Post√© le: 10/09/2007 15:15  Mis √† jour: 10/09/2007 15:20
 Re: Xoops 2.0.17
Bonjour,

Bien la correction du bug
Correction bug #1748019 : problème d'authentification LDAP avec le symbole Euro (pemen)
Mais donner la réference de la personne qui c'est acharné pour trouvé le problème aurais été sympa :)
Voir le fil de la discussion => http://www.xoopspro.com/modules/newbb ... c.php?topic_id=33&forum=2
pour les intéressé.

A savoir, qu'il n'y avait pas que le problème du signe Euro, mais parfois des accents et autres caractères.

Enfin je n'en tiens pas rigueur, je trouve juste cela dommage de ne pas citer l'auteur de la correction de ce problème.

Cordialement
Xoops accro
Inscrit le: 15/07/2004
De:
Contributions: 4763
blueteen Post√© le: 10/09/2007 18:25  Mis √† jour: 10/09/2007 18:26
 Re: Xoops 2.0.17
ce n'est sans doute pas évident non plus de coller un lien vers un message d'un forum, pour chaque résolution de bugs !
comment faire par exemple, si une résolution de bugs est liée à plusieurs forums ou plusieurs sujets !
en tout cas, sur tous les projets open source que je connais (et leur change log) ce n'est pas l'habitude.
on trouve juste le nom de l'auteur. (Pemen indiqué ici, ce n'est pas le cas ?)
dans l'article ci-dessus, on a :
# Xoopspro - Pemen (module de workflow, authentification LDAP,OpenID,explorateur de fichiers)
donc ceux qui veulent en savoir plus, peuvent quand même faire le lien avec xoopspro, mais crois-moi, d'expérience, les gens sont justes contents de savoir que ça marche, et éventuellement l'auteur.
après, le pourquoi du comment, sur x pages de messages, sur un forum externe, ça n'attire pas les foules.
mais ça n'enlève rien au travail fait, mais ça fait partie de "l'ingratitude"
merci donc pour ton rappel qui a plus ça place ici que dans un changelog déjà bien chargé
Newbie
Inscrit le: 18/07/2005
De:
Contributions: 2
steff Post√© le: 11/09/2007 03:37  Mis √† jour: 11/09/2007 03:40
 Re: Xoops 2.0.17
Je n'ai pas dit qu'il n'en était pas l'auteur (le module en lieu même), je dis juste qu'il aurait était bon de citer la personne ayant trouver la soluce.

Merci de ton petit mot.
Régulier
Inscrit le: 07/09/2006
De: So So Far
Contributions: 478
Monoroom Post√© le: 11/09/2007 14:00  Mis √† jour: 11/09/2007 14:00
 Re: Xoops 2.0.17
Newbie
Inscrit le: 20/12/2005
De:
Contributions: 13
philippe85 Post√© le: 25/09/2007 10:37  Mis √† jour: 25/09/2007 10:37
 Re: Xoops 2.0.17 Bug traduction fran√ßaise pour la MAJ 2.0.16 en 2.0.17
Dans le fichier /language/french/notification.php, la dernière ligne (87) a une erreur, l'apostrophe après "Il n" ferme la chaine, il faut la préfixer d'un backslash. Cela semble avoir été fait dans la version complète.
define ('_NOT_NOTHINGTODELETE''Il n'y a rien √† supprimer.');

à remplacer par
define ('_NOT_NOTHINGTODELETE''Il n'y a rien √† supprimer.');
.

Merci à tous pour le travail
Aspirant
Inscrit le: 12/01/2004
De:
Contributions: 48
gomugomu67 Post√© le: 30/09/2007 12:08  Mis √† jour: 30/09/2007 12:08
 Re: Xoops 2.0.17
Bonjour, j'ai repéré une petite faute dans le module d'installation de xoops 1.7 ^^

Dans la partie configuration générale : [...] Utiliser les connexions persistentes [...]

C'est persistante avec un "a" et non avec un "e".
Régulier
Inscrit le: 27/03/2005
De: Pen ar bed
Contributions: 147
vinyz Post√© le: 15/10/2007 17:04  Mis √† jour: 15/10/2007 17:04
 Re: Xoops 2.0.17
Bonjour,

bon, content que ça ait fonctionné pour vous, mais pour moi, c'est encore un échec ... comme toutes les mises à jour de Xoops

Quand je suis scrupuleusement ce qui est marqué - soit copier le contenu du répertoire htdocs à la racine du site, j'obtiens le formulaire d'installation de Xoops. Je remet mon mainfile.php original, et rien ne se passe.

Je retourne dans la gestion des modules pour mettre le System à jour ... rien ne se passe, il reste en 1.02.

Bizarre ...
Régulier
Inscrit le: 27/03/2005
De: Pen ar bed
Contributions: 147
vinyz Post√© le: 16/10/2007 09:49  Mis √† jour: 16/10/2007 09:49
 Re: Xoops 2.0.17
Bon, ça fonctionne ...

juste l'emplacement du répertoire /trust destiné à Protector :)

l'ancien paramétrage n'a pas été apprécié ... j'ai donc mis le répertoire /trust à la racine comme demandé, et hop ! tout fonctionne.
Anonyme Post√© le: 17/10/2007 11:51  Mis √† jour: 17/10/2007 12:00
 Re: Xoops 2.0.17
bonjour,

réf: steff/blueteen

ce n'est pas une question d'ingratitude,
c'est une simple question de respect de licence.
tout comme dans certains modules il est recommandé de laisser la mention de l'équipe qui a réalisé le module en bas, ou "portail fait avec xoops",
quand on prend un source de quelqu'un, il est en général recommandé de le citer, ne serait-ce que pour en reconnaitre le travail.
maintenant, si on ne veut pas reconnaitre le travail et la licence qui y est accordée, on ne prend pas le source, c'est aussi simple que cela.
quiconque n'est pas d'accord avec peut aussi bien relire la licence sous laquelle est xoops.
Newbie
Inscrit le: 09/12/2007
De:
Contributions: 1
nanoblogmaster Post√© le: 13/12/2007 20:22  Mis √† jour: 13/12/2007 20:22
 Re: Xoops 2.0.17
Au secours, page blanche alors que tout s'est parfaitement déroulé pendant l'install, j'ai eu le fameux cliquer ICI puis plus rien : PAGE BLANCHE
Team FrXoops
Inscrit le: 20/02/2006
De:
Contributions: 1162
mr-reda04 Post√© le: 13/12/2007 21:45  Mis √† jour: 13/12/2007 21:45
 Re: Xoops 2.0.17
Message d'erreur en mode debug ?

P.S: C'est plus + favorable de poster ton problème dans les forums !
Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

34 Personne(s) en ligne (1 Personne(s) connectée(s) sur Articles) | Utilisateur(s): 0 | Invité(s): 34 | Plus ...