Fork me on GitHub

Xoops 2.0.18.2

200829
Août
  Christian Versions 6185

Open in new windowL'équipe de développement Xoops a le plaisir de vous annoncer la sortie de XOOPS 2.0.18.2.

Dans cette version un contrôle des permissions du gestionnaire d'images a été corrigé par Dugris. Un bug a également été éliminé dans les sessions personnalisées avec l'activation de regenerateId. Pour terminer, le paramètre 'fct' du fichier admin.php est désormais filtré.

1. Spécifications système

PHP
version PHP >= 4.3.0+ (PHP 4.2.x peut fonctionner mais n'est pas officiellement supporté)
MySQL
serveur MySQL 3.23+
Serveur Web
Un serveur supportant la version PHP requise (Apache fortement recommandé)


2. Téléchargement

Vous pouvez télécharger la version francophone de Xoops 2.0.18.2 pour une nouvelle installation sur notre espace sourceforge.

Dans ce package nous avons intégré la dernière version du module Protector (version 3.16) qui protégera votre site des attaques malicieuses.

  1. Xoops 2.0.18.2 FR - version complète
  2. Mise Ă  jour de Xoops 2.0.18.1 vers Xoops 2.0.18.2

3. Installer Xoops

  1. DĂ©compressez l'archive
  2. Transférez la totalité du contenu du dossier htdocs à la racine de votre serveur (ce n'est donc pas le dossier lui-même qu'il faut transférer mais tout ce qu'il contient
  3. VĂ©rifiez que les dossiers cache, templates_c, uploads et xosecure\modules\protector\configs sont accessibles en lecture-Ă©criture par le serveur (chmod=777), ainsi que le fichier mainfile.php
  4. Contrôlez que tous les fichiers ont bien été uploadés sur le serveur avec l'utilitaire de contrôle d'intégrité des fichiers qui est décrit un peu plus loin dans cet article
  5. Dans votre navigateur saisissez l'adresse de votre site pour démarrer l'assistant d'installation
  6. A la fin de l'installation, une fois que vous aurez pu vous connecter sur votre site et avoir accès au menu administration, n'oubliez pas de supprimer le répertoire install et de mettre le fichier mainfile.php en lecture seule (chmod = 444)
  7. la version francophone contient un assistant d'installation (réalisé par Skalpa puis modifié par Dugris) différent de la version originale ; son utilisation sur free.fr nécessite, au préalable, la création d'un dossier "sessions" (au pluriel et en minuscules) à la racine de votre site.

4. Contrôle de l'intégrité des fichiers

Cette version de Xoops est livrée avec un script capable de vérifier si tous les fichiers du "system" (le noyau xoops) ont bien été uploadés sur le serveur. En effet il peut arriver que lors du transfert des fichiers avec votre logiciels ftp, certains fichiers s'égarent ou ne sont pas complètement uploadés des octets manquants dans certains fichiers altèreraient le bon fonctionnement de votre site.

Pour l'utiliser, suivez ces instructions :

  1. uploader les fichiers checksum.php et xoops.md5, situé à la racine du package dans le répertoire racine de votre serveur
  2. exécutez checksum.php dans votre navigateur
  3. si nécessaire, réuploader les fichiers manquants ou corrompus
  4. supprimer les fichiers checksum.php et xoops_.md5 de votre serveur

5. Mise à jour à partir d'une version antérieure

5.1 Mise Ă  jour Ă  partir d'une version 2.0.18.1

  1. Téléchargez le fichier de mise à jour à partir de notre espace sourceforge
  2. Transférez ces fichiers avec votre logiciel ftp sur votre serveur, ce qui va écraser les fichiers plus anciens
  3. Dans admin system, modules, faites une mise à jour du module système

5.2 Mise Ă  jour Ă  partir de XOOPS 2.0.14/2.0.15/2.0.16/2.0.17/2.0.18.* (utilisation du package complet)

  1. Commencez par faire une sauvegarde de vos fichiers et de votre base de données (on n'est jamais trop prudent)
  2. Après avoir décompressé l'archive de la version complète dans un répertoire temporaire, supprimez :
    1. htdocs/mainfile.php
    2. htdocs/install/
    3. htdocs/cache/
    4. htdocs/extras/
    5. htdocs/template_c/
    6. htdocs/themes/
    7. htdocs/uploads/
    8. htdocs/xosecure
    9. htdocs/modules/protector
  3. Ensuite déplacez le répertoire upgrade dans le dossier htdocs
  4. Transférer par ftp le contenu du dossier htdocs (et pas le dossier lui-même) à la racine de votre site
  5. Dans votre navigateur saisissez l'adresse http://www.votresite.com/upgrade/ et suivez les instructions affichées
  6. Après cette opération supprimez le dossier upgrade de votre serveur

5.3 Mise Ă  jour Ă  partir d'une version 2.0.7 Ă  2.0.13.2

  1. Commencez par faire une sauvegarde de vos fichiers et de votre base de données (on n'est jamais trop prudent)
  2. Après avoir décompressé l'archive de la version complète dans un répertoire temporaire, supprimez :
    1. htdocs/mainfile.php
    2. htdocs/install/
    3. htdocs/cache/
    4. htdocs/extras/
    5. htdocs/template_c/
    6. htdocs/themes/
    7. htdocs/uploads/
    8. htdocs/xosecure
    9. htdocs/modules/protector
  3. Ensuite déplacez le répertoire upgrade dans le dossier htdocs
  4. Transférer par ftp le contenu du dossier htdocs (et pas le dossier lui-même) à la racine de votre site
  5. Sur votre serveur, supprimer le dossier class/smarty/core et le fichier class/smarty/plugins/resource.db.php
  6. Toujours sur votre serveur, supprimez tout le contenu du répertoire templates_c à l'exception du fichier index.html
  7. Assurez vous que le fichier mainfile.php est accessible en Ă©criture par le serveur (chmod=777)
  8. Dans votre navigateur saisissez l'adresse http://www.votresite.com/upgrade/ et suivez les instructions affichées
  9. Après cette opération supprimez le dossier upgrade de votre serveur
  10. A partir du menu administration, allez dans admin system, modules, puis effectuez une mise Ă  jour du module system
  11. Modifiez les autorisations du fichier mainfile.php pour le mettre en lecture (chmod=444)

6. Incompatibilité avec quelques modules

Depuis la version Xoops 2.0.14, une modification dans la méthode des templates du noyeu provoque une incompatibilité avec quelques modules qui ne disposent pas de templates dans le dossier templates du module ("dirname"/templates/) comme les autres modules Xoops. Voici quelques exemples : wraps, 3dforum etc...

Si vous utilisez l'un de ces modules, vous pouvez corriger ce problème en remplaçant le fichier class/smarty/xoops_plugins/resource.db.php par celui contenu dans le dossier extras. Ce fichier est un correctif fourni par Gijoe sur http://peak.xoops.ne.jp.

Cette correction sera intégrée dans une version ultérieure du noyau pour fournir une meilleure compatibilité. Nous remercions GiJoe de peak.xoops.ne.jp pour son travail sur ce sujet.

7. Modules

Les packages Xoops ne contiennent pas de modules en dehors du module system. Vous pouvez parcourir notre espace téléchargement de modules.

Quelques uns des meilleurs modules peuvent être trouvés sur les sites suivants :

Si vous utilisez l'un des modules de xoopsforge (CBB 3.08,planet, article (et non news),etc... vous devez actualiser le composant Framework.

8. Sécurité

Nous recommandons fortement l'installation du module Protector ce qui apportera une protection additionnelle et des possibilités de journalisation à votre site. Il vous suffit juste laisser cocher à Oui l'écran qui vous proposera son installation.

La dernière version (3.16) du module Protector a été intégrée dans le package francophone. Consulter le fichier protector/doc/documentation_protector-3-16_french.pdf pour en comprendre le paramétrage.

Note: 0.00 (0 votes) - Noter cet article -

Partager Twitter Partagez cette article sur GG+
Format imprimable Envoyer cet article Ă  un ami
Les commentaires appartiennent Ă  leurs auteurs. Nous ne sommes pas responsables de leur contenu.
Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

111 Personne(s) en ligne (4 Personne(s) connectée(s) sur Articles) | Utilisateur(s): 0 | Invité(s): 111 | Plus ...