Fork me on GitHub






Xoops 2.3.0 & EMLH: accents, ça marche pas
Régulier
Inscrit: 20/03/2003 14:12
De Bruxelles
Messages: 319
Bonjour à tous,
j'utilise Xoops 2.3.0 avec EMLH pour les traductions,
tout fonctionne bien, mais dès que j'utilise un accent, la traduction de la page s'arrête au caractère précédant celui avec accent; le reste du texte ne s'affichant pas.

Merci pour votre aide.

Posté le : 17/10/2008 09:16

Merci íƒÂ  ceux qui permettent íƒÂ  Xoops d'avancer. Ils se reconnaîtront

http://www.4inch.be: 4INCH: for intelligent change!
Home Automation - Domotique


("DjVPX" a été rebaptisé "sm@
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Xoops accro
Inscrit: 18/01/2004 17:13
De Ma Caverne
Messages: 2839
je confirme, j'ai eu le même souci hier soir
voila qu'on en connait la raison, maintenant il va falloir expliquer et trouver la bonne soluce

Posté le : 17/10/2008 19:18

Trio de choc : FrXoops, FreeboxHD et OVH
MdxProd.com : des liens xoops indispensables
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Newbie
Inscrit: 18/10/2008 15:09
Messages: 2
Effectivement, j'ai aussi le même soucis, j'ai beau cherché des tuto pour résoudre le problème mais rien ne marche, même en modifiant la ligne 200 sur le fichier global.php en remplaçant "ISO-8859-1" par "UTF-8" la traduction de la page s'arrête toujours au caractère précédant.

quelqu'un a une solution ???
Merci d'avance

Posté le : 18/10/2008 15:21
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Régulier
Inscrit: 29/03/2007 17:04
Messages: 343
J'ai résolu provisoirement le problème en mettant mon site en français dans les préférences systèmes (avec la traduction non officielle de Xoops 2.3) .

Mais du coup c'est le forum qui foire pour marquer "aujourd'hui" il marque "A000000j2008urd'hui".

Posté le : 18/10/2008 20:43

http://www.orthodontie-fr.com et pan dans les dents
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Newbie
Inscrit: 18/10/2008 15:09
Messages: 2
Toujours pas de solution pour moi, la page s'arrête toujours au caractère précédant en présence d'un accents...!!!

Posté le : 19/10/2008 20:19
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Semi pro
Inscrit: 05/02/2006 23:34
De Ile-de-France
Messages: 520
Bonsoir,

Je rencontre le problème en français dans le module « user profile » lorsque je modifie le titre d’un champ.

Si l’on remplace les caractères accentués par leur code HTML, ça marche...
Ex. & e a c u t e ; (sans espace) pour « é »

Peut-être une piste ?

@+
Z

Posté le : 23/10/2008 20:40
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Semi pro
Inscrit: 05/02/2006 23:34
De Ile-de-France
Messages: 520
Bonsoir,

RC78 alias Titi, m'a donné une solution qui a réglé le problème d'accents que j'ai exposé hier.

En voici le lien.

Dites-moi si ça marche pour vous...

@+
Z

Posté le : 24/10/2008 22:27
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Semi pro
Inscrit: 05/02/2006 23:34
De Ile-de-France
Messages: 520
@flagada Citation :
Mais du coup c'est le forum qui foire pour marquer "aujourd'hui" il marque "A000000j2008urd'hui".


Je rencontre également le problème, et pour hier s'affiche "HiEurope/Parisr" ou "HiEurope/Berlinr" dans le site de madaxlux

En janvier 2008, donc avant la 2.3, madaxlux parle de ce problème ici

Mais la solution n'a pas encore été trouvée...

@+
Z

Posté le : 25/10/2008 00:24
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Semi pro
Inscrit: 05/02/2006 23:34
De Ile-de-France
Messages: 520
Bonsoir à tous,

Citation :
"aujourd'hui" il marque "A000000j2008urd'hui".


J’ai pas mal cherché… mais J'ai trouvé !

Voilà comment corriger
(fichiers de traduction de la 2.3 de titi) :

/language/french/global.php

lignes 173 & 174

define("_TODAY""Aujou\rd'hui H:i:s");
define("_YESTERDAY""Hie\r H:i:s");


à remplacer par :

define("_TODAY""Aujou\rd'hui H:i:s"); 
define("_YESTERDAY""Hie\r H:i:s");


adieu les A000000j2008urd'hui et les HiEurope/Parisr !!

@+
Z

Posté le : 25/10/2008 19:20
Partager Twitter Partagez cette article sur GG+
Re: Xoops 2.3.0 & EMLH: accents, ça marche pas
Régulier
Inscrit: 29/03/2007 17:04
Messages: 343
Ca fait longtemps mais je viens de me rendre compte que j'avais oublié de te dire un grand merci!
C'est réparé

Posté le : 04/02/2009 11:23

http://www.orthodontie-fr.com et pan dans les dents
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

35 Personne(s) en ligne (27 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 35 | Plus ...