Fork me on GitHub




(1) 2 3 4 »


De retour après 10 ans ... et petit problème
Régulier
Inscrit: 20/11/2005 11:48
Messages: 215
Hello,

Je suis en train de mettre à jour mon site qui était en 2.5.4.

Après voir fait les upgrade vers la 2.5.10, je souhaite mettre à myalbum-p. J'ai trouvé la version de 2020 (génial). Mais voila, j'ai une belle erreur après l'install du module (il est pourtant désactivé)

Parse error: syntax error, unexpected '{', expecting identifier (T_STRING) in XXXXXX www\modules\myalbum\xoops_version.php on line 20

mais aussi

Fatal error: Cannot make static method MyTextSanitizer::getInstance() non static in class MyAlbumTextSanitizer in D:\Programmes\projets_kiff\old\www\modules\myalbum\class\myalbum.textsanitizer.php on line 7 (ça c'est avec l'ancienne version qui visiblement ne veut pas fonctionner avec xoops 2.5.10

Je ne sais pas interpréter ces erreurs.
XoopsInfo :

Version de Xoops : XOOPS 2.5.10
Th�me Xoops : xswatch4
Jeu de templates : default
Version PHP : 5.6.40
Version MySQL :
Logiciel serveur : Apache/2.4.51 (Win64) PHP/5.6.40
Statut safe mode : OFF
Register Globals : OFF
Navigateur : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36
Support librairie GD : Activ� (vignettes disponibles)
Version libraire GD : bundled (2.1.0 compatible)
Statut d'upload du serveur : ON
Taille maximum d'upload autoris�e : 2M

J'ai tenté d'upgrader le PHP en 7.0.... j'ai tout un tas d'erreur.... je suis donc repassé en 5.6.40

Merci par avance.

Posté le : 22/01/2022 01:08
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Régulier
Inscrit: 20/11/2005 11:48
Messages: 215
Bon....

J'ai procédé à la hache.

J'ai supprimé tous les modules inutilisés et réputés plus mis à jour.

J'ai bien conservé mon forum en faisant la mise à jour vers la derniere version de Newbb.

Mais que je veux installer MyAlbum 3.09.....

Error : ParseError: syntax error, unexpected '='

Impossible. Je peux aller partout dans le site mais impossible d'installer ce module sans avoir cette erreur.

Je suis passé en php 7.0.29




Posté le : 22/01/2022 09:46
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2554
Bonjour,
pour la deuxième erreur je pense qu'il s'agit des appels a des fonctions par référence, syntaxe qui n'est plus supportée.
Pour la première je ne vois pas trop il faudrait que j'ai le module pour l’interpréter.
Peux-tu me dire ou tu as trouver le module, je vais tenter d'y remédier.
JJDai

Posté le : 22/01/2022 11:17

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Régulier
Inscrit: 20/11/2005 11:48
Messages: 215
Hello et merci.

Ici. https://github.com/XoopsModules25x/myalbum/releases/tag/3.09_Beta-1


Comme indiqué, je suis passé en php 7.0;29

J'ai supprimé tous les modules. Sauf la derniere version de NewBB.

Posté le : 22/01/2022 11:28
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2554
ok, je regarde ça des que j'ai un moment.
JJDai

Posté le : 22/01/2022 11:39

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2554
Je viens de l'installer et je n'ai aucune erreur.
Cependant, j'avais renommé le dossier en "myalbum-p" et impossible de l'installer, erreur sql. probablement un fichier non trouvé a cause du nom du dossier.
Je l'ai renommé en "myalbum" et aucun soucis, installation ok et navigation dans le module ok.

donc questions :
- quel est le nom du dossier ?

-dans ton premier post tu parles d'erreur sur l'ancienne version, du coup je ne sais plus trop qu'elle anomalie tu as.
on oublie l'ancienne version, parlons uniquement de la 3.9 que Mamba a mis à jour, ce sera plus simple et plus judicieux.

Posté le : 22/01/2022 12:00

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2554
Citation :
J'ai tenté d'upgrader le PHP en 7.0.... j'ai tout un tas d'erreur.... je suis donc repassé en 5.6.40


Je ne pense que c soit une bonne idée car cette version de php finira par disparaitre, et du coup si ces erreurs sont dues à la version de PHP, je ne pourrais pas t'aider faute de l'environnement adoc.

Dans ma config, le module fonctionne correctement.
JJDai

Posté le : 22/01/2022 12:07

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2837
Citation :
Dans ma config, le module fonctionne correctement.

Je confirme, ça fonctionne aussi chez moi.
vérifie qu'il n'y a pas d'anciens fichiers qui traine dans le répertoire /class de myalbum. Avec les autoload, un ancien fichier pourrait être appelé et interférer.

Idéalement, pour faire une MAJ de modules aussi lointaine, faut mieux supprimer le répertoire et installer la nouvelle version que d'écraser l'ancienne version avec la nouvelle.

Posté le : 22/01/2022 12:57
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Régulier
Inscrit: 20/11/2005 11:48
Messages: 215
Hello

J'ai supprimé, désinstallé, vérifié dans PHPmyadmin qu'il n'y a plus rien.

Je ne peux pas faire l'install car j'ai tout de suite le message :

Internal Server Error

A problem has occurred on our server!
Page is currently unavailable
We are working on a fix
Please come back soon ...

Error : ParseError: syntax error, unexpected '='


Wampserver derniere version
MySql 5.7.36

Posté le : 22/01/2022 13:21
Partager Twitter Partagez cette article sur GG+
Re: De retour après 10 ans ... et petit problème
Régulier
Inscrit: 20/11/2005 11:48
Messages: 215
Faut-il que je reparte d'une fresh install de Xoops ?

J'ai fais les mises à jour automatiques une par une depuis la 2.5.4 jusqu'a la 2.5.10. J'ai bien utilisé les upgrade.

Je crois que je vais passer à extgallery, il est intégré au thème Xswatch et j'avais travaillé sur la migration des tables SQL de MyAlbum vers ExtGallery il y a quelques années.


Posté le : 22/01/2022 13:28
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
(1) 2 3 4 »



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

9 Personne(s) en ligne (4 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 9 | Plus ...