Fork me on GitHub




« 1 2 3 (4)


Re: Le module FAQ a disparu ?
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2524
non c'est la classe limagei de du fichier:
xoopsfaq/templates/css/module.css

.limagei {
    list-
style-imageurl(../../images/faq.png);
    list-
style-typecircle;
    
margin-left15px;
    
color:rgb(0,153,255);
    
font-size1.2em;
    
font-weightbold;
}

Posté le : 22/02 19:53

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 34
Bonjour,

Non, ce n'est pas ça.
C'est assez fou, j'ai l'impression que c'est un zoom sur toute la page... Ca te fait ça aussi ?

J'ai commenté dans les CSS tout ce qui touchait les font-size, rien.
J'ai même renommé les 4 fichiers css du module pour casser le lien, ça ne change rien.
Et c'est la même chose sur chrome comme sur FF.
J'ai même été fouiller dans les JS sans succès.
C'est très fort 0_0

Ce qui est surprenant, c'est que ça ne fait ça que sur le thème default, mais c'est le thème que j'ai ciblé pour mes autres modules.

Posté le : 23/02 09:32
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2762
Vérifie sur ta page l'état du DOM.
Tous les id de chaque balise, pas d'espace, pas de symboles spéciaux, uniques (pas 2 id identique), etc...
J'ai rencontrer quelques modules qui utilisaient par exemple le titre pour générer un id, en français, avec les accents et les apostrophes, ça plante.
suffit qu'une propriété JS ou CSS est appliqué sur un de ces ID foireux pour que ça se répercute au bloc parent par héritage.

Posté le : 23/02 11:28
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2524
Je confirme que c'est bien la classe
.limagei {
    list-
style-imageurl(../../images/faq.png);
    list-
style-typecircle;
    
margin-left15px;
    
color:rgb(0,153,255);
    
font-size1.2em;
    
font-weightbold;
}

Il faut modifier font-size=1em ou 0.8em et peut être enlever font-weight si tu ne veux pas de gras.
Je viens de tester avec le thème par défaut le changement est bien pris en compte.

Open in new window


et pour les onglets.
Open in new window


Ce sont des choses que j'avais laissées en l'état quand j'ai repris le module, mais je vais peut être prendre le temps de modifier, notamment les valeurs absolues comme "8pt", il vaut mieux je pense les valeurs relative en "em".

Posté le : 23/02 11:46

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 34
Je ne suis pas sur qu'on parle de la même chose.

Je parle de tous les textes de Xoops, en dehors du module compris.
Le menu principal, utilisateur, ....
Egalement, il y a un espace entre le bandeau haut et le top de la page (ça ne le fait que sur ce module).

Je me rend compte que dans l'admin aussi, il y a cet espace.
Et cette erreur dans le debugger:Erreurs
NotificationTrying to access array offset on value of type bool dans le fichier /Frameworks/moduleclasses/moduleadmin/moduleadmin.php ligne 335

Je ne sais pas si c'est lié.

Posté le : 23/02 12:13
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2524
pour l'espace je me souviens avoir eu ça parce que le template était enregistré en utf8, ou quelque chose comme ça.

Tu peut regarder sur mon site de test, j'ai mis la liste des thème en bas et activé les menus pour accéder au module.
JJDai

Posté le : 23/02 12:16

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2762
en principe oui, les templates du module doivent être en UTF-8, et j'espère qu'il n'y a plus de module avec des template iso-latin encore en circulation.

Posté le : 23/02 12:40
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2524
bon pour l'espace au dessus de la barre de menu j'ai fini par trouver.
C'est bien un problème d'encodage. en l’occurrence c'est le fichier language/common.php, je l'ai mis en utf8-no-bom et le problème a disparu.
Mise à jour sur gitHub

Posté le : 23/02 18:32

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Aspirant
Inscrit: 28/11/2021 22:07
Messages: 34
En effet, c'était ça aussi le souci avec les polices générales.

Top, je vais pouvoir m'amuser avec ton module. merci.

Posté le : 24/02 08:50
Partager Twitter Partagez cette article sur GG+
Re: Le module FAQ a disparu ?
Team FrXoops
Inscrit: 14/05/2004 22:32
Messages: 2524
L'encodage des pages est chaque souvent une vrai galère.
La j'ai du m'y reprendre une bonne dizaine de fois.
Peut-être est-ce du à l'éditeur de texte que j'utilise (pspad).
L'essentiel est de solutionner le problème.
Merci pour les retours.
JJDai

Posté le : 24/02 09:42

Ne pas perdre patience, même si cela semble impossible, c'est déjà de la patience.
Origami
Conseil des Sages
Sur gitHub
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 2 3 (4)



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

31 Personne(s) en ligne (25 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 31 | Plus ...