Fork me on GitHub






Pb affichage sur certaines plaformes ...
Régulier
Inscrit: 26/05/2005 12:43
Messages: 373
Bonjour à Tous,

Désolé, je ne m'étais pas connecté depuis longtemps ...

Je me "prends la tête" depuis plusieurs jours concernant un site web sous :
XOOPS 2.5.7.2 - PHP 5.6.40

Je précise que je possède plusieurs sites avec les mêmes releases "XOOPS 2.5.7.2 - PHP 5.6.40" et qui n'ont pas ce problème. Tous mes sites de production sont hébergés chez OVH.

Mon site en question ne s'affiche plus correctement comme si tous les templates et CSS étaient désactivés et cela UNIQUEMENT sous Android (donc smartphone et tablette) et certains PC windows avec Chrome ...

Selon des utilisateurs le problème n'existe pas sous Firefox ou Edge ou autres navigateurs ... Moi-même, sur 3 PC je constate le problème sur 1 seul (les 3 étant sous navigateur Chrome); ce dernier n'a plus de pb si j'utilise Edge au lieu de Chrome. En revanche, je constate le problème sur mon smartphone et ma tablette ! (ça n'a pas été toujours le cas).

Le debugger ne signale rien de particulier sur les machines sous ce problème ...

Bien sûr, j'ai testé avec 3 "Themes" différents ... même constat !

Enfin, je possède un serveur privé sous SME-server qui est dédié à mes développements. Lorsque je teste mon site depuis cet hébergement perso, je n'ai pas de problème, je vois parfaitement mon site depuis mes PC, tablette ou smartphone !!

Bref, je ne comprends rien ...

Posté le : 19/10/2023 20:12
Partager Twitter Partagez cette article sur GG+
Re: Pb affichage sur certaines plaformes ...
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2837
J'ai déjà eu des pbs de ce genre.
En premier : mélange de domaine et sous domaine (par ex: monsite.fr et www.monsite.fr)
Par exemple pour les appels CSS, les navigateurs rejettent de plus en souvent les mélanges. Un site monsite.fr doit appeler les fichiers css de ce domaine.

En second :
appel de fichier http: alors que le site est sous https:
Pareil, les navigateurs empechent le chargement

Plus rare mais ça peut arriver, vérifie l'accessibilité du répertoire contenant le css incriminé

Commence par vérifié l'onglet réseau de l'outils de dev.
Lis la colonne état et en cliquant sur chaque ligne vérifie les entêtes et réponses

Posté le : 20/10/2023 00:31
Partager Twitter Partagez cette article sur GG+
Re: Pb affichage sur certaines plaformes ...
Régulier
Inscrit: 26/05/2005 12:43
Messages: 373
Merci pour tes recommandations.

Je vais commencer par le début. Pour éviter l'éventuel mélange, vaut il mieux que je retire le sous-domaine www (non utilisé pour le référencement) ?

Posté le : 20/10/2023 12:53
Partager Twitter Partagez cette article sur GG+
Re: Pb affichage sur certaines plaformes ...
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2837
certains navigateur, quand tu entre une URL dans la barre d'URL y ajoutent systématiquement le www. devant.
A mon avis, c'est ce qui déclenche ton erreur.

Pour être certains que cela ne posera plus de pbs avec le www est de mettre en place une redirection permanente de type 301 pour toutes les URL commençant par www.

Posté le : 20/10/2023 12:58
Partager Twitter Partagez cette article sur GG+
Re: Pb affichage sur certaines plaformes ...
Régulier
Inscrit: 26/05/2005 12:43
Messages: 373
Salut,

la redir www ne change rien,

Par contre, j'ai une piste intéressante : je constate ce problème uniquement sur le seul site que je n'ai pas encore passer en https !!!

Est-ce que cela pourrait être la cause ?

Posté le : 20/10/2023 16:21

G.
Partager Twitter Partagez cette article sur GG+
Re: Pb affichage sur certaines plaformes ...
Régulier
Inscrit: 26/05/2005 12:43
Messages: 373
RESOLU !!!


Tout fonctionne depuis que j'ai activé le mode httpS !!!

Je pense que c'est une information à faire passer ...


Posté le : 20/10/2023 19:05

G.
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

87 Personne(s) en ligne (69 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 87 | Plus ...