Fork me on GitHub




« 1 (2) 3 »


Re: Newbb 4.33 RC9
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3183
Sous Xoops 2.5.7 ce bloc fonctionne. Ce module est fait pour cette version, c'est écrit sur la page de téléchargement sous "Minimum Requis".

As-tu une erreur en mode "debug" ?

Citation :
vinyz a écrit :
Bah un truc que je trouve dommage, c'est que je suis revenu en 2.5.5 (car la 2.5.7 souffre trop de sa jeunesse).

Que reproches-tu précisément à Xoops 2.5.7 ?

Posté le : 30/08/2014 11:32

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Régulier
Inscrit: 27/03/2005 14:58
De Pen ar bed
Messages: 147
Voici que que j'ai en message :

Message(s): Use of undefined constant _MI_WFD_BNAME3 - assumed '_MI_WFD_BNAME3' dans le fichier /modules/wfdownloads/xoops_version.php - ligne 86
Avertissement(s): Smarty error: unable to read resource: "db:newbb_block_topic.tpl" dans le fichier /class/smarty/Smarty.class.php - ligne 1093
Avertissement(s): Smarty error: unable to read resource: "db:mylinks_block_new.tpl" dans le fichier /class/smarty/Smarty.class.php - ligne 1093
Avertissement(s): Smarty error: file:/themes/Xeatol_v3/xoscripts/breadcrumb.php is not readable dans le fichier /class/smarty/Smarty.class.php - ligne 1093
Avertissement(s): include(): Filename cannot be empty dans le fichier /class/smarty/Smarty.class.php - ligne 1923
Avertissement(s): include(): Failed opening '' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') dans le fichier /class/smarty/Smarty.class.php - ligne 1923


Comme ce sont des messages "smarty" et que c'est un truc de xoops que je n'ai jamais assimilé (les smarty pour moi sont encore des petits bonbons de couleurs), je n'arrive donc pas trop bien à saisir le pb.

Ma dernière expérience en 2.5.7 m'a un peu freinée, d'autant plus que certains modules ne fonctionnent plus sous 2.5.7 et je ne peux m'en passer. Ils restent fonctionnels sous 2.5.5 (wfdownloads par exemple, ou encore cshout)

Posté le : 30/08/2014 11:37

Les hommes naissent libres et égaux en droits. Ensuite, ils se mettent à boire !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3183
Concernant la dernière version de Newbb, un des changements apportés est le renommage de certains fichiers .html en .tpl, ainsi que la modification des fichiers qui y font appel. Tu peux le lire dans le "Changelog" décrit sur la page de téléchargement du module, par exemple.

Si tu souhaites rester sous Xoops 2.5.5, je te conseille d'installer la version précédente Newbb 4.33 RC7.

Posté le : 30/08/2014 11:44

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Régulier
Inscrit: 27/03/2005 14:58
De Pen ar bed
Messages: 147
Bon, j'ai pas trop compris pourquoi, mais c'est tombé en marche.

En effet, suis passé en 2.5.7 (osef, c'est une plateforme de test donc j'me défoule un peu) mais le comble, c'est que tout à l'air de fonctionner. Même une vieille version de wfdownloads ... là, j'y comprends plus rien car en prod j'ai oeuvré à l'identique et rien ne fonctionne. Je dois avoir une m.... dans mes fichiers de prod.

Bref, tout est bien qui fini bien (quoique je n'ai pas encore installé xoopsfaq et d'autres modules un peu vieillots).

Allez zou, un ptit tar gz de tout ça avant d'aller plus loin ^^


Encore merci !

Posté le : 30/08/2014 15:07

Les hommes naissent libres et égaux en droits. Ensuite, ils se mettent à boire !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3183
Il y avait peut-être encore des traces du cache.
Il faut aussi penser à mettre à jour le module Système à chaque changement, en plus de vider les caches de Xoops et de l'explorateur internet que tu utilises.

Posté le : 30/08/2014 15:28

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Team FrXoops
Inscrit: 12/08/2003 14:34
De Montpellier
Messages: 209
Citation :
slider84 a écrit :
On doit pouvoir le faire facilement avec une surcharge de template en utilisant comme condition la variable smarty {$xoops_usergroups}

Je n'en doute pas, mais l'idée serait de pouvoir activer ou désactiver ça dans l'admin, pour éviter le plus possible d'avoir à tenir un cahier avec la liste des hacks qu'on a apportés et devoir les refaire lors d'une mise à jour ^^

Posté le : 30/08/2014 15:31
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Admin Frxoops
Inscrit: 16/03/2009 16:40
De Tende (06)
Messages: 3183
Je vais soumettre l'idée mais si un développeur qui me lit peut le faire ça m'arrangerait car j'ai fait pas mal de demandes auprès de tous les développeurs étrangers pour d'autres modules et ils sont tous déjà bien occupés

Posté le : 30/08/2014 15:36

Open in new window

Xoopseuse Mai 2012 | Responsable équipe internationale | Recherche avancée en bas de page !
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Team FrXoops
Inscrit: 12/08/2003 14:34
De Montpellier
Messages: 209
Bonjour Vinyz,

je vais essayer de te renseigner sur tes erreurs :
Citation :
Message(s): Use of undefined constant _MI_WFD_BNAME3 - assumed '_MI_WFD_BNAME3' dans le fichier /modules/wfdownloads/xoops_version.php - ligne 86

Il manque la constante donnée dans le fichier concerné (un nom de bloc je pense vu le nom de la constante).
Citation :
Avertissement(s): Smarty error: unable to read resource: "db:newbb_block_topic.tpl" dans le fichier /class/smarty/Smarty.class.php - ligne 1093
Avertissement(s): Smarty error: unable to read resource: "db:mylinks_block_new.tpl" dans le fichier /class/smarty/Smarty.class.php - ligne 1093
Avertissement(s): Smarty error: file:/themes/Xeatol_v3/xoscripts/breadcrumb.php is not readable dans le fichier /class/smarty/Smarty.class.php - ligne 1093

Vérifie :
- l'existance de ces fichiers
- si ils existent
-> pour les fichier *.tpl : vérifie que tu n'as pas fichier.html au lieu de fichier.tpl
-> pour le fichier php : vérifie les droits sur ce fichier
Citation :
Avertissement(s): include(): Filename cannot be empty dans le fichier /class/smarty/Smarty.class.php - ligne 1923
Avertissement(s): include(): Failed opening '' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') dans le fichier /class/smarty/Smarty.class.php - ligne 1923

Là je ne vois pas trop. Peut-être lié aux erreurs précédentes.

Posté le : 30/08/2014 15:37
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Admin Frxoops
Inscrit: 04/03/2011 09:10
De Lot
Messages: 2638
Citation :

Je n'en doute pas, mais l'idée serait de pouvoir activer ou désactiver ça dans l'admin, pour éviter le plus possible d'avoir à tenir un cahier avec la liste des hacks qu'on a apportés et devoir les refaire lors d'une mise à jour ^^


Oui, mais après on tombe dans le paradoxe inverse, toute nouvelle option alourdit le code. Et le module finit par ressembler à une centrale nucléaire.
NewBB en est un bon exemple, il y a eu tellement de hack en tout genre rajoutés dans ce module qu'il est devenu complètement ingérable pour y effectuer une mise à jour.
Dès qu'on veut corriger une erreur, on en créé une nouvelle ailleurs.
Pour ma part, ma vision (et la politique que j'applique aux modules que je conçois) c'est :
- un module, une fonction
- L'ajout d'option dans le module doit uniquement servir à la majorité des utilisateurs du module ou corriger des failles.

Plus le module est propre et bien conçu, moins il y a de faille de sécurité potentiel et surtout moins de bug.
Et pour les hacks, je conseil toujours de les mettre à l'extérieur du script originel (dans un fichier à coté), bien sûr quand on le peut(mais là ce n'est pas forcément évident)

Posté le : 30/08/2014 15:47
Partager Twitter Partagez cette article sur GG+
Re: Newbb 4.33 RC9
Team FrXoops
Inscrit: 12/08/2003 14:34
De Montpellier
Messages: 209
Ca se tient.

Peut-être alors une politique de plugins ?

Genre un module qui fait ce qu'il faut comme il faut, et des plugins à côté ?

Posté le : 30/08/2014 16:41
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
« 1 (2) 3 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

18 Personne(s) en ligne (6 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 18 | Plus ...