Fork me on GitHub




(1) 2 3 4 »


Accès page admin en https
Aspirant
Inscrit: 14/12/2015 23:48
Messages: 57
Bonjour à toutes et à tous :)
Je suis sur Xoops 2.4.2 et j'ai essayé de mettre mon site en https, mais quand je souhaite allez sur la page admin, elle est servie en mode https et elle le contenu est tout désordonné et il n'est pas affiché correctement comme dans la version http simple !!
Quelqu'un saurait d'ou vient le problème et que puis-je faire pour remédier à cette situation ?
Merci bcp pour vos lumières :)

Posté le : 08/03 15:52
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Semi pro
Inscrit: 13/04/2007 20:36
Messages: 832
Bonjour Aminov

As-tu mis en https les liens dans le fichier theme.html
themes\nom de ton theme\theme.html

Posté le : 08/03 16:07

Une personne qui n'a jamais commis d'erreurs n'a jamais tenté d'innover. [Albert Einstein]
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Aspirant
Inscrit: 14/12/2015 23:48
Messages: 57
Bonjour Nendo :)
Merci bien pour votre réponse.
En fait le peu de liens qui existent sur mon fichier theme sont comme celui-là :
/nouvelles-publications.html
J'ai pas mis l'adresse du site au départ, donc pas de http non plus.
Cela explique-t-il quelque chose ?

Posté le : 08/03 16:27
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3771
Citation :
aminov a écrit :
Bonjour à toutes et à tous :)
Je suis sur Xoops 2.4.2 et j'ai essayé de mettre mon site en https,



NONNNNN

Tu DOIS mettre à jour ton XOOPS AVANT, mais vu la version TRES ANCIENNE, tu dois vérifier la compatibilité de tes modules, et éventuellement mettre à jours les modules que tu utilises.
il y a donc un travail à effectuer sur un site "bac à sable" (Ne jamais tenter une mise à jour depuis une version très ancienne en direct sur son site de production).

Il y a tellement de différence entre la 2.4.2 et la 2.5.11 que certaines fonctions n'étaient pas disponibles dans ta version historique.


Posté le : 08/03 20:08

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Aspirant
Inscrit: 14/12/2015 23:48
Messages: 57
J'ai pas de problème sur les pages accessibles aux utilisateurs. C'est juste les page admin ou il y a le problème. leur contenu s'affiche de manière désordonnée !
Moi ça me dérange pas de rester sur Xoops 2.4.2 vu que mon partenaire qui s'occupait des aspects techniques a abandonné le site il y a bien longtemps :(
Pas de solution tout en restant sur Xoops 2.4.2 ?

Posté le : 08/03 20:14
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Admin Frxoops
Inscrit: 04/02/2003 06:41
Messages: 800
Dans ce cas, regarde ce que te dit la console sur Chrome par exemple : Ctrl + maj + i

Il y a sans doute des appels vers des fichiers non sécurisés, en http au lieu de https, que tu devras corriger.

Posté le : 09/03 09:17

Quand tu montres la lune du doigt, l'imbécile regarde le doigt.
Infos sur TSO et tutos PC sur Tutoriaux PC
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Aspirant
Inscrit: 14/12/2015 23:48
Messages: 57
Bonjour Babouille,
Merci bcp pour tes lumières.
Voici ce que la console de Chrome dit :
------------------------------
- 8Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure stylesheet '<URL>'. This request has been blocked; the content must be served over HTTPS.
- 7Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure script '<URL>'. This request has been blocked; the content must be served over HTTPS.
- 45Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure image '<URL>'. This content should also be served over HTTPS.
- Uncaught TypeError: Cannot read property 'dd' of undefined at admin.php:293
------------------------------------------
- Dans le premier cas, le problème concerne les fichiers css qui ne sont pas servis en https, comme "/modules/system/class/gui/oxygen/css/style.css"
- Dans le deuxième cas c'est des fichiers javascript comme "/include/xoops.js"
- Dans le 3eme cas c'est des fichiers images comme "/modules/system/class/gui/oxygen/img/home.png"
Comment puis-je corriger cela ?

Posté le : 09/03 11:26
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Admin Frxoops
Inscrit: 16/05/2003 18:10
De Rhone-Alpes
Messages: 3771
Bien vu de la part de Babouille !

Oui, le https a horreur des mix.

Il faut dégager tout les mix...
En d'autres termes, tout les appels à des ressources non https, ou sinon, rendre ces ressources sécurisées.

Et un peu de lecture : https://www.webrankinfo.com/dossiers/t ... es/redirection-http-https

Posté le : 09/03 12:25

Open in new window
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Aspirant
Inscrit: 14/12/2015 23:48
Messages: 57
Excusez mes compétences limitées à ce sujet, et je fais tout pour éviter la hard task :)
Aurait-il par exemple un moyen de continuer à consulter les pages admin en mode http malgré la redirection https sur mon fichier htaccess ?
Car le problème se pose uniquement quand j'essaye d'aller sur ma console d’administration.

Posté le : 09/03 12:53
Partager Twitter Partagez cette article sur GG+
Re: Accès page admin en https
Aspirant
Inscrit: 14/12/2015 23:48
Messages: 57
Il y a vraiment personne qui passe par ici pour nous proposer une petite astuce qui peut débloquer temporairement le problème !

Posté le : 09/03 22:44
Partager Twitter Partagez cette article sur GG+

 Haut   Précédent   Suivant
(1) 2 3 4 »




Propulsé avec XOOPS | Graphisme adapté par Tatane, Grosdunord, Montuy337513

27 Personne(s) en ligne (8 Personne(s) connectée(s) sur Forum) | Utilisateur(s): 0 | Invité(s): 27 | Plus ...